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Conventions Used in This Manual

In describing the product, this manual uses the icons and conventions listed below.

	 Handling Precautions:
Handling Precautions indicate items that the user should pay attention to when handling 
the SLP-NX.

	 Note: Notes indicate information that might benefit the user.

This indicates the item or page that the user is requested to refer to.

[1], [2], [3]: Numbers within parentheses indicate steps in a sequence or parts of an explanation.

[Online (O)], [XX]: Square brackets indicate a window name, menu, or button shown on the PC screen.

[Ctrl] + [N]: Refers to the operation of pressing the [N] key while holding down the [Ctrl] key.

Check the following items when removing the SLP-NX (SLP-NX-J70 or SLP-NX-J71) from its package:
	 1.	 Check the model number to make sure you received the correct product.
	 2.	 Check for any obvious damage.
	 3.	� Check the contents of the package against the packing list to make sure that all items are included.

Handle the SLP-NX and its accessories with care to prevent damage or loss of parts.

If there is some problem with your order, please contact your dealer immediately.

Name Model or Document No. Qty Remarks

Smart Loader Package
SLP-NX installation CD

- 2 Japanese and English versions.

USB loader cable - 1 For the SLP-NX-J70 or  
SLP-NX-J70PRO only.

Installation Guide CP-UM-5559JE 1 Please read prior to installing.

User’s Manual CP-UM-5636E 1 This manual. 
This manual is included in the Smart 
Loader Package SLP-NX installation CD as 
a PDF file.

Software License Agreement CP-UM-5603JE 1 Please read the software license 
agreement carefully before your 
installation. 

USB protection key - 1 SLP-NX-J70PRO or SLP-NX-J71PRO only.

Software license Agreement

Installation Guide
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A total of 13 different manuals are available for the Network Instrumentation Module. Read them as necessary for 
your specific requirements. If a manual you require is not available, contact the azbil Group or its dealer.

Network Instrumentation Module Smart Loader Package SLP-NX User’s Manual 
	 Manual No. CP-UM-5636E

This Manual.
This manual is included in the SLP-NX Smart Loader Package as a PDF file.
Personnel in charge of design or configuration of a system using Network 
Instrumentation Modules should read this manual thoroughly. The manual describes 
the software that is used to configure Network Instrumentation Modules with a com-
puter. It covers the installation of the software on a personal computer, the operation of 
the PC, various functions, and setup procedures.

Network Instrumentation Module 
NX-D15/25/35 Controller Module User’s Manual for Installation 
	 Manual No. CP-UM-5561JE

This manual is supplied with the NX-D15/25/35. Personnel in charge of design and/or 
manufacture of a system using the NX-D15/25/35 should thoroughly read this manual. It 
describes safety precautions, installation, wiring, and primary specifications.
For further information about operation, refer to the user’s manual, Abridged Version.

Network Instrumentation Module Communication Box NX-CB1 User's 
Manual for Installation 	 Manual No. CP-UM-5558JE

This manual is supplied with the NX-CB1. Personnel in charge of design and/or 
manufacture of a system using the NX-CB1 should read this manual thoroughly. 
It describes safety precautions, installation, wiring, and primary specifications.

Network Instrumentation Module NX-CB2 Communication Box User's 
Manual for Installation 
	 Manual No. CP-UM-5715JE

This manual is supplied with the NX-CB2. Personnel in charge of design and/or 
manufacture of a system using the NX-CB2 should read this manual thoroughly. 
It describes safety precautions, installation, wiring, and primary specifications.

Network Instrumentation Module NX-DX1 Digital Input Module 
NX-DX2 Pulse Input Module 
User's Manual for Installation	 Manual No. CP-UM-5560JE

This manual is supplied with the NX-DX1/DX2.
Personnel in charge of design and/or manufacture of a system using the NX-DX1/
DX2 should read this manual thoroughly. It describes safety precautions, installa-
tion, wiring, and primary specifications.

The Role of This Manual
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Network Instrumentation Module NX-S11/12/21 Supervisor Modules  
User’s Manual for Installation 	 Manual No. CP-UM-5557JE

This manual is supplied with the NX-S11/12/21.
Personnel in charge of design and/or manufacture of a system using the 
NX-S11/12/21 should thoroughly read this manual. It describes safety precau-
tions, installation, wiring, and primary specifications.

Network Instrument Module NX-DY1/2 Digital Output Module  
User’s Manual for Installation 
	 Manual No. CP-UM-5564JE

This manual is supplied with the NX-DY1/2.
Personnel in charge of design and/or manufacture of a system using the 
NX-DY1/2 must thoroughly read this manual. It describes safety precautions, 
installation, wiring, and primary specifications.

Network Instrumentation Module Controller module NX-D15/25/35 
User's Manual of Function	 Manual No. CP-SP-1308E

Personnel who are using the NX-D15/25 for the first time or who are in charge 
of hardware design and/or maintenance of a control panel containing the 
NX-D15/25 should read this manual thoroughly. This manual describes the hard-
ware, surveys the NX-D15/25 and other products used with it, explains installa-
tion, wiring, and troubleshooting, and gives hardware specifications.

Network Instrumentation Module Digital Input/Pulse Input Module  
NX-DX1/DX2 User’s Manual of Functions	 Manual No. CP-SP-1323E

Personnel who are using the NX-DX1/DX2 for the first time or who are in charge 
of hardware design and/or maintenance of a control panel containing the 
NX-DX1/DX2 should read this manual thoroughly. This manual describes the 
hardware, surveys the NX-DX1/DX2 and other products used with it, explains 
installation, wiring, and troubleshooting, and gives hardware specifications.

Network Instrumentation Module NX-S11/12/21 Supervisor Module 
User’s Manual Functions	 Manual No. CP-SP-1324E

Personnel who are using the NX-S11/12/21 for the first time or who are in charge 
of hardware design and/or maintenance of a control panel containing  the 
NX-S11/12/21 should read this manual thoroughly.
This manual describes the hardware, surveys the NX-S11/12/21 and other prod-
ucts used with it, explains installation, wiring, and troubleshooting, and gives 
hardware specifications.
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Network Instrumentation Module User’s Manual 
Network Design Version 
	 Manual No. CP-SP-1313E

Personnel who are in charge of design of a network using the Network 
Instrumentation Module should read this manual thoroughly. It describes how to 
design a network and gives examples.

Network Instrumentation Module 
SLP-NX Smart Loader Package Installation Guide 
	 Manual No. CP-UM-5559JE

This manual is supplied with the SLP-NX Smart Loader Package and describes 
installation of the software on a personal computer.

Network Instrument Module NX-DY1/2 Digital Output Module  
User's Manual for Function	 Manual No. CP-SP-1345E

Personnel who are using the NX-DY1/2 for the first time or who are in charge of 
hardware design and/or maintenance of a control panel containing the NX-DY1/2 
should read this manual thoroughly.
This manual describes the hardware, surveys the NX-DY1/2 and other products 
used with it, explains installation, wiring, and troubleshooting, and gives hard-
ware specifications.
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Organization of This User's Manual

This manual is organized as follows:

Chapter 1.	 INTRODUCTION
Be sure to read this chapter before you start using the loader. 
This chapter describes the required operating environment for personal computers, 
explains how to install the package, and briefly introduces the functions.

Chapter 2.	 STARTING AND QUITTING THE LOADER
This chapter describes how to start and quit the loader.

Chapter 3.	 LOADER WINDOW LAYOUT
This chapter explains the configuration of windows for this loader and the roles of 
each window.

Chapter 4.	 WORK FLOW
This chapter explains how to set up parameters in the modules and the work flow 
for operating modules.

Chapter 5.	 ACTUAL MODULE COMMUNICATION SETTINGS
This chapter explains the address settings and communication settings required for 
module communications.

Chapter 6.	 PARAMETER SETTING
This chapter explains how to set up parameters for operating modules.

Chapter 7.	 UNIVERSAL MONITOR
This chapter explains how to change settings and describes the screens for 
monitoring the operation status.

Chapter 8.	 PID Simulator
This chapter explains the PID Simulator software and tells how to use it to adjust 
the PID values.

Chapter 9.	 RESTRICTIONS AND IMPORTANT NOTES ON USE
This chapter explains restrictions and important points for use.

Appendix -1	EXPLANATION OF TERMINOLOGY

Appendix -2	VERSION HISTORY

Appendix -3	Loader Support Corresponding to Module Versions
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Chapter 1.	 INTRODUCTION
1  -  1	 Overview

The Smart Loader Package: SLP-NX (called the “loader” from here on) is a software package for monitoring the 
settings and operational status of all Network Instrumentation Modules (called “modules” from here on).

■■ Loader Functions
This loader mainly performs the following operations for modules via Ethernet or 
when connected to a loader jack.
•	 Confirms/sets communication settings such as IP addresses.  

(With separate or combined modules. Combined operation is only done via 
Ethernet.)

•	 Reads/writes parameters 
(With separate or combined modules. Combined operation is only done via 
Ethernet.)

•	 Monitors online data, changes parameters, and samples data (with separate or 
combined modules. Combined operation is only done via Ethernet.)
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The following system environment is required to use this loader.

■■ System Environment
Type Description
Hardware Computer PC/AT compatibles with Pentium chip or higher 

Recommended: 1.5 GHz or higher Core 2, minimum 1 GHz
Operating system Windows 7 Professional or Home Premium 32/64-bit SP1(English) 

Windows 8.1/8.1 Professional 32/64-bit (except RT) 
Windows 10/10 Professional 32/64bit

Memory Recommended: 4 GB or more, minimum 2 GB
Hard disk drive Recommended free space: 60 GB or more, minimum 40 GB
Display 1024 × 768 pixels or more, 16-bit or higher color recommended
CD-ROM drive One drive
Ethernet port 1 port or more (if modules are connected via an Ethernet cable). 

Note: Do not use USB Ethernet adapter.
USB port 1 port or more (if the dedicated cable for module connection and PID Simulator 

are used at the same time, each of them requires one port) 
Note: The above applies only if the USB loader cable or USB protection key is used.

Pointing device Windows-compatible mouse or equivalent device
Other .NET Framework 4.6.2

Note. .‌�NET Framework 4.6.2 is pre-installed on Windows 10 version 1607. Windows 10 RTM and 
Windows 
10 version 1511 must be upgraded to version 1607 using Windows Update.

SQL Server 2014 Express Local DB SP2 *1
Note: The above software is installed if needed.

 Handling Precautions
*1  �The loader uses SQL Server 2014 Express Local DB SP2.  

     Successful operation of the product cannot be guaranteed if Microsoft 
SQL Server 2000, 2005, 2008, 2008R2, 2012, 2016 or 2018 is used or will be 
used in the future. 
      It is recommended that you use a separate PC if you need to run older 
or newer versions of Microsoft SQL Server alongside Microsoft SQL Server 
2014.

*  �Select [Control Panel] → [Regional Settings] → [Number] → [Decimal 
symbol] to check that "." is set. If any other symbol is set, the SLP-NX will not 
work properly.
Example: 
For Windows 7/8.1/10, go to [Control Panel] → [Clock, Language, and 
Region] → [Region and Language] → [Formats] → [Additional settings...] 
→ [Numbers] → [Decimal symbol].

*  �For Windows 8.1/8.1 Pro/10/10 Pro, use a REV.05/REV.06 or later USB loader 
cable.

1  -  2	 System Requirements
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■■ Connection to Modules

 Handling Precautions
•	 Multiple SLP-NXs cannot be connected to a single module at the same time.

●● Connection via dedicated cable
This connection method is limited to projects consisting of a single module.

Module

USB loader 
cable

PC
NX-D25N

LOCK

	 Handling Precautions

•	 In the case of multi-loop cooperative control using the supervisor module, 
multiple module settings are configured at the same time. Therefore this 
connection method should not be used.

●● Ethernet Connection 1  Connection Via Communication Adapter
Modules

Ethernet cable

PC Communication 
adapter

NX-D25N

LOCK

NX-D25N

LOCK

NX-D25N

LOCK

C
A

	 Handling Precautions

•	 This connection is allowed only with non-ring communication modules.

●● Ethernet Connection 2  Connection Via Communication Box

Modules
(All modules have the 
same connection system.)

Ethernet cable

PC Communication box

NX-D25N

LOCK

NX-D25N

LOCK

NX-CB1N

4

3

2

1

NX-D25N

LOCK

	� Handling Precautions

•	 �Connection is allowed with both ring and non-ring communications. 
However, make sure all modules are of the same type.

•	 Connection is still allowed when a general-purpose switching hub is 
located between the PC and communication box. 

•	 Use a UTP cable (4P) Cat 5e or higher (straight), (ANSI/TIA/EIA-568-B) for 
the Ethernet cable. 

	 Note
 2-5 "Configuration With External Devices ■ SLP-NX" (page 2-18) in Network 

Instrumentation Module User’s Manual for Network Design (CP-SP-1313E)  
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1  - 3	 Installing the USB Loader Cable Device Driver

A device driver must be installed before using the USB loader cable.
Follow the procedure below to install the device driver.

■■ Installing the Device Driver

 Handling Precautions
•	 Be sure to follow the procedure below when installing the device driver. 

The USB cable may not be recognized if the procedure is not followed. If the 
cable is not recognized, uninstall the driver and then install it again.

•	 Administrator privileges on the computer are required for device driver 
installation. Installation should be done by the administrator or by a user who 
belongs to the administrator group. 
The USB loader cable is compatible with Windows 7/8.1 (32-bit and 64-bit 
versions).

•	 If there are multiple USB ports, connect the USB loader cable to the same 
port every time. If it is connected to a different port, driver installation may be 
required again.

1.	 Install the USB loader cable driver.

>>	Open the loader destination folder “USBLoaderCable” in Windows Explorer. 
If the installation destination was not changed, the folder is located as follows.

•	 For Windows 7/8.1 (32-bit version) 
C:\Program Files\SLP\SLP-NX (enu)\Drivers\USBLoaderCable

•	 For Windows 7/8.1 (64-bit version) 
C:\Program Files(x86)\SLP\SLP-NX (enu)\Drivers\USBLoaderCable

[1]	 Double-click [drvsetup.exe]. 
>> The following screen appears:
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[2]	 Click the [Yes] button. 
>> Installation preparation begins, and the following screen appears:

[3]	 When installation preparation is complete, the following screen appears:

[4]	 Click the [Next >] button. 
>> The following screen appears:

[5]	 Select a seal of your loader cable.
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Click the [Next >] button.

[6]	 Click the [Install] button. 
>> This starts the loader cable driver installation.
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 Handling Precautions

•	 If the following screen is displayed on Windows 7/8.1, click the [Install] button.

[7]	 Click the [Next >] button.

>>	The following screen appears:

[8]	 If you agree to the software license agreement and wish to install the 
program, select the [AGREE] button, then click the [Next >] button.
>>�The installation program then starts up, and after it is completed, the 

following screen appears:

Click the [Finish] button.
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[9]	 Click the [Finish] button to complete installation.

2.	 Insert the USB loader cable into the USB port.

>>	When Windows recognizes the USB cable, the notification shown below 
appears on the task tray and the driver installation wizard appears.

3.	 Install the device driver.

[1]	 Usually, when Windows recognizes the USB loader cable, the window 
shown below appears. (Display of the window depends on the Windows 
environment. If the window is not shown, skip to step 4.) 
Select [No, not this time] and click the [Next >] button.

[2]	 For the retrieval location of the device driver to be installed, select [Install the 
software automatically (Recommended)] and click the [Next >] button.
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>>	Retrieval of the device driver starts.

>>	When the device driver is found, the following window appears:

[3]	 Click the [Continue Anyway] button.

>>	Installation of the device driver starts

>>	When the device driver installation is complete, the following window 
appears:

Chapter 1. INTRODUCTION

1-9



[4]	 Click the [Finish] button.�

>>	When the installation is completed, the notification shown below appears 
on the task tray, and Windows now correctly recognizes the USB loader 
cable.

[5]	 Select [Control Panel] → [System] → [Hardware] → [Device Manager], and 
find the port number for the Yamatake USB Loader Comm.Port from [Ports 
(COM & LPT)].

[6]	 Start up the loader, then from the Project window’s menu bar, select [Online] 
→ [Communications Path] to open the [Communications path] dialog box, 
and select [Loader jack]. 
Click [Advanced] to open the [Serial Communication] dialog box, confirm 
that the communication port checked in [5] is set, and click [OK].

■■ Uninstalling the Device Driver

 Handling Precautions
•	 Removing the driver requires restarting the computer. Close other 

applications first, and then uninstall the driver.
•	 To uninstall the driver, administrator privileges are required on the computer. 

Installation should be done by the administrator or by a user who belongs to 
the administrator group.

1.	 Execute the driver removal program.

[1]	 Open [Control Panel]. Click [Programs and Features] and select [Azbil 
Loader Cable Driver]. Then click [Uninstall].

[2]	 Click the [Yes] button.

[3]	 Restart the computer.
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1  -  4	 Installing the USB Protection Key Driver
To use PID Simulator with the SLP-NX professional version, it is necessary to install the device driver.
Follow the procedure below to install the device driver.

■■ Installing the Device Driver

 Handling Precautions
•	 Be sure to follow the procedure below when installing the device driver. 

The USB protection key may not be recognized if the procedure is not 
properly followed. 
If the key is not recognized, reinstall the driver, or uninstall it and then reinstall 
it.

•	 Administrator privileges on the computer are required for device driver 
installation. Installation should be done by the administrator or by a user who 
belongs to the administrator group. 
The USB loader cable is compatible with Windows 7/8.1 (32-bit and 64-bit 
versions).

•	 If there are multiple USB ports, connect the USB Protection Key to the same 
port every time. If it is connected to a different port, driver installation may be 
required again.

1.	 Install the USB protection key driver.

>>	Open the loader destination folder “Sentinel” in Windows Explorer.
If the installation destination was not changed, the folder is located in  
C:\Program Files\SLP\SLP-NX (enu)\Drivers\Sentinel.
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[1]	 Double-click [Sentinel System Driver Installer 7.5.1.exe].

>>	The following screen appears.

[2]	 Click the [Next >] button.

>>	The following screen appears.

[3]	 If you accept the software license agreement and wish to install the software, 
select [I accept the terms in the license agreement] and click the [Next >] 
button.

>>	The following screen appears.

Chapter 1. INTRODUCTION

1-12



[4]	 Click the [Next >] button.

>>	The following screen appears.

[5]	 Click the [Install] button.

>>	Installation of the USB protection key driver begins.

>>	When installation is complete, the following screen is displayed.

[6]	 Click the [Finish] button to complete installation.
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2.	 Insert the USB protection key into a USB port.

>>	When Windows recognizes the USB protection key, the following notification 
appears on the task tray and the key can be used.

■■ Uninstalling the device driver

 Handling Precautions
•	 After uninstalling the driver, reboot the computer. 

Close other applications before uninstalling the driver.
•	 To uninstall the driver, administrator privileges on the computer are required. 

Removal of the driver should be done by the administrator or by a user who 
belongs to the administrator group.

[1]	 Open [Control Panel]. Click [Add or Remove Programs] and select [Sentinel 
System Driver Installer 7.5.1] and then click the [Delete] button.

[2]	 Click the [Yes] button.

[3]	 Reboot the computer.
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Chapter 2.	 STARTING AND QUITTING THE LOADER
2  -  1	 Starting the Loader

Select [SLP-NX] from the Start Menu.

>>	Once started up, a Project window is displayed as shown below.

 Handling Precautions
•	 Administrator privileges on the computer are required for operating the 

loader. Installation should be done by the administrator or by a user who 
belongs to the administrator group.

	 Note
•	 A network profile function is provided that allows you to temporarily change 

the network settings of the PC to which the module will be connected, but only 
while the loader is starting up. 
■ Network Profile (page 5-31), or 
■ How to Select [Auto configuration from actual module] to Create a Project 
- Step [4] (page 6-8), if a network profile to be used for the loader is already 
created, the following dialog box will appear at startup:
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	 In this case, use the Radio button to select [Original profile] (current network 
settings), or select the name of the network profile used when previously 
running the loader. 
When you select a network profile name, change the PC’s network settings with 
the values for that network profile and then continue starting up the loader. 
After the loader has started up, change the network profile with the same 
procedure used for ■ Network Profile (page 5-31).

•	 If the loader is exited abnormally during project editing, the following message 
box will be displayed the next time the loader is started up. 
Click the [Yes] button, and the project will open.

	 Handling Precautions

•	 If the loader is exited abnormally while running, the PC’s network settings 
will remain as they were while the loader was running. 
Start up the loader, open the Network Profile window, then take 
appropriate action as described in ■ Network Profile (page 5-31). 
You can return to the network settings used before the loader’s previous 
startup.
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2  -  2	 Quitting the Loader

To quit the loader, select [File] from the Project window’s menu bar, then select [Exit],

	 Note
•	 If the computer’s network settings were changed with the network profile 

function, they will return to normal when you quit the loader.
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Chapter 3.	 LOADER WINDOW LAYOUT
3  -  1	 The Layout and Role of Windows

■■ The Layout and Role of Loader Windows
The loader has the following basic windows:
•	 Project window
•	 [Actual module configuration] window
•	 [Universal monitor] window
Explanations for each of these windows are shown below.

Name Role Window Image

Project window This window is used to set the 
parameters of the modules required for 
system operation.

 �This chapter and Chapter 6.	
PARAMETER SETTINGS

[Actual module configuration] window This window is used to configure the 
settings for modules required for basic 
communication with the outside of 
them.

 �n Actual Module Configuration 
Tree Levels (P. 5-4)

[Universal monitor] window This window is used to monitor module 
operations.
It enables you to monitor multiple 
module operations at once.

 �7  -  3	 Universal Monitor Window 
(P. 7-3)
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■■ Project Window Layout

Title Bar

Project Tree Contents Area

Menu Bar
Tool Bar

Status Bar

●● Title Bar
The opened project name, loader name and version are displayed here.

●● Menu Bar
Used to select or run various operations. 
Available operations vary depending on what is displayed in the project tree and 
contents area.

●● Tool Bar
Frequently used operations from among menu items are available as buttons on the 
tool bar.

●● Project Tree
Items to be managed in projects are displayed in a hierarchical structure. 
Click on an item to select it, and its corresponding setup screen will be displayed in 
the contents area.

 ■ Project Tree Levels (next page)

●● Contents Area
A setup screen is displayed here for items selected from the project tree.

●● Status Bar
High-level communication addresses, setting ranges, etc. are displayed here for 
selected parameters.
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■■ Project Tree Levels
The project tree hierarchy is constructed as follows.

Workgroup View

Project View

Module Configuration View

Parameter Bank View

Mapping View

Individual Mapping Name View

 page 3-3

 page 3-4

 page 3-5  page 3-7

 page 3-6  page 3-8

The following explains what is displayed in the contents area when you select each 
of these levels from the project tree.

●● Project View

Project Name Comments

[Edit] Button
[Add] Button
[Delete] Button

[Project] is displayed at the top level of the project tree.
When you select [Project] from the project tree, a project view is opened. 
Workgroups can be added or deleted in the contents area.
•	 [Project Name] 

Sets the project’s name.
•	 [Comments] 

Defines comments.
•	 [Edit] button 

The applicable workgroup in the project tree is selected.
•	 [Add] button 

Adds a workgroup.
•	 [Delete] button 

Deletes a workgroup.
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 Handling Precautions

•	 For project names, tag names, etc., use alphanumeric character strings 
only. If Unicode strings or the like are used, they may be garbled during 
CSV output, etc.

●● Workgroup View

Workgroup Name Comments

Operation List

The [Workgroup] view is one level below the [Project] view.
In the [Workgroup] view, you define a cluster of methods, consisting of more than 
one module.
[Operation list] in the contents area contains the following items for the entire 
workgroup:
•	 [1: Module definition] 

When you click this, the Module Configuration view is displayed.
•	 [2: Module mapping] 

When you click this, the Mapping view is displayed.
•	 [3: Parameter writing] 

This allows you to write all parameters onto the module.
•	 [4: Monitor] 

This allows you to initiate the Universal Monitor.
•	 [5: Parameter reading] 

This allows you to read all parameters from the module.
For each workgroup, [Workgroup name] and [Comments] can be defined.
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●● Module Configuration View

Type

[Down] Button

[Add a copy] Button
[Delete] Button
[Up] Button

[Add] Button

[Edit] Button

[Initialize] Button

Name Model No.

[Set model number] Button

[Module configuration] and [Mapping] views are one level below the [Workgroup]
view.
When [Module configuration] is selected in the project tree, you can define the 
configuration of modules belonging to the workgroup in the contents area.
When an actual module is used, selecting [Automatic configuration from actual 
module] in the [Create new project] dialog box allows you to automatically define 
the module configuration, so you don’t have to do it manually. 
The following settings can be made in the [Module configuration] view:
•	 [Add] button 

Adds a module.
•	 [Add a copy] button 

Adds a module with the parameter settings of any defined module.
•	 [Delete] button 

Deletes a module.
•	 [Up] button 

Moves the definitions of the selected module up one level in the list.
•	 [Down] button 

Moves the definitions of the selected module down one level in the list.
•	 [Edit] button 

Moves to the Parameter Bank view for the module selected in the project tree.
•	 [Set model number] button 

Displays the [Module model number setting] dialog box for the selected module.
•	 [Initialize] button 

Restores the initial parameters of the selected module.
•	 [Type] 

Defines the module’s type (typical model number).
•	 [Name] 

Defines the module’s name.
•	 [Model No.] 

In this box, you enter the module’s model number manually.

Chapter 3. LOADER WINDOW LAYOUT

3-5



●● Parameter Bank View

Editor Grid

The Parameter Bank view is one level below the [Module configuration] view. 
The Parameter Bank view has categories for each module on the tree, which are 
divided into levels. 
Refer to each module’s manual for the meaning and operation of each parameter.
•	 Editor Grid 

In this area, you can set the values of parameters belonging to the Parameter 
Bank.
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●● Mapping View

[Add] Button

[Delete] Button

[Edit] Button
[Set communication]
Button

[Module configuration] and [Mapping] views are one level below the [Workgroup]
view.
When [Mapping] is selected in the project tree, the following settings can be made 
in the contents area.
•	 [Add] button 

Adds mapping to each module and actual module belonging to a workgroup.
•	 [Delete] button 

Deletes mapping from each module belonging to a workgroup, to an actual 
module.

•	 [Edit] button 
Moves to the Individual Mapping Name view for the selected mapping.

•	 [Set communication] button 
This allows you to configure communication settings that are common to all 
modules within a workgroup, and RS-485 communication settings for each 
module.

•	 [Up] [Down] buttons are unsupported.
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●● Individual Mapping Name View

[Acquisition of actual module 
configuration] Button

[All unmap] Button

[Set communication] Button

[Automatic numbering] Button

Workgroup ID
Node ID

IP Address
Mapping Name

The Individual Mapping Name view is one level below the [Mapping] view. When 
an Individual Mapping Name is selected in the project tree, you can move the 
mapping from each module to an actual module in the contents area.
•	 [IP address], [Node ID], [Workgroup ID] 

In each of these boxes you can set a value manually.
•	 [Mapping name] 

You can change the name of a mapping.
•	 [Acquisition of actual module configuration] button 

Used to map a scanned module. 
The [Actual module configuration] window is displayed.

•	 [Set communication] button 
The [Communication settings (module)] dialog box is displayed.

•	 [All unmap] button 
Unmaps the modules. 
Module illustrations are grayed out in the Actual Module Configuration contents 
area.

•	 [Automatic numbering] button 
Numbers all IP address and node IDs.

	 Handling Precautions
•	 To change the IP address, node ID or workgroup ID of a module that is using 

data transfer function between modules or multi-loop cooperative control,

 ■ Changing the IP Address, etc. of a Module That Is Using Data Transfer 
Function between Modules or Multi-Loop Cooperative Control (P. 9-4).

•	 Do not add leading zeroes to IP addresses.
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■■ Project Window - Menu Configuration List
Menu Submenu 1 Submenu 2 Description Shortcut Keys Remarks

File New — Creates a new project.
(Offline, from Actual Module 
Configuration)

[Ctrl + [N]

Open — Opens the project. [Ctrl] + [O]

Save — Overwrite saves the project. [Ctrl] + [S] When the project is open.

Save as — Saves the project with a different name. —

CSV output — Outputs parameter settings as a CSV 
file.

—

Exit — Exits the loader. — If the Universal Monitor is 
running, it will also exit.

Edit Cut — Cuts data. [Ctrl] + [X] Enabled when data that 
can be cut is selected.

Copy — Copies data. [Ctrl] + [C] Enabled when data that 
can be copied is selected.

Paste — Pastes data. [Ctrl] + [V] Enabled when pastable 
data has been cut or 
copied.

Workgroup 
independent mode

— Switches to Workgroup independent 
mode.

— Unsupported

Data check — Checks parameter settings. —

Display [Logical 
operation 
definition] window

— Displays the [Logical Operation 
Definition] window.

—  ■ Logical Operation 
Display (P. 6-34).

Online Actual module 
configuration

— [Displays the [Actual Module 
Configuration] window.

—

Write Parameters — Writes parameters to a module. — Writes the target selected 
on the tree.

 6  -  5	 Writing 
Parameters (P. 6-46).

Monitor — Initiates the Universal Monitor. —  6  -  6	 Monitoring 
Module Operations 
(P. 6-51) and Chapter 7.	
UNIVERSAL MONITOR.

Read Parameters — Reads parameters from a module. — Reads to the target 
selected on the tree.

 6  -  7	 Reading 
Parameters (P. 6-56).

Communications 
path

— Changes communication path from PC 
to module.

—  ■ Communication Path 
(P. 5-29).

Network Profile — Switches network settings such as 
computer’s IP address.

—  ■ Network Profile 
(P. 5-31).

Communications 
options

— Loader communication time out 
settings.

—  ■ Communications 
Options (P. 5-37).

Compare module 
versions

— Compares module versions between 
the project and the actual module.

—  ■ Compare module 
versions (P. 6-59).
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Menu Submenu 1 Submenu 2 Description Shortcut Keys Remarks

View Go Back Moves one position back on the project 
tree.

[Alt] + Left When the project is open.

Forward Moves one position forward on the 
project tree. 

[Alt] + Right

Up Moves one level up on the project tree.

Home Moves to the workgroup level 
belonging to the current project tree 
position.

[Alt] + [home]

Display line graph — Displays line table as a graph. —  ■ Line Graph Display 
(P. 6-35).

Display the list 
of data transfer 
between modules

— Displays the [List for data transfer 
between modules] window.

—  ■ Display the List of 
Data Transfer between 
Modules (P. 6-30).

Set user level — Changes the parameter user level. —  ■ User Levels (P. 6-19).

Help Help — Displays the online help. — Unsupported

About SLP-NX — Displays version and license 
information.

—

■■ Tool Bar
Icon Name Icon Function Remarks

Back Moves one position back on the project tree. When the project is open the project 
tree.

Next Moves one position forward of the project 
tree.

Up Moves one level up the project tree.

Home Moves to the workgroup level belonging  
to the current project tree position.

Create Creates a new project.
(Offline, from Actual Module Configuration)

Open Opens the project.

Save Overwrite saves the project. When the project is open.

Expand Expands the project tree. When the project is open.

[Actual module configuration] 
window

Displays the [Actual Module Configuration] 
window.

Read

 
*

Reads parameters from a module. Reads from a device selected on the 
tree.  6  -  7	 Reading Parameters 
(P. 6-56).

Write
 
* Writes parameters to a module. Writes to a device selected on the tree. 

 6  -  5	 Writing Parameters (P. 6-46).

Monitor Initiates the Universal Monitor.  6  -  6	 Monitoring Module 
Operations (P. 6-51).

*	 If working via the USB loader cable,  (Read)  (Write) icons are displayed. 
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■■ Version Information
Select [Help] → [About SLP-NX] from the Project window’s menu bar.

>>	The following version and license information is displayed for this loader.
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Chapter 4.	 WORK FLOW
4  -  1	 General Work Flow

This section explains the basic procedures to set up parameters and actual module communication settings for 
modules to operate.

Operating window Operation Reference page

1. Enable the actual module for 
    communication.

4. Confirm the operation of the module.

5. Confirm and save the settings to 
    the module.

2. Determine the configuration of the 
    processing module.

3. Set the parameters and let the module 
    go into operation.

Mainly the [Actual module 
configuration] window

Prepare the actual module and 
configure the actual module 
communication settings.

5  -  2	 Defining IP Address and Node 
Address (P. 5-7)

5  -  3	 Communication Settings 
(P. 5-12)

[Project] window Create the module configuration 
offline.
OR
Create the module configuration 
online.

6  -  1	 Creating a Project (P. 6-1)

6  -  2	 Defining Module Configuration 
(P. 6-11)

[Project] window Edit the parameters.

Specify the target module.

Write the parameters.

6  -  3	 Editing Parameters (P. 6-16)

6  -  4	 Mapping (P. 6-38)

6  -  5	 Writing Parameters (P. 6-46)

[Universal monitor] window Confirm the operation on the 
Universal monitor.

6  -  6	 Monitoring Module Operations 
(P. 6-51)

[Project] window Read the parameters from the 
module.

Output the settings in CSV format.

Save the project.

6  -  7	 Reading Parameters (P. 6-56)

6  -  11	 Output to CSV File (P. 6-69)

6  -  9	 Saving a Project (P. 6-65)

Open the saved project. 6  -  10	 Opening a Project (P. 6-67)
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4  -  2	 When There is Any Available Module

If any modules can be used, follow the steps explained below to set parameters and mapping for them to operate.

Operating window Operation Reference page

1. Enable the actual module for 
   communication.

4. Confirm the operation of the module.

5. Confirm and save the settings to 
    the module.

2. Determine the configuration of the 
    processing module.

3. Set the parameters and let the module 
    go into operation.

Mainly the [Actual module 
configuration] window

Prepare the actual module and 
configure the actual module 
communication settings.

5  -  2	 Defining IP Address and Node 
Address (P. 5-7)

5  -  3	 Communication Settings 
(P. 5-12)

[Project] window Create the module configuration 
online.

6  -  1	 Creating a Project (P. 6-1)

[Project] window Edit the parameters.

Write the parameters.

6  -  3	 Editing Parameters (P. 6-16)
6  -  5	 Writing Parameters (P. 6-46)

[Universal monitor] window Confirm the operation on the 
Universal monitor.

6  -  6	 Monitoring Module Operations 
(P. 6-51)

[Project] window Read the parameters from the 
module.

Output the settings in CSV format.

Save the project.

6  -  7	 Reading Parameters (P. 6-56)

6  -  11	 Output to CSV File (P. 6-69)

6  -  9	 Saving a Project (P. 6-65)

Open the saved project. 6  -  10	 Opening a Project (P. 6-67)

Chapter 4. WORK FLOW

4-2



4  -  3	 When There is No Available Module

If any modules cannot be used initially, follow the steps explained below to set parameters and mapping for them to 
operate.

Operating window Operation Reference page

1. Determine the configuration of the 
    processing module.

7. Confirm the operation of the module.

8. Confirm and save the settings for 
    the module.

2. Set the parameters.

6. Set the parameters and let the module 
    go into operation.

3. Confirm and save the settings for 
    the module.

4. Open the saved project after acquiring 
    the module.

5. Enable the actual module for 
    communication.

[Project] window Create the module configuration 
offline.

6  -  1	 Creating a Project (P. 6-1)

6  -  2	 Defining Module Configuration 
(P. 6-11)

[Project] window Edit the parameters.

Define the mapping information.

6  -  3	 Editing Parameters (P. 6-16)
6  -  4	 Mapping (P. 6-38)

[Project] window Output the settings in CSV format.

Save the project.

6  -  11	 Output to CSV File (P. 6-69)

6  -  9	 Saving a Project (P. 6-65)

[Project] window Open the saved project. 6  -  10	 Opening a Project (P. 6-67)

[Project] window
[Actual module configuration] 
window

Prepare the actual module and 
configure the actual module 
communication settings to the 
module using mapping information.

6  -  4	 Mapping (P. 6-38)

5  -  3	 Communication Settings 
(P. 5-12)

[Project] window Write the parameters. 6  -  5	 Writing Parameters (P. 6-46)

[Universal monitor] window Confirm the operation on the 
Universal monitor.

6  -  6	 Monitoring Module Operations 
(P. 6-51)

[Project] window Read the parameters from the 
module.

Output the settings in CSV format.

Save the project.

6  -  7	 Reading Parameters (P. 6-56)

6  -  11	 Output to CSV File (P. 6-69)

6  -  9	 Saving a Project (P. 6-65)

Open the saved project. 6  -  10	 Opening a Project (P. 6-67)
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4  -  4	 When You Change Module Configuration

Follow the steps explained below when you change the configuration of the processing module later, and set 
parameters and actual module communication settings again for them to operate.

Operating window Operation Reference page

1. Determine the configuration of the 
    processing module.

7. Confirm the operation of the module.

8. Confirm and save the settings for 
    the module.

2. Set the parameters.

6. Set the parameters and let the module 
    go into operation.

3. Confirm and save the settings for 
    the module.

4. Open the saved project after acquiring 
    the module.

5. Enable the actual module for 
    communication.

[Project] window Open the saved project.

Modify the module configuration 
offline.

6  -  10	 Opening a Project (P. 6-67)

6  -  2	 Defining Module 
Configuration (P. 6-11)

[Project] window Edit the parameters.

Define the mapping information.

6  -  3	 Editing Parameters (P. 6-16)
6  -  4	 Mapping (P. 6-38)

[Project] window Output the settings in CSV format.

Save the project.

6  -  11	 Output to CSV File (P. 6-69)

6  -  9	 Saving a Project (P. 6-65)

[Project] window Open the saved project.    6  -  10	 Opening a Project (P. 6-67)

[Project] window
[Actual module configuration] 
window

Prepare the actual module and 
configure the actual module 
communication settings to the 
module using mapping information.

6  -  4	 Mapping (P. 6-38)

5  -  3	 Communication Settings 
(P. 5-12)

[Project] window Write the parameters. 6  -  5	 Writing Parameters (P. 6-46)

[Universal monitor] window Confirm the operation on the 
Universal monitor.

6  -  6	 Monitoring Module Operations 
(P. 6-51)

[Project] window Read the parameters from the 
module.

Output the settings in CSV format.

Save the project.

6  -  7	 Reading Parameters (P. 6-56)

6  -  11	 Output to CSV File (P. 6-69)

6  -  9	 Saving a Project (P. 6-65)

Open the saved project. 6  -  10	 Opening a Project (P. 6-67)
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Chapter 5.	 ACTUAL MODULE COMMUNICATION SETTINGS
5  -  1	 Displaying Actual Module Configuration Window

Before using this module, number it with an IP address and node address (workgroup ID and node ID).
Also, configure other communication settings as needed.
Configuring communication settings for a module, such as numbering an IP address and node address, is done in 
the [Actual module configuration] window.

■■ How to Open the Actual Module Configuration Window
Click the  ([Actual module configuration] window) icon in the Project 
window, or go to the Project window’s menu bar and select [Online] → [Actual 
module configuration]. 

>>	The [Actual module configuration] window is displayed. 
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■■ Actual Module Configuration Window Layout
The [Actual module configuration] window is as follows:

Actual module configuration tree Contents Area

Title Bar
Menu Bar

Tool Bar

The names and functions for each window part are described below.

●● Title Bar
Displays the [Actual module configuration] window.

●● Menu Bar
This is used to select or run various operations. Operable content differs depending 
on what is displayed in the Actual Module Configuration tree and contents area.

●● Tool Bar
Frequently used operations from among menu items are available as buttons on the 
tool bar.

●● Actual Module Configuration Tree
The actual module configuration is displayed here as a chain. Selecting any chain 
will display the applicable setup screen in the contents area.

 ■ Actual Module Configuration Tree Levels (P. 5-4)

●● Contents Area
A screen is displayed here for items selected in the Actual Module Configuration 
Tree.

Chapter 5. ACTUAL MODULE COMMUNICATION SETTINGS
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■■ Actual Module Configuration Window - Menu Configuration List

Menu Icon Submenu 1 Submenu 2 Description Shortcut Keys

File — Close — Closes the [Actual module configuration] 
window.

—

Edit — Cut — Cuts data. [Ctrl] + [X]

— Copy — Copies data. [Ctrl] + [C]

— Paste — Pastes data. [Ctrl] + [V]

Online — Workgroup 
independent mode

— Unsupported —

— Communications path — Changes communication path from PC to 
module.

 ■ Communication Path (P. 5-29).

—

— Network profile — Allows you to change the PC’s IP address 
settings.

 ■ Network Profile (P. 5-31).

—

— Communications 
options

— Loader communication time out settings.
 ■ Communications Options (P. 5-37).

—

— Sensitive to ring 
disconnection error

— Changes between detecting and not 
detecting ring disconnection.

—

View Go Back Moves one position back on the Actual 
Module Configuration Tree.
Enabled when the project is open.

[Alt] + [Left]

Forward Moves one position forward on the Actual 
Module Configuration Tree.
Enabled when the project is open.

[Alt] + [Right]

Up Moves one level up on the Actual Module 
Configuration Tree.
Enabled when the project is open.

—

Home Moves to the top level (All) of the Actual 
Module Configuration Tree.

[Alt] + [home]

— [Workgroup] screen — Moves to the workgroup view in the Project 
window for the selected module.
Enabled when a module is selected in the 
[Actual module configuration] window.

—

— Return to Project 
window

— Returns focus to the Project window. —

— Error display — Displays module errors.
Displayed when an error occurs for a module 
selected in the [Actual module configuration]  
window.

—

— Set user level — Changes the user level. —
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■■ Tool Bar
Icon Name Icon Function

Back Moves one position back on the Actual Module 
Configuration Tree.

Next Moves one position forward on the Actual Module 
Configuration Tree.

Up Moves one level up on the Actual Module Configuration 
Tree.

Home Moves to the top level (All) of the Actual Module 
Configuration Tree.

Expand Expands the Actual Module Configuration Tree.

■■ Actual Module Configuration Tree Levels
The Actual Module Configuration Tree is made up of the following levels.

 page 5-5

 page 5-6

 page 5-4All

Chain Name

Module Name

●● All
The Actual Module Configuration Tree’s top level is called [All].
This enables you to scan the actual module configuration, configure the 
communication settings common to all modules, etc.

[Edit] Button

[Set communication] Button
[Return] Button

[Execute] Button

•	 [Execute] button 
Scans the actual module configuration.

•	 [Edit] button 
Displays a list of modules connected to the selected chain.

•	 [Set communication] button 
The [Communication settings (all)] dialog box is displayed.

•	 [Return] button 
Returns focus to the Project window.
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●● Chain Name
•	 A Chain Name is located one level below [All]. 

You can configure the settings for each module (such as an IP address and node 
ID) here.

By clicking the [Write] button, you can write actual module communication settings 
to the module. 

[Details] Button
[Set communication] Button

[Lit LED] Button

[List] [Chain name][Actual module configuration tree]

[Automatic numbering] Button
[Write] Button

[Workgroup ID] [IP address]       [Node ID]

[Chain ID]

[Target]

Each component of a Chain Name tab is explained below.
•	 [Chain ID] 

Can be set the chain ID.
•	 [Chain name] 

Can be set the chain name.
•	 [Target] Check Box 

These boxes are to be checked for LED lights, writing, and automatic numbering.
•	 [Workgroup ID] 

Displays the workgroup ID (the same value for Chain ID is displayed).
•	 [IP address] 

Can be set the IP address.
•	 [Node ID] 

Can be set the node ID.
•	 [Details] button 

Displays module information for the selected module.
•	 [Set communication] button 

Can be configured. Individual communication settings for the selected module.
•	 [Lit LED] button 

Turns on an LED light for the module with the [Target] check box checked. 
•	 [Auto numbering] button 

This allows you to automatically set the IP address and node ID.
•	 [Write] button 

When clicked, the altered actual module communication settings will be written 
onto the modules  with the [Target] check box checked.
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	 Note

•	 	�If the module name acquired from the module itself differs from the module 
name specified for the project, the module name is shown preceded by an 
asterisk (*) in the actual module configuration tree and in the contents area 
of the [Actual module configuration] window.

●● Module Name
Module Name is one level below a Chain Name.
Here is displayed module information acquired when executing a scan of the actual 
module configuration.

[Item name]  [Setting value] [Read value]

•	 [Item name] 
Name of acquired information.

•	 [Setting value] 
Setting value while editing in the [Actual module configuration] window.

•	 [Read value] 
Module value acquired when executing a scan of the actual module 
configuration.

	 Note

•	 	�From SLP-NX 4.00, as well as the value being edited, the reading results of 
the previous successful scan are displayed in the setting value column.
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Address numbering is done in the [Actual module configuration] window. 
If there is no available module, you can configure module settings via  
6  -  4	 Mapping (P. 6-38).

 Handling Precautions
•	 To create a new project from the actual module configuration even if a ring 

error occurs, in the menu of [Actual module configuration] window, remove 
the check mark in [Online] → [Sensitive to _ring disconnection error], and 
then execute the actual module configuration scan. In SLP-NX Ver 3.02.2 or 
earlier, if a ring error has occurred, a new project cannot be built by executing 
an actual module configuration scan from the loader. 
If a problem with the ring occurs,the creation of a new project by scanning 
the actual module configuration will fail. 
In this case, resolve the ring problem or create the project offline.

■■ Steps

[1]	 In the [All] tab of the [Actual module configuration] window, click the 
[Execute] button.

>>	The [Confirmation of module startup] message box appears. 

[2]	 Turn on the module to be numbered with an address, then connect the cable 
selected via communication path to a running PC.

	 Note

•	 If multiple modules are concatenated, and the Ethernet is used as a 
communication path, these modules can be numbered at once.

5  -  2	 Defining IP Address and Node Address
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[3]	 Confirm connection, and click the [OK] button.

>>	The [Progress] dialog box is displayed.

	 Note

•	 Make sure whether the loader and the module are properly connected in an 
appropriate environment. 

 ■ Communication Path (P. 5-29) and ■ Network Profile (P. 5-31).
After this, one of many message boxes will be displayed depending on the module 
status.

[4]-1	 If an error occurs during actual module configuration scan: 
A message box containing the error description will be displayed. 
Check the error description and take appropriate action.

	 Note

•	 For details on the errors, and counter measures, refer to: 
 ■ Message List (P. 5-16).

[4]-2	 If no error occurs during actual module configuration scan, but the project is 
not open in the Project window:  
The following message box is displayed. When you want to configure the 
communication settings for modules (such as address numbering), click the 
[No] button.

	 Note

•	 When you click the [Yes] button in the message box shown above,  
 “Selecting [Auto configuration from actual module] to create” in 6-1, 

“Creating a Project” (page 6-1)

[4]-3	 If no error occurs during actual module configuration scan, but you are 
editing a workgroup in the Project window:  
The following message box is displayed. When you want to configure the 
communication settings for modules (such as address numbering), click the 
[No] button.
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[5]	 Scan results are displayed on the screen for each chain. 

	 Note

•	 If an error occurs:  
An error icon  will flash for the module with a scan error. By right 
clicking on the module with the flashing error icon, and selecting [Error 
display], you can see the error description. 

[6]	 For each chain, number the modules with addresses (IP addresses, node IDs, 
and workgroup IDs).

	 Handling Precautions

•	 Node IDs are required for data transfer function between modules and 
multi-loop cooperative control.  
If data transfer function between modules and multi-loop cooperative 
control are not used, there is no need to change the node IDs.
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•	 To change the IP address, node ID or workgroup ID of a module that is 
using data transfer function between modules or multi-loop cooperative 
control, 

 ■ Changing the IP Address, etc. of a Module That Is Using Data 
Transfer Function between Modules or Multi-Loop Cooperative Control 
(P. 9-4).

•	 The workgroup ID displayed on the screen is the identifier of a work group 
which represents a group made up of modules in the Project window. 
Since the workgroup ID is linked with the chain ID, it cannot be edited. 

[6]-1	 To configure the settings manually, click the line of the target module, and set 
the desired value directly in the edit box. 

[6]-2	 To configure the settings automatically (sequential numbering), click the 
[Automatic numbering] button.

>>	The [Auto module numbering] dialog box will then be displayed.

	 Note

•	 When there is any module which is not applicable for auto numbering, 
uncheck the appropriate [Target] box in the module list. 
After confirming the range of available IP addresses, specify the first IP 
address and node ID for the modules to be numbered, and click click the 
[OK] button.

[7]	 After completing numbering the IP addresses, node IDs, and workgroup 
IDs, click [Write] on the [Module list] screen to write actual module 
communication settings.
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>>	The [Writing of chain information, address information, and 
communication settings.] message box will then be displayed.

	 Handling Precautions

•	 Once writing is completed, the module will be reset (restarted). Confirm 
operational status and start working.

	 Note

•	 Writing of actual module communication settings to the module is done for 
each chain.

•	 If there are multiple chains, a different chain ID will be assigned to each 
chain, but if an appropriate chain name has already been set, comparative 
management for the actual chain is easy.

•	 The settings are written only to modules with the [Target] check box checked.
•	 If you want to confirm mapping with the target module before writing, 

perform the steps described in 5  -  4	 Module LED Lights (P. 5-15) to turn on 
the module’s LED light for confirmation.

[8]	 Click the [Yes] button on the [Writing of chain information, address 
information, and communication settings.] message box.

>>	The [Progress] dialog box is displayed.

[9]	 Actual module configuration information is then automatically acquired 
from the module.
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5  -  3	 Communication Settings

Communication settings other than the module’s IP address and node address are to be configured in the [Actual 
module configuration] window [Set communication] button. The following settings can be configured. 
If there is no available module, you can configure module settings via 6  -  4	 Mapping (P. 6-38).

Settings Screen

Type Name Description
All

(page 5-13)
Chain Name
(page 5-14)

Basic settings for 
module

Set the following value to all 
modules

Checks this box when performing the 
automatic address numbering prohibition 
function for all modules

❍ —

Automatic address 
numbering is prohibited.

Excludes modules from auto address 
numbering.
(Check mark will be removed from the list of 
target modules.)

❍ ❍

IP settings Netmask IP net mask ❍ —

Default gateway IP default gateway ❍ —

Port settings Set next value to all modules Checks this box when you want port settings to 
apply to all modules.

❍ —

Dedicated communication 
port number

Cannot be changed. ❍ ❍

MODBUS/TCP port number MODBUS/TCP function’s port number ❍ ❍

CPL/TCP port number CPL/TCP communication port number ❍ ❍

RS-485
detailed settings

Set the following value to all 
modules

Checks this box when you want the changes to 
RS-485 setting to apply to all modules.

❍ —

RS-485 device address Device address used for host communication 
(RS-485).

— ❍

RS-485 protocol Host communication (RS-485) protocol 
selection

❍ ❍

RS-485 transmission rate Transmission speed used for host 
communication (RS-485)

❍ ❍

RS-485 bit length Bit length used for host communication (RS-
485)

❍ ❍

RS-485 parity status With/without parity used for host 
communication (RS-485)

❍ ❍

RS-485 stop bits Stop bit used for host communication (RS-485) ❍ ❍

RS-485 minimum response 
time

Minimum response time used for host 
communication (RS-485)

❍ ❍
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■■ Setting Procedure
The following explains the setting procedure.
•	 To configure the settings common to all modules:  

Select [All] from the Actual Module Configuration Tree, then select a chain from 
the [All] tab’s contents area and click [Set communication].

>>	The [Communication settings (all)] dialog box will then be displayed.

	 Set the necessary items, then click the [OK] button.
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•	 To configure the settings for each module individually:  
Select a desired Chain Name from the Actual Module Configuration Tree, then 
select a line in the [List] tab for the module you want to set (when clicking the 
line for the target module, the background will turn gray), then click the [Set 
communication] button.

>>	The following dialog box will then be displayed.

	 Set the necessary items, then click the [OK] button.

	 Note
•	 You can simultaneously change the actual module communication settings (IP 

address, node address, and communication settings) and write to the module.
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The module LED light function is used to confirm which module is an actual module when numbering a module’s 
IP address, etc.

[1]	 Select a desired Chain Name from the Actual Module Configuration Tree 
in the [Actual module configuration] window, then check a check box 
under [Target] for the module you want to light up from the [List] tab in the 
contents area, and click the [Lit LED] button.

>>	The [Lit module LED] dialog box will then be displayed.

[2]	 Set the values in the [Lighting indication] area, and click the [OK] button. 
In this area, you can select as the lighting type as [Timer], [ON], or [OFF].   
When you select [Timer], you can also set the lighting time(s) as a value 
between 1 and 255 seconds.

>>	All top LED lights will flash at a low speed for target modules.

5  -  4	 Module LED Lights
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5  -  5	 Confirming Mapping with Workgroups

■■ Overview
When you create a project offline and manually edit module configuration, or 
when you create a project with auto configuration from the actual module, but add 
module configuration or change the model number, you must maintain consistency 
between workgroup information and actual module configuration information.
Check the consistency with the actual module configuration scan function, etc.

■■ Message List
The following messages are displayed when you confirm mapping with workgroups.

No. Message Cause and Action

1

An error was found during scanning of actual module 
configuration.
xxx: �Duplicate IP addresses exist. IP address setting is 

required.
Please set/confirm the valid values and then write.

<Module Error>
The IP address is already used.

Set a different IP address in the [Actual module 
configuration] window, and click [Write] to write to the 
module.

2

An error was found during scanning of actual module 
configuration.
xxx: Duplicate chain IDs exist.
Please set/confirm the valid values and then write.

<Module Error>
The chain ID is already used.

Set a different separate chain ID for each chain in the 
[Actual module configuration] window, then click 
[Write] to write to the module.

3

An error was found during scanning of actual module 
configuration.
xxx: IP address of base does not match that of body.
Please set/confirm the valid values and then write.

<Module Error>
The module device and base combination has been 
changed.
Return the module device and base combination 
to normal, or click [Write] in the [Actual module 
configuration] window to write to the module.

This operation will write the IP address	information 
etc. that was written to the module to the base as well, 
eliminating any difference between the module device 
and base.

4

No module was found on the selected communication 
path.

<Module Error>
No module was found during scan.

Confirm the following:
• The module is turned on
• The module and PC are connected properly
• [Communications path settings] are set correctly
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No. Message Cause and Action

5

An error was found during scanning of actual module 
configuration.
xxx: Chain ID does not match that of initial module.
...
Writing from actual module configuration window is 
required.
Please set/confirm the valid values and then write.

<Module Error>
A module was found with different chain ID within the 
same chain.

Confirm chain ID in the [Actual module configuration] 
window, then to make sure all chain IDs are the same 
within the chain, click [Write] to write to the module.

6

An error has occurred.
Some module model numbers defined for the project do 
not match the model numbers of the scanned modules.
...

<Module Error>
Model number of module defined in the project differs 
from that of the scanned module.

Clicking [OK] will display the [No. 8] message box, and 
this message box will be displayed again.
In this case, confirm [Module configuration] in the 
Project window, and match it to the module’s model 
number.

7

An error has occurred.
Significant differences in configuration exist between a 
module defined for the project and a scanned module.(28)

An error has occurred.
No scanned modules has the same combination of type, 
position, IP address, node ID, and workgroup ID of any one 
module defined in the project.
Significant differences in configuration exist between a 
module defined for the project and a scanned module. (28)

<Module Error>
An error occurred during map processing. Because the 
type, position, IP address, node ID, and workgroup ID of 
the module defined in the project do not match  those 
of the scanned module.

Clicking [OK] will display the [No. 8] message box.
If mapping cannot be performed after the [No. 8] 
message box is displayed, this message box will 
be displayed again. Please confirm project module 
settings when this occurs.
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No. Message Cause and Action

8

Do you wish to perform mapping by overwriting scanned 
information with module IP address and node ID as defined 
in the project?
(In single-chain and workgroup linked mode, workgroup 
IDs will also be overwritten.)

<Confirmation of Mapping Retry>
Displayed after an error message when there is 
significant difference between project settings and 
modules.

Selecting [Yes] will transfer the scanned module’s IP 
address and node ID to the project, and start mapping.
When in workgroup linked mode with only one chain, 
the scanned workgroup ID will be used in the project, 
and mapping will be performed.
When selecting [No], project settings will not be 
changed, and mapping will not be performed.

Moreover, if you want to write project settings to the 
actual module, select [No] to cancel mapping, and after 
mapping with drag & drop in the Project window’s 
[Mapping] screen, write to the module by clicking 
[Write] in the [Actual module configuration] window.

9

No IP address has been set for module defined for the 
project.
Click [YES] to update project with scanned IP address and 
node ID and to perform mapping.
OK to continue?

<Confirmation of Mapping Continuation>
An IP address has not been set to the project module 
defined in the project. 

Clicking [Yes] will transfer the scanned project, and 
mapping will occur.
When selecting [No], project settings will not be 
changed, and mapping will not occur.

10

Some modules defined for the project cannot be found.
Click [YES] to perform mapping with found modules  only.
OK to continue?

<Confirmation of Mapping Continuation>
Some modules defined in the project were not found 
when scanning.

Clicking [Yes] will only perform mapping for modules 
that were found during scanning that are consistent 
with modules defined for the project.
When selecting [No], mapping will not occur.

11

A module not defined for the project has been found.
...
Click [YES] to perform mapping with a module other than 
that above.
OK to continue?

<Confirmation of Mapping Continuation>
Module(s) not defined in the project were found when 
scanning.

Clicking [Yes] will only perform mapping for modules 
that were found during scanning that are consistent 
with modules defined in the project.
When selecting [No], mapping will not performed.
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No. Message Cause and Action

12

Configuration data has been acquired for the number of 
chains (x) and the number of modules (y).
The project will be configured based on this information.
Do you also wish to read module setting parameters?

<Build Project>
Displayed when creating a new project with [Auto 
configuration from actual module], and a module scan 
occurs normally.

Clicking [Yes] will read the module parameters and 
include them in the project.
When selecting [No], the project will be created, but 
parameters will not be read.
When selecting [Cancel], the project will not be 
created.

13

Do you wish to build project with scanned information?

<Project Construction>
Displayed when there is no project, but a scan of actual 
module configuration is performed normally.

Clicking [Yes] will create a project.
When selecting [No], a project will not be created.

14

Do you wish to move to the actual module configuration 
window?

<Confirmation of Transition to the Actual Module 
Configuration Window>
Displayed if there is any error during module 
scan when a new project is created using [Auto 
configuration from actual module], and an error occurs. 

Clicking [Yes] will display the [Actual module 
configuration] window, and module status can be 
confirmed.
When selecting [No], the [Actual module configuration] 
window will return to its original empty state.

15

Do you wish to overwrite project mapping information with 
actual module communication settings?

<Confirmation of communication setting overwriting>
Displayed when module scanning and mapping occur 
normally.

Selecting [Yes] will apply actual module 
communication settings of the scanned module to the 
project mapping data.
When selecting [No], project mapping data set during 
mapping will not be changed.

16

There is a difference between scanned module 
communication settings and project communication 
settings.
Please confirm the data on the actual module configuration 
window.

<Communication Setting Differences>
Displayed when selecting [No] in the [No.15] message 
box, and there are differences between the project’s 
communication settings and the communication 
settings of the scanned modules.

Please confirm communication settings in the [Actual 
module configuration] window.

17

Do you wish to read module setting parameters and use 
them to update the project?

<Parameter Reading>
Displayed when selecting [Yes] in the [No.15] message 
box.

Clicking [Yes] will read the module parameters and 
apply them to the project.
When selecting [No], the parameters will not be read.
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No. Message Cause and Action

18

Scanning of actual module configuration has been 
completed.

<Scanning Complete>
Displayed when an actual module configuration scan is 
executed normally.

19

Receiving parameters has been completed.

<Setting Parameter Reading Complete>
Displayed when reading of module parameters is 
complete.

20

Chain information, address information, and 
communication settings will be written.
Module will be restarted after writing.
OK to proceed?

<Write Confirmation>
Displayed when clicking [Write] in the [Actual module 
configuration] window.

When selecting [Yes], actual module communication 
settings are written to the module.
The module is restarted when writing takes place.
When selecting [No], nothing will be written to the 
module.

21

An error was found in a post-writing scan.
xxx: �Duplicate IP addresses exist. IP address setting is 

required.
Please confirm the actual modules and the set values and 
repeat the writing process. (729)

<Error After Writing>
All information was successfully written to the module, 
but after that a scan detected duplicate IP address.

Confirm module IP address via [Actual module 
configuration]  and then click [Write] again to execute 
writing once more.
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No. Message Cause and Action

22

Failed to write to module or some data has not been 
written.
xxx: �Certain chain information, address information, and 

communication settings.
Please write any such chain information, address 
information, or communication settings in an available 
chain.

<Error After Writing>
There is an unwritten module in the [Actual module 
configuration] window.

Check that the module is marked with “*” in the [Actual 
module configuration] window’s [Modification] 
column, and then click [Write] to write the actual 
module communication settings to the module as 
needed.

23

Failed to write to module or some data has not been 
written.
xxx: Actual module configuration has been changed.
Please clear the previous configuration and re-execute the 
process.

<Error After Writing>
A difference was detected between project module 
configuration and scanned module configuration 
when writing to module.

Click [Execute] from [Actual module configuration] to 
re-acquire actual module configuration, and then click 
[Write] again to write to the module.  

24

Failed to write to module or some data has not been 
written.
xxx: Chain ID does not match that of initial module.
...
Please write chain information, address information, or 
communication settings in a chain without data.  

<Error After Writing>
When writing to modules, a module with a chain ID 
differing from other modules in the same chain was 
found.

Check for chain IDs in the [Actual module 
configuration] window, and click [Write] so that all 
modules in the chain have the same chain ID.  

25

Writing to modules has been completed successfully.

<Writing to Modules Completed>
Displayed when all information has been written to the 
module.
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■■ Typical Methods of Confirmation
The following are three typical methods to confirm mapping between workgroups 
and actual module configuration.
1.	 Apply actual module communication settings to new modules
2.	 Apply parameters prepared in advance to actual modules
3.	 Read the parameters of an operating module and change the settings
The steps for each method are explained below.

●● Apply actual module communication settings to new modules
Start up the loader, and acquire actual module configuration from the new project.

[1]	 Click the  icon in the Project window, or select [File] → [New] from 
the Project window’s menu bar.

>>	The [Create new project] dialog box will then be displayed.

[2]	 Select [Auto configuration from actual module] and the[OK] button.

[3]	 The [Confirmation of module startup] message box appears. 
Click the [OK] button.

>>	The Collection of the module’s information begins, and the [Progress] 
dialog box is displayed.

[4]	 A message box appears, explaining there are duplicate IP addresses. 
Click the [OK] button.
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[5]	 The [Confirmation of transition to the actual module configuration 
window] message box is displayed. 
Click the [Yes] button

[6]-1	 There are currently duplicated IP addresses and node IDs in the [Actual 
module configuration] window.

[6]-2	 Click [Auto numbering] to number the IP address and node ID of all 
modules at the [Auto module numbering] dialog box, or enter each module’s 
IP address and node ID individually in text boxes in the [Actual module 
configuration] window’s contents area. (The example below shows the [Auto 
module numbering] dialog box is shown below as an example.)  

[6]-3	 If the IP address and node ID have been changed, they are marked with a “*” 
in the [Modification] column. Click the [Write] button to write actual module 
communication settings to the module.
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[7]	 The [Writing of chain information, address information, and 
communication settings] message box is displayed. Click the [Yes] button.

>>	The [Progress] dialog box is displayed for writing progress.

[8]	 The [Project construction] message box is displayed. 
Click the [Yes] button.

[9]	 The message box for reading parameters is displayed. 
Click the [Yes] button. 
Parameters are then applied to the project.

>>	The [Progress] dialog box is displayed for reading progress.
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[10]	 The [Parameters received] message box is displayed. 
Click the [OK] button.

	 Select [File] → [Save as] from the Project window’s menu bar, and save the 
project with an appropriate name.

●● Apply parameters prepared in advance to actual modules

[1]	 Start up the loader, and open the project prepared in advance. 
Open the [Actual module configuration] window, then click the [Execute] 
button for [Scanning of actual module configuration].

[2]	 The [Confirmation of module startup] message box is displayed. 
Click the [OK] button.

>>	The [Progress] dialog box is displayed.

[3]	 Confirm that no error has occurred during the [Scanning of actual module 
configuration].

•	 If an error has occurred, refer to the “Message” and “Cause and Action” 
sections of ■ Message List (P. 5-16), and after taking appropriate action, 
start again from step [1].

•	 If no error has occurred, resume process from step [4].
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[4]	 The [Confirmation of communication setting overwriting] message box is 
displayed. 
Click the [No] button..

[5]	 The [Build project] message box is displayed. 
Click the [No] button.

[6]	 The [Scanning of actual module configuration complete] message box is 
displayed. 
Click the [OK] button.

[7]	 Select a workgroup from the Project window, and use one of the following 
methods to write parameters to the modules.

•	 Select [3: Parameter writing] under [Operation list] in the [Workgroup] 
view’s contents area.

•	 Select [Online] → [Write Parameters] from the Project window’s menu 
bar.

•	 Select the  icon from the Project window’s tool bar.

[8]	 The [Confirmation of parameter write] message box is displayed. 
Click the [Yes] button.

>>	Writing begins, and the [Progress] dialog box is displayed.
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[9]	 The [Parameter sending complete] message box is displayed. 
Click the [OK] button.

●● Read the parameters of an operating module and change the settings
Start up the loader, and acquire actual module configuration from the new project.

[1]	 Click the  icon in the Project window, or select [File] -> [New] from 
the Project window’s menu bar.

>>	The [Create new project] dialog box will then be displayed.

[2]	 Select [Auto configuration from actual module] and click the [OK] button..

[3]	 The [Confirmation of module startup] message box appears. 
Click the [OK] button.

>>	The Collection of the module’s information begins, and the [Progress] 
dialog box is displayed.

[4]	 The [Build project] message box is displayed. 
Changes will occur as the module setting parameters are being read, so click 
the [Yes] button.
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[5]	 The [Progress] dialog box is displayed for reading progress.

[6]	 The [Parameters received] message box is displayed. 
Click the [OK] button.

[7]	 When changing the actual module communication settings, change them at 
the [Actual module configuration] window, and perform writing. 
When changing parameters, first change settings in the [Project] window, 
then perform parameter writing.

[8]	 Save the project under different names as necessary.
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5  -  6	 Other

■■ Communication Path
A method of module-to-loader connection (Ethernet or USB loader cable) must be 
selected in the communication path. 
When connecting via Ethernet, network interface assignment must be done for the 
PC to be used with the loader.

Select [Online] → [Communications path] from the [Actual module configuration] 
window or Project window’s menu bar.

>>	The [Communications path] dialog box is then displayed.

	 Note

•	 To select a USB loader cable, the following requirements must be met:
•	 The USB loader cable must be recognized by the PC when connected.
•	 Only 1 module must be registered to the project’s module configuration. 

●● Connecting via USB loader cable
Connection can only be done via USB loader cable when the project consists of a 
single module.

[1]	 Select [Loader jack] in the combo box of the [Communications path] 
dialogue box.

Click the [Advanced] button, and select the serial port to which the USB 
loader cable is connected. Normally the serial port to which the USB loader 
cable is connected will be automatically selected, so this doesn’t have to be 
changed. 
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●● Connecting via Ethernet
Ethernet connection can be done with a project made up of a single or multiple 
modules.

[1]	 Select [Ethernet] in the combo box of the [Communications path] dialog 
box.

[2]	 Click the [Custom comm. path] button.

[3]	 Assign a network interface to the PC to be connected to module(s).
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■■ Network Profile
You can set or change network settings for the loader (IP address, default gateway, 
net mask) in the [Network Profile Explorer] dialog box.
The network setting selected as [Activate] here will be used as a network setting 
for the PC while the loader is starting up. Each time the loader starts up after this, 
you can select which network profile to use in the [Network profile initialization 
process] dialog box. 
Also, when the loader is terminated, the network settings will automatically return 
to the same status as before the loader startup (displayed as [Original] in the 
[Network profile] window). 
Select [Online] → [Network profile] from the [Actual module configuration] 
window or Project window’s menu bar.

>>	The [Network Profile Explorer] dialog box is then displayed.

 Handling Precautions
•	 If the loader is terminated abnormally, the network profile will recognize that 

the loader is still being used. To return the PC’s network settings to the same 
status as before the loader startup, restart the loader, then terminate it. The 
[Select profile] window will be displayed. Select [Original] in this window to 
return the network settings to the same status as before the loader startup.

•	 When using the network profile function to change the PC’s network settings, 
do not remove the Ethernet cable during  processing. Otherwise, network 
settings may not be changed correctly.
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●● New
Select [New] from the [Network Profile Explorer] dialog box’s tool bar.

>>	A new network profile will be created. 
Currently used network settings will be copied as they are, so make changes as 
necessary. 

 ● Edit (P. 5-36).
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●● Activate
Select a profile name (with a folder icon attached) from the [Network Profile 
Explorer] dialog box’s tree view, then click on the tool bar’s  icon, or select 
[Activate] from the right click menu.

>>	This will apply the selected network profile as settings for the PC starting up the 
loader, and will also cause the selected network profile to be selected as a default 
value each time the loader starts up from now on.

When selecting [Activate]:

>>	A check mark will be added to the tree view’s profile name with “In use” as a 
profile, when that network profile has actually been enabled as a network setting 
for the PC.
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●● Delete
Profiles other than the “In use” profile and “Original” profile can be deleted.
Select a profile name (with a folder icon attached) from the [Network Profile 
Explorer] dialog box’s tree view, then click on the tool bar’s  icon, or select 
[Delete] from the right click menu.
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●● Edit Profile Name
Profiles other than the “In use” profile and “Original” profile can be renamed.
Select a profile name (with a folder icon attached) from the [Network Profile 
Explorer] dialog box’s tree view, then directly alter the name from the tree view, or 
change it via the profile name edit pane text box.

●● Network Device Information
When you want to view the network interface IP address, sub net mask, or default 
gateway information of a certain profile, select a network interface name under the 
tree view’s profile name.

>>	The information will be displayed in the Network Device Information pane on 
the right.
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●● Edit
The network interface IP address, sub net mask, and default gateway for profiles 
other than “Original” can be edited.
Select a network interface name from under the tree view’s profile, then click [Edit] 
from the tool bar, or from the network device information pane.

●● Exit
This button exits the [Network Profile Explorer] dialog box.
Select [File] → [Exit] from the menu bar, or click the [Exit] button in the lower right 
corner of the dialog box.
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■■ Communications Options
Set message timeout, etc. for module communication when connected via loader 
cable.
Normally this does not have to be changed.

Select [Online] → [Communications options] from the [Actual module 
configuration] window or Project window’s menu bar.

>>	The [Communications options] dialog box is then displayed.

●● Minimum Communication Interval (ms)
Determine the interval to send  the next request message after the reception of the 
response to the previous one.Values cannot be changed.

●● Timeout (ms)
Determine the time taken for the response to a request message.
If there is no response within the timeout period, and the number of times of 
resending a request is specified, the request will be resent the specified number of 
times.

●● Resend (number of times)
Determine the number of times of resending a request message when the response 
to the request message is timed out. 
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Chapter 6.	 PARAMETER SETTINGS
6  -  1	 Creating a Project

■■ Overview
Modules handled with the loader, such as module parameter settings, etc. are called 
projects. This chapter describes how to create a project.

Select [File] → [New] from the Project window’s menu bar, or click the  icon.

>>	The [Create new project] dialog box will then be displayed.

The [Module configuration selection] radio buttons are described below.

●● Selecting [Single module configuration] to create
When selecting the [Single module configuration] radio button to create a project, 
module configuration is registered as a single unit. The model number of the 
registered module is NX-D15NT4T00.
After creating the project, the model number can be changed, and additional 
modules can be added.

 ■ Selecting [Single module configuration] to Create a Project (P. 6-2).

	 Handling Precautions

•	 In the case of multi-loop cooperative control using the supervisor module, 
multiple module settings are configured at the same time. Therefore this 
connection method should not be used.

●● Selecting [Multiple module configuration] to create
When selecting the [Multiple module configuration] radio button to create a 
project, the project will be created without any module being registered.
After the project is created, module configuration will be defined.

 ■ Selecting [Multiple module configuration] to Create a Project (P. 6-4).

●● Selecting [Auto configuration from actual module] to create
When the [Auto configuration from actual module] radio button is selected and 
a project is created, an actual module configuration scan is done and a project is 
created with the module definition and actual module communication settings 
based on the detected information.

 ■ Selecting [Auto configuration from actual module] to Create a Project 
(P. 6-6).
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■■ Selecting [Single module configuration] to Create a Project
The following steps explain how to register the module configuration for a single 
module while creating a project.
The model number of the registered module is NX-D15NT4T00.

[1]	 Select [File] → [New] from the Project window’s menu bar, or click the 
 icon.

>>	The [Create new project] dialog box will then be displayed.

[2]	 Select [Single module configuration] and click the [OK] button.

	 Note

•	 If a new project is created while another project is already open, the  
[Confirmation of new creation] message box will be displayed. To close the 
opened project and start a new one, click the [Yes] button. 
If you don’t want to close the opened project, click the [No] button.
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[3]	 A [New project] message box is displayed when the new project has been 
created. Click the [OK] button.

>>	A workgroup display will then appear in the project tree.

[4]	 Select [1: Module definition] from the workgroup display’s contents area.

>>	Here you can confirm the model number NX-D15NT4T00 is registered 
for a single module configuration.

	 Note
•	 You can change NX-D15NT4T00 to another model number by changing the 

module type or model number. You can also add modules.
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■■ Selecting [Multiple module configuration] to Create a Project
The following steps explain how to create a project without registering module 
configuration.

[1]	 Select [File] → [New] from the Project window’s menu bar, or click the 
 icon.

>>	The [Create new project] dialog box will then be displayed.

[2]	 Select [Multiple module configuration] and click the [OK] button.

	 Note
•	 If a new project is created while another project is already open, the  

[Confirmation of new creation] message box will be displayed. To close the 
opened project and start a new one, click the [Yes] button. 
If you don’t want to close the open project, click the [No] button.
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[3]	 A [New project] message box is displayed when the new project has been 
created. Click the [OK] button

>>	A workgroup display is then shown at the project tree.

[4]	 Select [1: Module definition] from the workgroup display’s contents area.

>>	Here you can confirm that no modules have been registered to the module 
configuration. 

	 Note
•	 For details on module configuration settings, 

 6  -  2	 Defining Module Configuration (P. 6-11).
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■■ Selecting [Auto configuration from actual module] to Create a Project
This section describes how to use the actual module configuration to create a 
project and at the same time acquire the actual module communication settings. 

 Handling Precautions
•	 To create a new project from the actual module configuration even if a ring 

error occurs, in the menu of [Actual module configuration] window, remove 
the check mark in [Online] → [Sensitive to _ring disconnection error], and 
then select "Auto configuration from actual module" to create the project. In 
SLP-NX Ver 3.02.2 or earlier, if a ring error has occurred, a new project cannot 
be built by executing an actual module configuration scan from the loader. In 
this case, eliminate the ring error, or create the project offline.

•	 The following steps describe how actual module communication settings are 
applied to a module. 
If you are not going to set actual module communication settings, first refer 
to 5  -  2	 Defining IP Address and Node Address (P. 5-7) , and then number 
an IP address, etc. to the module.

[1]	 Select [File] → [New] from the Project window’s menu bar, or click the 
 icon.

>>	The [Create new project] dialog box will then be displayed.

[2]	 Select [Auto configuration from actual module] and click the [OK] button.
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	 Note
•	 If a new project is created while another project is already open, the  

[Confirmation of new creation] message box will be displayed. To close the 
opened project and start a new one, click the [Yes] button. 
If you don’t want to close the open project, click the [No] button.

[3]-1	 The [Confirmation of module startup] message box appears. Click the [OK] 
button to start the actual module configuration scan.

>>	The [Progress] dialog box is displayed.

Depending on actual module configuration scan results, the project will 
differ as follows.

[3]-2	 If there are no errors

>>	The [Build project] message box is displayed.

If you want to coordinate a parameter reading 
click the [Yes] button in the [Build project] message box. Then move on to step [4].

If a parameter reading is not necessary 
click the [No] button in the [Build project] message box. Then move on to step [7].

To cancel an actual module configuration scan 
click the [Cancel] button in the [Build project] message box. 

[3]-3	 If an error occurs

>>	The [Error in scanning of actual module configuration] message box will 
be displayed. 

	 Note

 ■ Message List (P. 5-16).

Click the [OK] button in the [Error in scanning of actual module 
configuration] message box.

>>	The [Confirmation of transition to the actual module configuration 
window] message box will be displayed. 
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When clicking the [Yes] button in the [Confirmation of transition to the 
actual module configuration window] message box, the [Actual module 
configuration] window shown in step [5] in 5  -  2	 Defining IP Address and 
Node Address (P. 5-7) will be displayed. 
Clicking the [No] button will end the process. First work to avoid the 
displayed error.

[4]-1	 If the settings are unable to directly communicate with modules connected 
via PC network settings, a [Network profile search] dialog box is displayed.
If the settings are able to directly communicate with modules connected via 
PC network settings, the parameter receiving process begins.
In this case, move on to step [5].

[4]-2	 If an applicable profile is available among those registered, a dialog box is 
displayed to confirm whether or not the found profile will be used.

<When using a registered profile that is displayed>
	 Click the [OK] button and move on to step [5].

<When not using any profile that is displayed >
	 Click the [Cancel] button.

Note)	A [Confirmation of continuation] message box is displayed. To 
cancel communication, click the [Cancel] button.

When [OK] is clicked in the [Confirmation of continuation] 
message box, the process proceeds to step [5], but when 
communication fails, the [Process failure] message box is 
displayed. Reset the module and PC network settings correctly 
before repeating the process.
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[4]-2	 If an applicable profile is not available among those registered, a dialog box is 
displayed to confirm whether or not you want to create a new profile.

<When creating a new profile>
Click the [OK] button to create a new applicable profile, and a dialog 
box will be displayed to confirm whether or not you will use it.
When clicking the [OK] button again, the profile will switch to a new 
one. In this case, move on to step [5].
If you do not want to use the new profile, click the [Cancel] button.
Note)	A [Confirmation of continuation] message box is displayed. To 

cancel communication, click the [Cancel] button.

When [OK] is clicked in the [Confirmation of continuation] 
message box, the process proceeds to step [5], but when 
communication fails, the [Process failure] message box is 
displayed. Reset the module and PC network settings properly 
before repeating the process.

<When not creating a new profile>
Click the [Cancel] button.
Note)	A [Confirmation of continuation] message box is displayed. To 

cancel communication, click [Cancel].

When [OK] is clicked in the [Confirmation of continuation] 
message box, the process proceeds to step [5], but when 
communication fails, the [Process failure] message box is 
displayed. Reset the module and PC network settings properly 
before repeating the process.

[5]	 When receiving parameter files, the [Progress] dialog box is displayed.

[6]	 When the files have been received, the [Parameters received] message box is 
displayed. Click the [OK] button.

Then move on to step [8].
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[7]	 A [New project] message box is displayed when the project has been created.
Click the [OK] button..

[8]	 A workgroup display will then appear in the project tree.

[9]	 Select [1: Module definition] from the workgroup display’s contents area.
When information acquired from network modules is shown on the module 
configuration display, registration of module configuration settings can be 
confirmed.
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6  -  2	 Defining Module Configuration

When selecting [1: Module definition] in the Project window → [Workgroup] view’s contents area, the module 
configuration belonging to the workgroup will be displayed.

	 Note
•	 The actual module configuration’s chain is a workgroup.

Select [1: Module definition] from the [Workgroup] view’s contents area.

>>	The [Module configuration] screen is then displayed.
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In the [Workgroup] view’s [Module configuration] screen, module types (basic model number), module names 
(automatically named by loader if a module that acquired information has no name), and model numbers that 
belong to the workgroup are listed.

 Handling Precautions
•	 If  a module type on the list is changed, the [Confirmation of module  type 

modification] message box is displayed. When a module’s type is changed, all 
of its parameters will be initialized.

■■ Adding Modules
To add a module to the workgroup’s module configuration, select the [Add] button 
or [Add a copy] button.

●● Selecting the [Add] button to add a module
A single module with the model number NX-D15NT4T00 will be added to the 
module configuration.
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●● Selecting the [Add a copy] button to add a module
Select the module to be copied in the module list, and then click the [Add a copy] 
button.

>>	The [Add copy confirmation] dialog box will then be displayed. 
This function will also copy parameters of the copied module.

Set the copy conditions (number of copies), and click the [OK] button..
Clicking the [Cancel] button will cancel the process.
When setting the number of copies and clicking the [OK] button, the [Add copy 
completed] message box is displayed, and the designated number of copied 
modules are added.
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■■ Delete
Select the module to be deleted in the module list, and then click the [Delete] button. 
When the [Delete confirmation] message box is displayed, click the [Yes] button.

>>	The selected module will then be deleted.

■■ Edit
Have a module to edit selected in the module list, then click the [Edit] button.

>>	The selected module will then be selected in the project tree. 
Select  from the tool bar, or double click the selected position on the project 
tree to display parameters for the selected module on the project tree. 

 6  -  3	Editing Parameters (P. 6-16).

	 Note

•	 Parameters displayed in the project tree will differ according to user level. 
 ■ User Levels (P. 6-19).

■■ Set Model Number (Confirm or Change a Module’s Model Number Details)

[1]	 When information is acquired via the actual module configuration scan, it 
is usually unnecessary to change model number details. When you want to 
confirm or change a module’s model number details, select the module in the 
module list, and then select [Set model number].

>>	The [Module model number setting] dialog box is displayed.

[2]	 Select a radio button for the model number you want to change, then click 
the [OK] button. The selected model number will be changed.

	 Note

•	 When you already know the model number, it can be changed directly 
by entering it in the [Model number] text box. (Excluding basic model 
numbers)

•	 When entering a model number manually, or changing it after creating a 
project with the actual module configuration scan function, a write error will 
occur during parameter writing if it is inconsistent with the actual module’s 
model number.

•	 Initialize or change the version as necessary.  ■ Initialize (P. 6-15).
•	 “Change version” Dialog Box, page 6-64 (for information about the [Change 

version] button)  ■ User Levels (P. 6-19).
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■■ Initialize
Have a module selected for parameter initialization in the module list, then click 
the [Initialize] button.

>>	 Parameters for the selected module will be initialized.

 Handling Precautions
•	 When parameters are initialized, the module version is updated to the latest 

one that the loader recognizes. 
•	  6  -  8	 Handling Module Versions (P. 6-59)
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6  -  3	 Editing Parameters

Each parameter can be edited by performing the following steps.

[1]	 Select the module to be edited in the module configuration display list, and 
then click the [Edit] button.

>>	The selected module will then be selected in the project tree.
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[2]	 Click the [+] mark displayed on the left of the module name’s node.

>>	Categories will then be displayed.

[3]	 Click the [+] mark on the left of any category name.

>>	The parameter bank will then be displayed.
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[4]	 Click the parameter bank name.

>>	An editor grid will then be displayed for that parameter bank in the 
contents area.

•	 For basic/setup

•	 For basic/loop (extended)
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[5]	 Enter data values directly, or select an option from the combo box to change 
parameters.

•	 For combo box

■■ User Levels
Parameters displayed by the loader will differ depending on the user level.
There are three user levels in total, as shown below.
•	 Simple	 : Only basic settings are displayed.
•	 Standard	 : Standard functions are displayed.
•	 Multi-function	 : More advanced functions are displayed.

 Each module’s user manual.

[1]	 To change the user level, select [View] → [Set user level] from an open 
project, or from the [Actual module configuration] window’s menu bar.

>>	 The [User level setting] dialog box is then displayed.

[2]	 Select a level you want to change from the combo box, then click the [OK] 
button.

	 Note

•	 When the loader is started next time by the same user of the Windows, the 
user level will be the same as when the loader was terminated previously. 
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■■ Copy
Select a single parameter cell, string numbers (select all strings), or line numbers 
(select all lines), then right click and select [Copy] (or press Ctrl+C), to copy the 
selected data area to the copy buffer.

■■ Paste
Select a single parameter cell, string numbers (select all strings), or line numbers 
(select all lines), then right click and select [Paste] (or press Ctrl+V), to paste the 
data values copied to the copy buffer. Note that “select all strings” and “select all 
lines” will be pasted within the same parameter bank.
When pasting, the data setting range of the paste destination will be applied.

■■ Edit
Selecting and right clicking a single parameter cell, then selecting [Edit], enables 
you to directly change data. (Parameters normally entered in a combo box can also 
be used.)

 Handling Precautions
•	 For project names, tag names, etc., use alphanumeric character strings only. If 

Unicode strings or the like are used, they may be garbled during CSV output, 
etc.
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■■ Setting Up the Data Transfer Function between Modules
This function enables you to use monitor data or parameters from other modules as 
actual module parameters via the actual module’s user-defined bits or user-defined 
numbers.

	 Note
•	 User-defined bits and user-defined numbers are used one at a time for 

parameters each time remote data is used. 
 Network Instrumentation Module User’s Manual for Network Design 

Version (CP-SP-1313E).

 Handling Precautions
•	 The model numbers of certain modules are not compatible with the data 

transfer function between modules. 
Example: NX-D15 is not compatible with the data transfer function between 
modules.

•	 Modules using the data transfer function between modules must have 
different node IDs within the same workgroup.

•	 After setting up the data transfer function between modules, parameters 
must be written tor the actual module and other module as shown in 6  -  5	
Writing Parameters (P. 6-46). 
Write parameters for both modules or all workgroups.

•	 Do not set up data transfer function between modules for the modules that 
are using multi-loop cooperative control.

Steps for this process are shown below.
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●● Basic Steps
As an example, the Logical Operation Function’s input assignment A data will be 
used in the DI input port status of another module.
To use the Logical Operation Function, the user level must be set to [Standard] or 
[Multi-function].

[1]	 Click the down arrow on the combo box for the [Input assignment A] 
parameter setting in the [Logical operation] parameter bank.

[2]	 There are two types of combo boxes: Level 1 and Level 2. Select a user-
defined bit from Level 1, then select a number that is not being used for 
anything else from Level 2.

	 Note

•	 If the user-defined bit is already in use, the remote data name will be 
displayed in its place.

[3]	 Click the [Yes] button on the [Remote data confirmation] message box.

	 Note

•	 When clicking the [No] button, the user-defined bit number of the selected 
number will be assigned.
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[4]	 The [Remote data selection] dialog box is then displayed. 
Select the necessary data. Select [DI1 terminal status] from the targeted 
module’s [Standard bit] bank.

	 Note

•	 This data number is displayed when the far right pane is divided by channel 
or loop. If there is only one, it will be selected automatically.

[5]	 Click the [OK] button to confirm, and when exiting the [Remote data 
selection] dialog box, you can confirm that data from another module is 
selected for parameter as seen below.
Clicking the [Cancel] button in the [Remote data selection] dialog box will 
register the assigned user-defined bit number, but not the remote data.
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●● Steps for using the same remote data for multiple parameters
The following steps explain how to use remote data being used as parameters for 
different parameters within the same module.
As with basic steps, the process of registering the DI input terminal status of 
another module to the Logical Operation Function’s 2 (Input) Input Assignment A 
will be used as an example.

[1]	 Make sure the basic steps have already been completed.
In order to use the same remote data for other parameters click the down 
arrow on the combo box - 2 (input) - for [Input assignment A] in the Logical 
Operation Function as done in the basic steps.

[2]	 When selecting a user-defined bit from the Level 1 combo box, the remote 
data name is displayed in the user-defined number, which has already been 
in use on the Level 2 combo box since basic steps were performed. Select 
that. (The DI1 terminal status of D25_2 is used in the example below.)

	 Note

•	 If already in use, the remote data name will be displayed in place of the user-
defined bit’s data name.
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[3]	 Click the [Yes] button on the [Remote data confirmation] message box.

	 Note

•	 When clicking the [No] button, only the selected user-defined bit number 
will be assigned. Parameters set during the basic steps will also be user-
defined bit numbers.

[4]	 Data will already be selected in the [Remote data selection] dialog box. Click 
[OK] or [Cancel].

[5]	 You can confirm that the same remote data is being used for different 
parameters.
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●● Steps for cancelling the use of a single parameter when the same remote data is being used for 
multiple parameters

The following steps describe how to cancel single parameter use of remote data 
being used for multiple parameters. The steps performed when using the same 
remote data for multiple parameters will be used as an example. The same remote 
data will be used for the Logical Operation Function’s (Input 1 and Input 2) Input 
Assignment A.

[1]	 The same remote data is already selected from ● Steps for using the same 
remote data for multiple parameters. To only cancel some use of the remote 
data for parameters, click the down arrow in the combo boxes of those 
parameters.

[2]	 You can confirm that remote data is selected in the combo boxes.

[3]	 In the combo box, change to a user-defined bit number that hasn’t been 
assigned to remote data, or change to an option other than the user-defined 
bit. This allows you to change exclusive use of those parameters to local data. 
(In the example below, [Always 0 (Off )] has been selected in the [ON/OFF] 
option.)
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[4]	 You can confirm that only a portion of the parameters have been set to local 
data.
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●● Steps for clearing all remote data use when the same remote data is being used for multiple 
parameters

The following steps explain how to clear all remote data use when remote data is 
being used for more than one parameter.
The same remote data used for basic steps, with the Logical Operation Function’s 
Input Assignment A, will be used for this example.

[1]	 “Steps for using the same remote data for multiple parameters” 
must already be completed. To clear the use of remote data for multiple 
parameters, click the down arrow in the combo box of any parameter.

[2]	 You can confirm the remote data is selected in the combo box.

[3]-1	 After performing step [2] above, click the 2nd level’s selection status name (in 
the example above, it is the DI1 terminal status of D25_2).

[3]-2	 Click the [Yes] button on the [Remote data confirmation] message box.

[3]-3	 Click the [Clear] button on the [Remote data selection] dialog box.

Chapter 6. PARAMETER SETTINGS

6-28



[4]	 You can confirm that remote data is no longer assigned as any of the 
parameters.

	 Note

•	 If using the same remote data  while using different user-defined bit/user-
defined numbers, perform the clear process for each instance.

•	 After performing the clear process, parameters will be the same  as user-
defined bit/user-defined numbers that were being used. When assigning 
different remote data to those user-defined bit/user-defined numbers, all 
parameters using those numbers can use the remote data. 

●● Steps for clearing remote data use from the [Remote data selection] combo box
•	 Remote data use can also be cleared by right clicking numbers you want to clear 

from the Level 2 combo box, then selecting [Clear].
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■■ Display the List of Data Transfer between Modules
This function displays a list of the settings for data transfer between modules.

	 Note
•	   Chapter 5, "Function for Transmitting Data Between Modules" in Network 

Instrumentation Module User's Manual Network Design Version, CP-SP-1313E

 Handling Precautions
•	 This function shows a list of the settings for data transfer between modules. 

When changing the settings, see "n Setting Up the Data Transfer Function 
between Modules (P. 6-21).

(1)	 Select a lower level than the target workgroup from the [Project] window's 
project tree.

(2)	 In the [Project] window's menu bar, select  [View] → [Display the list of data 
transfer between modules]

(3)	 The [List for data transfer between modules] dialog box shows the settings 
for data transfer between modules. 
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[List for data transfer between modules] dialog box

●● Title Bar
Shows the workgroup name. 

●● Module name (No.)
Shows module names and numbers in the module configuration window.

●● Connections
Shows the total No. of module reception and transmission connections 

●● Connections (reception settings)
Shows how many receiving connections the module has.

●● Bits
Shows the total number of user-defined bits that the module has received.

●● Numbers
Shows the total number of user-defined numbers that the module has 
received.

●● Connections (transmission settings)
Shows how many transmitting connections the module has.

●● Records
Shows the total number of parameters that the module has transmitted.

●● [Detailed reception settings] button
Shows the [Detailed reception settings] dialog box for the selected module. 
It is disabled if the number of connections is set to 0.

●● [Detailed transmission settings] button
Shows the [Detailed transmission settings] dialog box for the selected 
module. It is disabled if the number of connections is set to 0.

●● [To clipboard] button
Copies the displayed contents to the Windows clipboard. 

●● [Close] button
Closes the [List for data transfer between modules] dialog box.
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[Detailed reception settings] window

The size of the [Detailed reception settings] window can be changed if the 
display width is not sufficient.

●● Title bar
Shows the module name.

●● Reception parameter name
Shows the name of the parameter to which data received by the receiver 
module will be written.

●● Receiving bit/number
Shows the user-defined number or bit destination for the data received 
by receiver module. The data will be written to parameters listed in the 
[Reception parameter name] column.

●● Transmitting module name (No.)
Shows transmitting module names and numbers.

●● Transmission parameter name
Shows the name of the parameters sent from the transmitting module.

●● Group title
Groups data records for each transmission source module and shows the 
transmission source module name and the number of received data records. 
Module status details can be displayed or hidden by clicking the button to the 
left of the group title.

●● [Grouping] check box
Displays or hides the group title.

●● [To clipboard] button
Copies the displayed contents to the clipboard.

●● [Close] button
Closes the [Detailed reception settings] window.
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[Detailed transmission settings] window.

The size of the [Detailed transmission settings] window can be changed if 
the display width is not sufficient.

●● Title bar
Shows module name.

●● Transmission parameter name
Shows the name of the parameter to be sent.

●● Receiving module name (No.)
Shows receiving module names and numbers.

●● Receiving bit/number
Shows user-defined number or bit destination for data received by receiver 
module. The data will be written to the parameter listed in the [Reception 
parameter name] column.

●● Reception parameter name
Shows the name of the parameter to which data received by the receiver 
module will be written.

●● Group title
Groups data records for each destination module and shows the destination 
module name and the number of data records sent. Module status details can 
be displayed or hidden by clicking the button to the left of the group title.

●● [Grouping] check box
Displays or hides the group title.

●● [To clipboard] button
Copies the displayed contents to the clipboard.

●● [Close] button
Closes the [Detailed transmission settings] window.

 Handling Precautions
•	 If there is no corresponding module (no destination module for the data that 

was read, etc.), a warning appears for the appropriate item. 
Details about the warning can be seen by hovering the mouse pointer over 
the warning icon.
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■■ Logical Operation Display
This function displays a list of the settings for logical operations.

[1]	 Select the [Logical operation] parameter bank.

[2]	 Select [Edit] → [Display logical operation definition window] from the 
project window menu bar.

[3]	 The logical operation settings are displayed in the [Logical operation] 
window.
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■■ Line Graph Display
This function displays the linearization table settings.

[1]	 Select the [Linearization table] parameter bank.

[2]	 Select [View] → [Display line graph] from the Project window’s menu bar.

[3]	 The linearization settings are displayed in the [Line graph] window.
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■■ Setup of Multi-Loop Cooperative Control
Select the [Cooperative Control (Set by Group)] category of the supervisor module 
from the project tree.

Click the [Set/Edit] button in the group settings list in the contents area. 
The screen for configuring the advanced settings for cooperative control is 
displayed. Configure the settings. For details, refer to Network Instrumentation 
Module NX-S11/12/21 Supervisor Module User’s Manual Functions (CP-SP-
1324E).

Chapter 6. PARAMETER SETTINGS

6-36



■■ Data Check
With a project open in the Project window, selecting [Edit] → [Data check] from 
the menu bar enables you to check the parameters of all modules registered to the 
project. If no problems are indicated by the data check results, the following will be 
displayed.

If problem(s) are indicated by the results, the following [Data check] message box is 
displayed.

	 Note
•	 The setting range will be inspected during normal input, but changing upper/

lower limits, or altering the decimal point position, etc. will check the range of 
other settings if they are changed. 
Fields output to each line of the error display are as follows.

No. Description
1 The mapping data module’s IP address
2 Module name
3 The parameter category name
4 The parameter bank name
5 The parameter item name
6 Error message
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6  -  4	 Mapping

■■ Overview
Mapping is to associate a module configured via workgroup with an actual module.
Mapping data are module communication settings.
Mapping data can be set up in the view of [Mapping], on the Project window’s 
project tree.
If there is an available module, you can use the actual module configuration scan 
function to acquire module configuration and actual module communication 
settings, and set up mapping data automatically.
Module communication settings will be defined and written to the module in the 
[Actual module configuration] window.
If there is not any available module, you can set module communication settings as 
mapping data in advance by following this mapping procedure.

■■ Creating a Mapping
Since a mapping can be created when you create a project, or when you use the 
actual module configuration scan function, the tasks described in this section are 
usually not necessary.
When you want to delete and re-create the mapping, follow the steps described 
below.

[1]	 Go to the Project window’s project tree and select the [Mapping] workgroup 
for creating mapping data. Confirm that mapping data is empty in the [List] 
screen,  then select [Add].
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■■ Editing Mapping Data
When you use the actual module configuration scan function to acquire module 
configuration and actual module communication settings, mapping data can be set 
up automatically. Therefore, the tasks described in this section are not necessary. 
When you create a project offline, a mapping will be created, but mapping data will 
not be set up.

To edit mapping data, perform the following steps.

[1]	 Select the [Mapping] workgroup from the Project window’s project tree.
Confirm that the mapping data is displayed in the [List] screen, and click the 
[Edit] button.

[2]	 The [Individual Mapping] screen is then displayed.

Chapter 6. PARAMETER SETTINGS

6-39



[3]	 Set the IP address and node ID. Clicking the text box enables you to enter 
them directly. Also, by clicking [Automatic numbering], setting the first IP 
address and node ID in the [Automatic module numbering] dialog box, and 
clicking the [OK] button, you can perform setup via consecutive numbering.

	 Note
•	 If multiple workgroups are on the same network, workgroup ID will be used for 

identification.

■■ Editing/Managing Communication Settings
Communication settings other than the module’s IP address and node address are 
set via the Mapping view’s [Set communication].
You can set the following.

Settings Screen

Type Name Description
All

(page 6-41)
Chain Name
(page 6-42)

Basic settings for 
module

Set the following value to 
all modules

Checks this box when performing the 
automatic address numbering prohibition 
function for all modules.

❍ —

Automatic address 
numbering is prohibited.

Excludes modules from auto address 
numbering.

❍ ❍

IP settings Netmask IP net mask ❍ —

Default gateway IP default gateway ❍ —

Port settings Set the following value to 
all modules

Checks this box when you want port 
settings to apply to all modules.

❍ —

Dedicated communication 
port number

Cannot be changed. ❍ ❍

MODBUS/TCP port number MODBUS/TCP function’s port number ❍ ❍

CPL/TCP port number CPL/TCP communication port number ❍ ❍

RS-485
detailed settings

Set the following value to 
all modules

Checks this box when you want the 
changes to RS-485 setting to apply to all 
modules.

❍ —

RS-485 device address Device address used for host 
communication (RS-485).

— ❍

RS-485 protocol Host communication (RS-485) protocol 
selection

❍ ❍

RS-485 transmission rate Transmission speed used for host 
communication (RS-485)

❍ ❍

RS-485 bit length Bit length used for host communication 
(RS-485)

❍ ❍

RS-485 parity status With/without parity used for host 
communication (RS-485)

❍ ❍

RS-485 stop bits Stop bit used for host communication (RS-
485)

❍ ❍

RS-485 minimum response 
time

Minimum response time used for host 
communication (RS-485)

❍ ❍
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●● When configuring communication settings common to a workgroup
The steps are explained below.

[1]	 Go to the Project window’s project tree and select the [Mapping] workgroup 
for editing mapping data. 
Confirm that workgroup configuration is not empty in the [List] screen, and 
click the [Set communication] button.

[2]	 The [Communication settings (all)] dialog box will then be displayed. 
Set the necessary items, then click the [OK] button.
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●● When configuring communication settings for each module
The steps are explained below.

[1]	 Go to the Project window’s project tree and select the [Mapping] workgroup 
for editing mapping data. 
Confirm that workgroup configuration is not empty in the [List] screen, and 
click the [Edit] button.

[2]	 Select a module line in the [Individual Mapping] screen, then click the [Set 
communication] button.
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[3]	 The [Communication settings (module)] dialog box will then be displayed.
Set the necessary items, then click the [OK] button.

■■ Mapping to Actual Module with Edited Mapping Data
When there is not any available module, and module communication settings (IP 
address/node address, communication settings, etc) have been set as mapping data, 
you need to write the mapping data to the actual module before you use the module 
actually.
The steps are explained below.

[1]	 Display the mapping data to be written.
Confirm that the mapping data is displayed in the [List] screen, then click the 
[Edit] button to display the [Individual Mapping] screen.
Click the [Acquisition of actual module configuration] button at the 
[Individual Mapping] screen.

[2]	 The [Actual module configuration] window opens.
Execute an actual module configuration scan.
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[3]	 If an error with the actual module is confirmed during the actual module 
configuration scan, close the [Actual module configuration] window, and 
return to the [Individual Mapping] screen.

	 Note

 ■ Message List (P. 5-16).

[4]	 Actual module configuration data acquired through the actual module 
configuration scan is then displayed in [Actual module configuration] in the 
contents area.
* Select the chain.

[5]	 By dragging and dropping a module (illustration) under [Mapping] onto a 
module (illustration) under [Actual module configuration], the mapping 
data will be mapped to the actual module configuration information. Once 
mapping is completed, the module (illustration) under [Actual module 
configuration] will change in color from gray to black.

Drag & drop
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	 Handling Precautions

•	 If the module’s basic model number (module type) does not match up, 
drag and drop cannot be performed. In this case, you will have to change 
the module type in the module configuration display, or change the actual 
module. For the module model numbers of projects, check the module 
configuration screen, and for the model numbers of actual modules, click 
a module in the actual module configuration screen and check the line of 
the product model number.

	 Note

•	 If there are multiple workgroups, the same operation will have to be 
performed for each one as necessary.

•	 By holding down [Shift] and clicking to select multiple modules, then 
dragging and dropping them, mapping can be performed for multiple 
modules at once.

•	 In the tasks described in this section, you would only do mapping on the 
loader. (The mapping data is not written to the actual module.) 
To write the mapping data to the actual module, write actual module 
communication settings from the [Actual module configuration] window.
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6  -  5	 Writing Parameters

Parameters can be written to all modules in a workgroup at once, or to an individual module.

 Handling Precautions
•	 In any of the following cases, the module is reset (restarted) after parameter 

writing is complete. Then confirm the operational status.
•	 NX-D15/25, ROM version 1.xx
•	 There is a supervisor module or a module under the control of a supervisor 

module
•	 A controller module is removed from under the control of a supervisor 

module
•	 The NX-D25/35 and the project have different settings for the cycle period 

parameter.
In modules (NX-D15/25 with ROM version 2.00) that do not fit into one of the 
categories above, and in digital/pulse input modules, the device operation 
mode changes to IDLE mode during parameter writing.
To display the ROM version of the NX-D15/25/35, in the SLP-NX project tree, 
select the module that read the parameters. Under the Other category, in the 
Instrument Information bank, “2.00” is displayed as the F/W ROM version 1 
parameter. In this case, the ROM version is Ver. 2.00.

■■ Workgroup Batch Writing
This is a method for writing parameters to all modules in a workgroup.
This method is possible only via Ethernet. (USB loader cable is not supported.)
Set up the communication path and network profile in advance.

[1]	 Select a workgroup from the Project window’s project tree for batch 
parameter writing. 
By performing one of the following operations, all parameters can be written 
to modules belonging to the workgroup.

•	 Select [3: Parameter writing] under [Operation list] in the [Workgroup] 
view’s contents area.

•	 Select [Online] → [Write Parameters ] from the Project window’s menu bar.

•	 Select the  icon from the Project window’s tool bar.
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[2]	 When the [Confirmation of parameter write] message box is displayed, click 
the [Yes] button to write parameters.

[3]	 When writing parameter files, a [Progress] dialog box is displayed.

[4]	 When writing is completed normally, and the [Parameter sending complete] 
message box is displayed, click the [OK] button to end the process.

If writing is completed abnormally, error information will be displayed.
After dealing with the error situation, write parameters again.
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■■ Writing to a Single Module
This is a method for writing parameters to all modules in a workgroup.
When writing parameters to a single module, it can be performed via Ethernet, 
or via USB loader cable. Set up the communication path and network profile in 
advance (when using Ethernet).

 Handling Precautions
•	 When using a USB loader cable, the USB driver must be installed in advance. 

 1  -  4	 Installing the USB Loader Cable Device Driver (P. 1-4).

•	 The communication path for the USB loader cable cannot be set unless the 
project has been configured with one module. 
If the project is configured with multiple modules, the USB loader cable 
cannot be used.

•	 To use the data transfer function between modules, the project must be 
configured with multiple modules. 
In order to be executed, the data transfer function between modules 
needs the setting information of the modules between which data will be 
exchanged. 
Do not read the parameters as a single module and then write them, because 
the data transfer function between modules may operate in an unintended 
way.

[1]	 Select a module from the Project window’s project tree for parameter writing. 
Parameters can be written to the module via one of the following methods.

•	 Select [3: Parameter writing] under [Operation list] in the [Workgroup] 
view’s contents area.

•	 Select [Online] → [Write Parameters] from the Project window’s menu bar.

•	 Select the  icon (when using Ethernet) or the  icon (when using 
USB loader cable) from the Project window’s tool bar.

[2]	 Steps after this are the same as with  ■ Workgroup Batch Reading 
(P. 6-56).
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 Handling Precautions
The following warnings may be shown depending on the write module 
selection and combination.

•	 Cannot write to the specified model number

Change the model number to the actual module number using the [Module 
model number setting] dialog box.

•	 Selection and attempt to write to a single module that is configured for 
data transfer between modules.

Select the workgroup and try again.

•	 Selection and attempt to write to a single module that is being used for 
multi-loop cooperative control.

Select the workgroup and try again.
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• Different module versions

The actual module version is earlier than the module version stored in the 
project. Make the versions the same.  

 6  -  8	 Handling Module Versions (P. 6-59)
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6  -  6	 Monitoring Module Operations

■■ Overview
Monitoring of module operations is done in the [Universal monitor] window.

 Chapter 7.	 UNIVERSAL MONITOR (P. 7-1).

 Handling Precautions
•	 When changing parameters in the universal monitor, the changes are applied 

to modules, so the loader’s project data remains unchanged. If the changes 
need to be applied to the project data as well, perform parameter reading.

■■ Method of Operation
A simple sequence method is explained as follows.

[1]	 Select a workgroup from the Project window’s project tree to display the 
[Workgroup] view. Perform one of the following operations to start up the 
universal monitor.

•	 Select [4: Monitor] under [Operation list] in the contents area.

•	 Select [Online] → [Monitor] from the Project window’s menu bar.

•	 Select the  icon from the Project window’s tool bar.

>>	 The Universal Monitor Startup dialog box is then displayed.

[2]	 When the startup process has ended, the [Universal monitor] window will be 
displayed.

Chapter 6. PARAMETER SETTINGS

6-51



[3]	 When selecting [Monitor] → [Start] from the [Universal monitor] window’s 
menu bar, the status bar’s communication status will change from [Wait] to 
[OK], and the monitor will start up.

•	 Monitor startup operation

•	 After monitor startup 
(When a module is selected for monitoring from [Module configuration] 
at the [Universal monitor] window’s monitor tree.)
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[4]	 To change a specific module’s parameters and operational status, select a 
target module from the [Universal monitor] window’s monitor tree, display 
the numeric monitor settings tab, double click the target for performing 
numeric grid changes, change values in the [Writing online] dialog box, and 
click the [OK] button to confirm the changes.

[5]	 To cancel a monitor operation, select [Monitor] → [Stop] from the [Universal 
monitor] window’s menu bar.
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[6]	 When cancelling a monitor operation, the [Universal monitor information] 
message box is displayed, asking whether or not a CSV-format trend log file 
should be output. 
If a trend log file is needed, click the [Yes] button.

	 Note

•	 Even when clicking the [No] button, a CSV-format trend log file can still be 
created.

•	 [1]	 Select [File] → [Log file conversion] from the [Universal monitor] 
window’s menu bar.

•	 >> The [Open log file] dialog box will then be displayed.
•	 [2]	 Select a file that you want a CSV-format trend log file output from, and 

click the [Open] button.
•	 >> The [Save As] dialog box will then be displayed.
•	 [3]	 Click the [Save] button.
•	 >> �A CSV-format trend log file is created, and the [Universal monitor 

information] message box is displayed.
•	 [4]	 Click the [Yes] button, and Explorer will start up.

[7]	 To exit the universal monitor, select [File] → [Exit] from the [Universal 
monitor] window’s menu bar.
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6  -  7	 Reading Parameters

■■ Overview
There are two methods to read parameters: parameter reading on a workgroup 
basis. and parameter reading on a module basis.

■■ Workgroup Batch Reading
This is a method for reading parameters from all modules in a workgroup.
This method is possible only via Ethernet. (USB loader cable is not supported.)
Set up the communication path and network profile in advance.

[1]	 Select a workgroup from the Project window’s project tree for batch 
parameter reading. By performing one of the following operations, 
parameters can be read from all modules belonging to the workgroup.

•	 Select [5: Parameter reading] under [Operation list] in the [Workgroup] 
view’s contents area.

•	 Select [Online] → [Read Parameters] from the Project window’s menu bar.

•	 Select the  icon from the Project window’s tool bar.

[2]	 When the [Confirmation of parameter read] message box is displayed, click 
the [Yes] button to read parameters.
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[3]	 When reading parameter files, the following [Progress] dialog box is 
displayed.

[4]	 When reading is completed normally, and the [Parameters received] 
message box is displayed, click the [OK] button to end the process.

If reading is completed abnormally, error information will be displayed in a 
message box.
After dealing with the error situation, read parameters again.
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■■ Reading from a Single Module
This is a method for reading parameters  on a single module basis.
The parameters of a single module can be read via Ethernet, or via USB loader 
cable. Set up the communication path and network profile in advance (when using 
Ethernet).

 Handling Precautions
•	 When using a USB loader cable, the USB driver must be installed in advance. 

 1  -  4	 Installing the USB Loader Cable Device Driver (P. 1-4).
•	 The communication path for the USB loader cable cannot be set unless the 

project has been configured with one module. 
If the project is configured with multiple modules, the USB loader cable 
cannot be used.

•	 To use the data transfer function between modules, the project must be 
configured with multiple modules. 
In order to be executed, the data transfer function between modules 
needs the setting information of the modules between which data will be 
exchanged. 
Do not read the parameters as a single module and then write them, because 
the data transfer function between modules may operate in an unintended 
way.

[1]	 Select a module from the Project window’s project tree for parameter 
reading. Parameters can be read from modules via one of the following 
methods.

•	 Select [5: Parameter reading] under [Operation list] in the contents area.

•	 Select [Online] → [Read Parameters] from the Project window’s menu bar.

•	 Select the  icon (when using Ethernet) or the  icon (when using 
USB loader cable) from the Project window’s tool bar.

[2]	 Steps after this are the same as with ■ Workgroup Batch Reading (P. 6-56).
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6  -  8	 Handling Module Versions

Each Network Instrumentation Module has a module version for the management of parameter compatibility.
This section describes the relationship between module version that the SLP-NX stores for projects and the actual 
module version that is used for parameter read and write, and how to manage versions.

Relationship between the loader module version and the actual module version
If the loader creates a project off-line, it is configured using the latest module 
version recognized by the loader. Each module has its own module version. The 
procedure when parameters are written is as follows.
•	 If the actual module version is newer than or the same as the module version 

stored in the project, parameters can be written. 
If the actual module version is not supported by the loader, the [Parameter 
initialization module selection] dialog box appears.

•	 If the actual module version is older than the module version stored in the 
project, an error occurs. If the loader can communicate with a module, the 
module version in the project can be changed using the [Compare module 
versions] dialog box. If there is no actual module, the module version setting can 
be changed using the [Change version] button in the [Module model number 
setting (controller)].

Once parameters are read from an actual module, the module's actual version is 
stored in the project.
If a data check or parameter write is executed after a module version in the project 
is changed, the parameters are converted to a set of parameters that are appropriate 
for the module version.

■■ Compare module versions

[1]	 In the [Project] window's menu bar, select  [Online] → [Compare module 
versions].
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[2]	 Select a workgroup from the workgroup list on the left.

>>	A list of workgroup modules, including module names, model numbers, 
IP addresses, and project module versions, is displayed. At this point, 
since the loader has not acquired data from the modules, the columns for 
[Actual module ver.], [Difference], and [Not supported] are shown as 
"Not retrieved" or blank.

[3]	 Check the check boxes under [Target] for the modules you want to compare 
and click the [Online retrieval] button. All check boxes in the column can be 
selected or deselected using the [Select all] or [Deselect all] buttons.

>>	Module version information is collected from the target modules and is 
reflected in the columns for [Actual module ver.], [Difference], and [Not 
supported].
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	 Note

•	 The [Difference] column indicates "writable" or "unwritable" if there is a 
difference in versions between the project and the actual module. 
If the module is not supported by the loader, "*" is shown in the [Not 
supported] column, as seen below.

[4]	 To apply the module version information that was read from the actual 
module to the project, click the [Apply to Project ver.] button.

>> The information is applied to the project.
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	 Note

•	 If [Apply to Project ver.] is executed from the [Compare module versions] 
dialog box, data checking or data check processing at the beginning of 
parameter writing is executed, and any increase or decrease in the actual 
parameters is applied to the project.

•	 If the loader executes [Apply to Project ver.]  for an unsupported module 
version, the message seen below is displayed.

In addition, after the data is applied to the project, the [Compare module 
versions] dialog box is displayed as shown below.
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■■ [Change version] dialog box
Even if there is no actual module, the module version in the project can be changed 
in advance using the [Change version] dialog box.

[1]	 With the desired module selected in the target column of the module list, 
click the [Set model number] button.

>> The [Module model number setting] dialog box is displayed.

[2]	 Click the [Change version] button.

>> The list box shows the module versions that can be selected. Choose the 
desired version and click the [OK] button. To change the module version 
stored in the project, click the [OK] button in the [Module model number 
setting] dialog box.

	 Note

•	 If a module version is changed using the [Change module version] dialog box, 
an increase or decrease in actual parameters is applied to the project by means of 
a data check (P. 6-37).

 Handling Precautions
•	 Initializing using the [Initialize] button in the [Module configuration] window 

changes the module versions in the project to the latest ones recognized by 
the loader.
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 Handling Precautions

•	 If the loader attempts to read a module, and the module's version is not 
supported, the following warning appears.

•	 If the loader attempts to write parameters to a module whose version is 
not supported by the loader, a warning dialog box like the one below is 
displayed.

>> It is possible to initialize parameters that the loader does not recognize. 
The background of modules that do not need initialization is dark. The 
[Initialization target] check box is displayed for all unsupported module 
versions that need initialization. In the dialog box they are automatically 
selected as initialization targets. Select the desired "initialization target" 
modules by checking or unchecking individual [Initialization target] 
check boxes or clicking the [Select all] or [Deselect all] buttons. When the 
[Continue] button is clicked, initialization and parameter writing begin 
for the target modules. For modules with no check mark or with a dark 
background, parameters are written without initialization. 

 Handling Precautions

•	 If there is an initialization target module, writing parameters takes up to 
about 2 minutes.
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■■ Overview
This section describes how to save a project as a file.

■■ Method of Operation

[1]	 A project file can be saved by using one of the following methods.

•	 Select [File] → [Save] from the Project window’s menu bar.

•	 Select [File] → [Save as] from the Project window’s menu bar.

•	 Select the  icon from the Project window’s tool bar.

[2]	 When saving a new project, or saving a project under another name, the 
[Save project] dialog box will appear. Set the saving options (name, location) 
and click the [OK] button.

[3]	 When the file has been successfully saved, and the [Save project] message 
box is displayed, click the [OK] button.

6  -  9	 Saving a Project
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 Handling Precautions
•	 The following characters are not allowed in a project name.

. (period)
: (colon)
" (quotation marks)
<> (less-than, greater-than signs)
| (vertical bar)
/  (slash)
\ (back slash)
? (question mark)
* (asterisk)

	 Note
•	 The project file is kept in a folder (of multiple files). When moving the project 

file to a different destination, move the entire folder.

•	 Starting with SLP-NX version 5.00, project files are created in the SLX2 format.	
SLX2 project files are not compatible with SLX files.	
Therefore, SLP-NX 4.01 and earlier versions cannot open SLX2 project files.	
To open SLX project files using SLP-NX 5.00 choose the file type “SLP-NX 
project file (*.SLX)” to display them in the file list, and select the desired file.	
When opened, the file is converted to SLX2.	
The original SLX project files are automatically saved in a backup folder.
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6  -  10	 Opening a Project

■■ Overview
Saved projects can be opened again with the loader.

■■ Method of Operation

[1]	 The project file can be opened using either of the following methods.

•	 Select [File] → [Open] from the project window menu bar.

•	 Click the icon on the project window tool bar.

[2]	 When the project is opened, a [Confirmation of opening] message box will 
be displayed.

To exit a project that is already open, click the [Yes] button.
If you don’t want to exit the open project, click the [No] button.

	 Note

•	 Even if the [Yes] button is clicked and work proceeds, if the work is cancelled 
in step [3] or later, the project that was already open will return to the opened 
condition.
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[3]	 The [Open] dialog box will then be displayed.
If a previously saved project exists, that project is designated as the initial 
value.
If you want to go with the previously saved project, click the [Open] button, 
and if you want to open a different project, designate it and click the [Open] 
button.
If you want to cancel, click the [Cancel] button.

[4]	 Once reading of the project file has completed, a [Reading projects] message 
box is displayed. Click the [OK] button, and a Workgroup view is displayed.
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6  -  11	 Output to CSV File

■■ Overview
All module parameter settings registered to the project (including IP address, etc.) 
can be output to a CSV file. 

■■ Method of Operation

[1]	 Select [File] → [CSV output] from the Project window’s menu bar.

[2]	 In the [Save as] dialog box, specify a [Location] and [File name], then select 
[Save].
The CSV file will be output.
Fields output to each line are as follows.

No. Field Name Description
1 IPAddress The mapping data module’s IP address
2 WorkgroupID The mapping data module’s workgroup ID
3 WorkgroupName The workgroup’s name
4 ModuleName The module’s name
5 ModuleType The module’s model number
6 NodeID The mapping data module’s node ID
7 FolderName Parameter category name
8 BankName Parameter bank name
9 Name Parameter item name

10 Number Sequential number of the same parameter
11 DataType Parameter type
12 RAM Address RAM address for access via host communication
13 EEPROM Address EEPROM address for access via host communication
14 Value Setting value
15 DefaultValue Initial value (default)
16 Diff Difference from initial value (default) output with “*” mark
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 Handling Precautions
•	 For project names, tag names, etc., use alphanumeric character strings 

only. If Unicode strings or the like are used, they may be garbled during 
CSV output, etc.

	 Note
•	 Parameters output via CSV file output are organized by user level. 

 6  -  3	 Editing Parameters (P. 6-16), and the user manual of each module.
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Chapter 7.	 UNIVERSAL MONITOR
7  -  1	 Monitoring Function Overview

Universal monitor is used for monitoring the module status, or verifying the operation status during test running or 
actual running after a parameter is changed, etc. 

 Handling Precautions
•	 Universal monitor does not include general-purpose 24-hour data-logger 

functionality. 
It can be used for temporary monitoring such as in test-run adjustment. 
Please do not use the universal monitor function for long-term data sampling 
or continuous alert monitoring, etc. 
Because universal monitor is not an application software designed for long-
term operation, such usage may result in the stoppage of data sampling, 
effects on the other application software due to a high load on the computer 
being used, or insufficient hard-disk space. 
Make sure that the computer’s power option settings will not allow it to go 
into sleep or standby mode when universal monitor is operating. Also, be 
sure to ensure that there is sufficient space on the hard disk by checking it 
and moving log files accordingly, etc., even when not using this function 
continuously.

■■ Universal monitoring flow of operation

Starting Universal 
Monitor

page 7-2
Universal Monitor Window 
page 7-3 
- Simple monitor operations 
- Available windows 
- Performing the monitoring

Offline 
page 7-41 
- Redisplaying and analyzing 

the collected trend log

Settings 
page 7-28 
- Setting dialog box

Custom Monitoring
page 7-33 
- Customizing the monitoring 

target 

Trend Memo 
page 7-39 
- Registering/listing a memo in 

the trend graph 
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Start the universal monitor using one of the procedures below: 
•	 In the workgroup display of the [Project] window, select [4. Monitor] from the [Operation list]
•	 Select [Online] → [Monitor] from the menu bar of the [Project] window. 
•	 Click the  icon on the tool bar of the  [Project] window. 

The selection of [Online] → [Monitor] from the menu bar of the [Project] window is shown below. 

The following window is displayed after starting the Universal monitor.

	Note
•	 Universal monitor will operate with a user level based on the status when it was 

started. To change the user level of parameters for the universal monitor, make 
the changes (“6-3 Editing Parameters (page 6-16)” ), and then close and restart 
the universal monitor. While the universal monitor is open, even if the module 
configuration is changed, the changes are not reflected in the universal monitor. 
If you change the module configuration (“6-2 Defining Module Configuration 
(page 6-11)), close and restart the universal monitor.

•	 When the [Universal monitor] window is closed, the position of each window 
is stored and windows are displayed the same way when the program is started 
next. 

7  -  2	 Starting Universal Monitor
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7  -  3	 Universal Monitor Window

The structure of the [Universal monitor] window is shown below. 

[Monitor tree] [Trend monitor] [Trend group] [Bit display monitor]

[Numeric monitor] Tab
[Crossline data] Tab Numeric Monitor and Crossline Data

[Alarm monitor] Tab
Tool Bar
Menu Bar

Status Bar

Numeric Monitor
[Monitor] Tab

Numeric Monitor
[Settings] Tab

Title Bar

Categories 
Individual

The window names and functions displayed in the [Universal monitor] window are as follows. 
The window can switch between floating and docking modes.

●● [Monitor tree] window
In conjunction with the [Numeric monitor] window, displays a list of monitored 
modules and loops that can be selected.  

●● [Trend monitor] window
Displays graph data for each monitor in real time.

●● [Trend group] window
Shows graph view/hide, colors, and the latest data values for the [Trend monitor] 
window. 

●● [Bit display monitor] window
Displays the bit display target parameters for the module(s) selected in the [Monitor 
tree].

●● [Alarm monitor] window
Displays alarm status in a grid and in front automatically when an alarm occurs.
Also, if the mouse cursor is placed over the [Alarm monitor] tab, the [Alarm monitor] 
window will be displayed in front. 

●● [Numeric monitor] window
Displays in a grid the parameters of modules and loops selected in the [Monitor 
tree], making them editable. When the [Numeric monitor] tab is clicked, the 
[Numeric monitor] window is displayed. 
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	 Handling Precautions

•	 When the [Setting] tab of the [Numeric monitor] window is selected, an 
editable grid is displayed. Changes cannot be made with the [Monitor] 
tab. Also, depending on the parameters, changes cannot be made in some 
cases. 

 user’s manual for each module.

●● [Crossline data] window
Displayed when the [Crossline data] tab is clicked. Displays the crossline cursor 
value from the [Trend monitor] window. This can be used when monitoring is 
being stopped. 

■■ Project Window - Menu Configuration List
Menu Submenu 1 Submenu 2 Description Remarks

File Log file Open log file Reads the log file (CSV format) and displays the 
trend monitor.

Enabled only when 
monitoring is being 
stopped.Open log file [Multi-

time mode]
Reads multiple log files (CSV format) and groups 
the data if the same data type exists.

Log file conversion — Select the file and then select the output format.
 n Log File Conversion (P. 7-42).

Custom data 
processing

Import Selects a custom data file (XML format) from 
the Select File dialog box and adds it to the 
custom items.

Export Writes the items currently registered in the 
custom monitor to the custom data file (XML 
format).

Copy graph to 
clipboard

— Copies the graph drawing region of the trend 
monitor to the Clipboard.

Start control profile — Not supported —

Exit — Closes the [Universal monitor] window. Enabled only when 
monitoring is being 
stopped.

Monitor Start — Starts monitoring. Enabled only when 
monitoring is being 
stopped.

Stop — Stops monitoring. (The graph is not cleared.)
After monitoring is stopped, the [Universal 
monitor information] dialog box is displayed, 
prompting whether to output a CSV file of the 
trend log.

The graph is not cleared 
until [Start] is selected 
again.

Settings Edit monitoring data —  7  -  7	 Custom Monitoring (P. 7-33) Enabled only when 
monitoring is being 
stopped.

Communication 
destination

—  n Communication destination (P. 7-28)

Monitor settings —  n Monitor settings (P. 7-28)

Trend color settings —  n Trend monitor color settings (P. 7-30)

Options —  n Options (P. 7-31)

Record View trend memo —  7  -  8	 Trend Memo (P. 7-39) —

Trend memo 
registration

—  7  -  8	 Trend Memo (P. 7-39) —
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Menu Submenu 1 Submenu 2 Description Remarks

Window Fixed-position 
window

— Prohibits floating of windows. Turn ON/OFF by adding/
removing a check mark.

Return to standard 
position

— Returns the position of each window to their 
standard positions.

Enabled only when the 
[Fixed-position window] 
menu item is OFF.

View Monitor tree Displays the [Monitor tree] window. If the window is already 
displayed, it becomes 
active.

Trend monitor Displays the [Trend monitor] window.

Crossline Data Displays the [Crossline data] window.

Trend Group Displays the [Trend group] window.

Numeric monitor Displays the [Numeric monitor] window.

Alarm monitor Displays the [Alarm monitor] window.

Bit display Monitor Displays the [Bit display monitor] window.

Logical operation 
monitor

Displays the [Logical Operation Definition] 
window.

Favorite Add to favorites Registers the current window configuration. —

Organize favorites Changes or deletes the names of window 
configurations registered to favorites.

—

Help Show help — — Nothing is displayed.

About (version info) — Displays the [Version] dialog box. —

 Handling Precautions
•	 The import for custom data processing checks whether there are 

corresponding items for node numbers, IP addresses and model numbers. 
If matching items do not exist, a warning is displayed during the import. In 
this case select [Settings] → [Edit monitoring data], and check the custom 
monitoring settings. 

 7  -  7	 Custom Monitoring (P. 7-33) 
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■■ Window configuration operations
The [Universal monitor] window consists of multiple windows placed together. 
Size adjustments, as well as switching between floating and docking modes, can be 
made by dragging these windows.

●● Positionally fix window
By selecting [Window] → [Fixed-position window] from the menu bar of the 
[Universal monitor] window, the positions of all windows are fixed, and floating is 
prohibited.  
With a check mark, all windows have a fixed position.

●● Return to standard window position
Clicking on [Window] → [Return to standard position] from the menu bar of the 
[Universal monitor] window will return all windows to their standard positions. 

	 Handling Precautions

•	 [Return to standard position] is only enabled when [Fixed-position 
window] is not checked. 

●● Window redisplay
From the pop-up menu displayed by clicking [Window] → [View] from the menu 
bar of the [Universal monitor] window, the selected window is displayed in front. 

●● Window position memory
When the [Universal monitor] window is closed, the position of each window is 
stored and each window is displayed in the same position when the program is 
started next. 

●● Closing windows
To close a window, click the  icon on the window’s title bar. 
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7  -  4	 Starting or Stopping Monitoring

■■ Starting monitoring

[1]	 Select [Monitor] → [Start] from the menu bar of the [Universal monitor] 
window.

>>	Monitoring begins.

[2]	 Select [Module] in the [Monitor tree].

>>	[Numeric monitor] and [Bit display monitor] are displayed. 

	 Handling Precautions

•	 Do not edit or delete module configurations when monitoring is being 
started. When changing module configuration, close the [Universal 
monitor] window, and restart it after writing to the module(s). 

•	 When using the Universal monitor with a USB loader cable in an 
environment with multiple modules, do not connect the USB loader cable 
to a different module after starting monitoring. Restart the SLP or reopen 
the project. 

■■ Stopping monitoring

[1]	 Select [Monitor] → [Exit] from the menu bar of the [Universal monitor] 
window.

>>	The [Universal monitor information] message box is displayed.

	 Note

•	 Even if the [No] button is selected, monitoring will stop. 
To reopen monitoring, follow the procedure in ■ Starting monitoring. 

•	 Even if the [No] button is selected, a CSV-format trend log file can be created 
afterward using the procedure below.
1.	 Select [File] → [Log file conversion] from the menu bar of the [Universal 

monitor] window. 
2.	 Select a CSV-format trend log file as the file that you want to output in 

the [Open log file] dialog box that is displayed. 
3.	 Click the [Open] button. 
4.	 Click the [Save] button in the [Save As] dialog box. �
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[2]	 When outputting a trend log file, click the [Yes ] button.

>>	A trend log file (CSV format) is created, and the [Universal monitor 
information] message box is displayed confirming whether or not to open 
the location where the file was stored with Explorer.

[3]	 To confirm the CSV-format trend log file with Explorer, click the [Yes] 
button.

>>	The output trend log file (CSV output) is displayed in Explorer. 
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7  -  5	 Explanations of Individual Windows

■■ Monitor tree window
The Monitor tree window is as follows.

 

➞

 

●● Display items
The following items are displayed in the tree, starting from the left.
•	 [Data sampling switchover] check box 

Displays the [Data sampling switchover] check box for a project, workgroup or 
module. There is no data sampling of modules that are not selected for sampling, 
and therefore trend graphs, trend groups, numeric monitor, bit display monitor 
and alarm monitor are not updated.

•	 Check status or projects and workgroups
 Icon:	Sample data from modules in the project/workgroup.
 Icon:	Does not sample any data from modules in the project/workgroup.
 Icon:	� Mixed status: some data from modules in the project/workgroup is 

sampled and some is not.
Note that there are only 2 possible settings for the project/workgroup check boxes: 
sample and do not sample. To switch the sampling status, click the icon portion.
•	 Check status of modules

 Icon:	Samples data from module
 Icon:	Does not sample data from module.

To switch the sampling status, click the icon portion.
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•	 Module communication status icons 
Icons are displayed that indicate the status of communication with the modules, 
and the module communication status resulting from the module status. Icons 
also identify which modules are controlled by the supervisor module.
Communication 

status
Module status

Controlled by the supervisor module
No Yes

Communication 
standby

Communication 
interruption

IDLE mode
(blinking) (blinking)

RUN mode

Soft Failure

Soft Failure idle
(blinking) (blinking)

Hard Failure

Initializing

●● Configuration
The [Default] and [Custom] tabs make up this window. 
•	 [Default] tab 

Displayed based on each category and the individual units for categories for the 
workgroup configuration.

•	 [Custom] tab 
Information is displayed in the [Custom] tab once the custom monitoring 
function (“7  -  7	 Custom Monitoring (P. 7-33)”) has been registered. 

●● Coordination with the [Numeric monitor] window and the [Bit display monitor] window
The [Numeric monitor] window and the [Bit display monitor] window are 
displayed in conjunction with the selection of modules and module categories. 
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●● Right-click menu

Menu items Functions Remarks

Copy data Copies the level of the 
monitor tree.

—

Paste data Pastes the copied level to 
the applicable level. This 
menu is enabled when the 
[Custom] tab is selected in 
the [Monitor tree] window.

—

Register to trend monitor Registers the selected tree to 
the trend monitor.

Enabled only when the 
[Custom] tab is selected in 
the [Monitor tree] window.

Move to the relevant 
module

Moves to the module to 
which the loops that are 
selected in the control group 
of the supervisor module 
belong.

Enabled only when the 
supervisor module is right-
clicked in the [Monitor tree] 
window.

Back to cooperative 
control

Returns from the module 
registered in the control 
group to the supervisor 
module.

Enabled only after moving 
with the [Move to the 
relevant module] menu 
option in the [Monitor tree] 
window.

Set date and time Sets the date and time for the 
supervisor module.

Enabled only when the 
supervisor module is right-
clicked in the [Monitor tree] 
window.

Flash ROM backup and 
restore

Displays the dialog box for 
backing up the supervisor 
module parameters to the 
flash ROM or restoring the 
parameters.

Enabled only when the 
supervisor module is right-
clicked in the [Monitor tree] 
window.
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■■ [Numeric monitor] window
The [Numeric monitor] window displays data related to a category selected in the 
[Monitor tree]. 
Example: � When modules are selected on the Monitor tree of the controller module

●● Displayed data
Displayed data comes from a model prepared as a loader from each category, the 
data from which is displayed in the [Default] tab of the [Monitor tree] window.
When the necessary data is not in this model,

 7  -  7	 Custom Monitoring (P. 7-33)

●● Right-click menu

Menu items Functions Remarks

Copy items Copies cell data. Disabled when a column or 
row header is selected.

Add copied items Adds data copied with 
[Copy items] to the end 
of the columns on the 
Numeric monitor (in the 
case of Custom).

Enabled only when the 
[Custom] tab is selected in 
the [Monitor tree] window 
and the column header 
of the numeric monitor is 
selected.

History of PID parameter 
change*

Checks the changed PID 
setting parameters.

—

Move to the relevant 
module

Switches the monitor 
tree and numeric monitor 
displays to the controller 
module to which the 
various control loops for 
cooperative control belong.

Enabled only when the 
control loop column for 
cooperative control is 
selected.

Back to cooperative control Switches the monitor 
tree and numeric 
monitor displays to the 
previous control group of 
coordination control.

Enabled only after the 
display is switched with the 
[Move to corresponding 
module] menu option.

* The History of PID parameter change function is enabled for controller modules. 

●● Settings tab and Monitor tab
The [Numeric monitor] window is divided into the [Setting] tab and the [Monitor] tab. 
In the [Setting] tab, with data writable to a module, data can only be written when 
monitoring is being started. 
Writing to EEPROM device in the case of NX-D_ _, NX-DX_ or NX-DY_.
Writing to SRAM device in the case of NX-S_ _.
In the [Monitor] tab, even with data writable to a module, data can only be viewed 
when monitoring is being started. 
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■■ Numeric grid display
The tabs of the [Numeric monitor] window are displayed in the following format 
based on a category or the individual units in a category selected in the [Monitor 
tree] window. 
•	 If a category has been selected 

The lists of the main data for the selected category and the data for the individual 
units in the category are displayed in the [Numeric monitor] window.  
If the cells of the numeric grid are clicked, item names are displayed as tool tips.

•	 If the individual units in a category have been selected 
The list of data for the individual units in a selected category is displayed in the 
[Numeric monitor] window.  
Example: �Select the controller module loop in the Monitor tree

●● Editing values
In the [Numeric monitor] window [Setting] tab, if monitoring has been started, 
•	 When a grid cell is double-clicked
or
•	 When the [Enter] key is pressed
Values can be set in the [Writing online] dialog box that is displayed. 
Clicking the [OK] button in the [Writing online] dialog box writes the input values 
to the module(s). 
If the [Cancel] button is clicked, the values entered in the [Writing online] dialog 
box are not applied. 
Based on the data type of the target value, one of the two [Writing online] dialog 
boxes below will be displayed.
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•	 Change by numeric input

Enter a numeric value in the edit box of the [Writing online] dialog box, click 
the [OK] button, and when the dialog box is closed, the value is written to the 
module.  
If the [Cancel] button is clicked, the value entered is not applied.  
When the [OK] button is clicked, a check of the upper and lower limit values of 
the edited value is performed, and if the data is out of range the entered value 
will remain the same as previously confirmed.  

•	 Change by selection

A list box is displayed in the [Writing online] dialog box.  
Select one of these from the list box and click the [OK] button. The value is 
written to the module when the dialog box is closed.  
If the [Cancel] button is clicked, the value entered is not applied. 

●● Editing the row unit value
When a row header is clicked, the data in the same row is selected.
Also, if a row header is double-clicked, the [Writing online] dialog box 
corresponding to the selected row data is displayed, and the edited value is applied 
to all selected data. 
For the initial value displayed in the [Writing online] dialog box, the value of the 
leftmost item is displayed, even in the case of an edit box or radio button. 
Example:	 If the “Set point (LSP)” cell is double-clicked and settings made with 

multiple loops displayed, all “Setting value (LSP)” for the target loops can 
be changed.
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●● Data registration to unconfigured groups in the [Trend group] window
[Monitor tree] window, if categories or individual units for each category are 
selected, the applicable data is displayed in the Numeric monitor. If a drag-and-
drop operation from the [Numeric monitor] window to a [Trend group] window 
unconfigured group is performed with either a numeric monitoring cell, column 
header, or row header selected, a trend group with the selected data range registered 
is created. 
When a column header is selected the item name is set for the trend group category 
name, when a row header is selected the column name is set, and when a cell is 
selected the module name is set.

	 Handling Precautions

•	 This operation can only be used when monitoring is being stopped.

●● Data registration to existing groups in the Trend group window
[Monitor tree] window, if categories or individual units for each category are 
selected, the applicable data is displayed in the Numeric monitor. If a drag-and-
drop operation from the [Numeric monitor] window to a [Trend group] window 
existing group is performed with either a numeric monitoring cell, column header, 
or row header selected, the data dragged from the source is added to the group data 
of the drop target. 
In this case if a column header or row header is selected, all selected column or row 
data is added.

	 Handling Precautions

•	 This operation can only be used when monitoring is being stopped.

●● History of PID parameter change (with controller modules)
If a right-click is performed with a column header in the [Numeric monitor] 
window selected, [History of PID parameter change] is displayed. 
If the [History of PID parameter change] menu is selected, the [History of PID 
parameter change] dialog box is displayed. 
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■■ Trend monitor window
The [Trend monitor] window is displayed in the following way. 

Trend monitoring can display the graphs of up to eight groups at the same time. 
If the mouse cursor is placed on the graph area, the name of the [Trend group] 
window will be highlighted. 

•	 Graph display area scrolling 
Dragging the vertical axes on the left or right, or the graph display area (left/right 
mouse button for vertical axes, right button for graph area) will scroll the graph 
rendering area. 
Scroll vertically by trend group units, or scroll the entire group when including 
the horizontal axis. 
This function can be used when rendering a graph during monitoring or 
displaying a graph after stopping monitoring. 
* Can also be used in the Universal monitor [Offline]. 
To return to initial status (entire monitor is an updated graph), use the same 
method as for cancelling [Zoom], described below. 

	 Note

•	 When scrolling only the vertical axis while monitoring is being started, graph 
rendering will be continued.  
When scrolling to the future area with the horizontal axis, graph rendering 
will continue until the graph reaches the right side of the display area, but 
will stop after it has been reached. Also, when scrolling to the past area, 
rendering will stop with the current graph. Data sampling will continue. 
Example:	 The vertical axis on the left of the graph is specified with the 

mouse pointer. 
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•	 Zoom 
By holding down the left button of the mouse and dragging from upper left to 
lower right to form a rectangle in the graph area, the graph display for the trend 
group where you performed the operation will be enlarged. 
To cancel zoom display, perform the reverse, dragging the mouse from lower 
right to upper left to draw a rectangle. 
This function can be used when rendering a graph during monitoring or 
displaying a graph after stopping monitoring. 
* Can also be used in the Universal monitor [Offline]. 
Graph rendering stops when zoom is used. 
* When zooming includes the future area, graph rendering will continue until 
the graph reaches the right side of the display area, but will stop after it has been 
reached. Data sampling will continue. 

•	 Crossline cursor 
When the mouse cursor is placed within the graph area, the lines displayed on 
the vertical axis are called crosslines. These can be used in conjunction with the 
[Crossline data] window. This function can be used for the entire group.  
* Group units are used in the [Crossline data] window. 

•	 Moving the cursor	:	 The data for points where the crossline cursor and graph 
overlap is displayed in the [Crossline data] window.

•	 Double-clicking	 :	 The starting point for the crossline cursor is established. 
(Changes to bold line display. ) If the crossline cursor is 
moved with the mouse, the start point data established 
in the [Crossline data] window and end point data for 
points overlapping with the crossline are displayed.  
* When establishing the start point, if the crossline is 
single-clicked again it is fixed as the end point. Clicking 
again cancels the fixed end point. Double-click the start 
point to cancel it.

•	 Display time	 :	 Time displayed in trend monitoring is displayed in 
relative time and absolute time, and is updated on the 
monitoring cycle. Display time is switched between 
absolute time and relative time by selecting [Settings] → 
[Options] from the menu. 

	 Handling Precautions

•	 This can be used when graph data is being displayed in the graph area. 
•	 This operation can only be used when monitoring is being stopped.  

Can also be used in the Universal monitor [Offline].

 ■ Crossline data window (P. 7-23) regarding the [Crossline data] window 
display contents. 
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•	 Absolute time	 :	 Displays the current time. The horizontal axis display 
format is “MM/dd hh:mm:ss.fff ”.

•	 Relative time	 :	 Displays monitoring start time as 0. The horizontal axis 
display format is “hh:mm:ss.fff ”. The trend graph is 
displayed in the range of 0:00:00-23:59:59, and when 24 
hours has elapsed the time display is reset to 0:00:00. 

●● Display time length (X axis on a graph)
Select [Settings] → [Monitor settings] from the menu bar of the [Universal 
monitor] window. 
The [Monitor settings] dialog box is displayed. 
Select one of the seven display lengths (1 min, 2 min, 10 min, 1 h, 12 h, 24 h, and 
automatic) in [Display time length] in [Trend graph settings]. 
Settings can also be made using  in the [Universal monitor] window 
tool bar. 

	 Note

•	 Display time length settings can be changed from the tool bar even when 
monitoring is being started. 

•	 Display length settings will be stored and become the initial settings next 
time that universal monitor is started. 

	 Handling Precautions

•	 Display time length cannot be changed by using [Settings] → [Monitor 
settings] from the menu bar of the [Universal monitor] window while 
monitoring operations are active. 
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●● Set trend high and low limit values (graph Y axis) to desired values
Select [Settings] → [Monitor settings] from the menu bar of the [Universal 
monitor] window. 
The [Monitor settings] dialog box is displayed. 
Either “Automatic” or “Fixed” (range entry setting) can be set in [Trend graph 
settings] → [High and low limits]. 

	 Note

•	 The target will be all trend groups and the left and right axes. 
•	 The same settings can be made in [Y axis high and low limits settings] in the 

[Trend group] window. This operation can be used to make settings for trend 
group units and for each left and right axis. 

	 Handling Precautions

•	 This operation is possible only when monitoring is stopped.

●● Automatic clearing of displayed data
Select [Settings] → [Monitor settings] from the menu bar of the [Universal 
monitor] window. 
If a fixed sample number (10,000 items) of data is displayed, the graph display will 
be automatically cleared. 
Settings range, etc. 

 ■ List of Value Limits (P. 9-2). 

	 Handling Precautions

•	 This operation is possible only when monitoring is stopped.

●● Zoom in, zoom out
Select the icon from the [Universal monitor] window tool bar. 

 Icon	 : Zoom in
 Icon	 : Zoom out

One click enlarges or reduces by 25%.
This can be used either when monitoring is being started or stopped. 
* The Universal monitor [Offline] can also be used. 

●● Manual horizontal scrolling
Select the icon from the [Universal monitor] window tool bar. 

 Icon	 : Return to start time

 Icon	 : Advance to most recent time

 /  Icon	 : Scrolls one-half of the screen

 /  Icon	 : Scrolls one-fourth of the screen
This can be used either when monitoring is being started or stopped. 
* The Universal monitor [Offline] can also be used. 
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■■ Trend group window
The [Trend group] window groups registered data, and can perform display in the 
[Trend monitor] window and sampling status operations. 

Items are displayed in list format.
A maximum of 32 data items can be registered in a group.
A maximum of eight registered trend groups can be displayed at the same time in 
the [Trend monitor] window. 
To display data registered to a trend group, click either the leftmost  icon or the 
group name. 

●● Display items
Items are displayed from the left side in order as follows.
•	 [Data sampling switchover] check box 

Switch the data sampling status of the trend monitor. There are two statuses, and 
their meanings are given below.  

 Icon :  Makes a trend group the target for sampling 
 Icon :  Does not make a trend group the target for sampling 

To switch the sampling status, click the icon portion.

•	 [Graph update switchover] check box 
Switches the graph view/hide status. Checks can be selected for three levels. The 
meaning of each check is given as below. 
•	 Check status of groups 

 Icon :  Views all data registered to a group 
 Icon :  Hides all data registered to a group 
 Icon :  Views some of the data registered to a group, and hides the other 

Changing the check mark for an entire group switches only between the two 
states of view/hide. To switch the view state, click the icon portion. 

•	 Check status of individual data items 
 Icon :  Display target data in graph 
 Icon :  Do not display target data in graph 

To switch the display state, click the icon portion.
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•	 Item names 
Displays group names and data names. 
If the name is longer than the display length, placing the mouse cursor over 
the name will display the entire name in a tool tip. 
For custom-registered trend groups, item names can be changed when 
monitoring is being stopped. 
<For a group name> 
Selecting [Data name change] from the right-click menu displays the [Data 
name change] dialog box in which a name can be changed. 
<For a data name> 
Double-clicking a cell or selecting [Data name change] from the right-click 
menu displays the [Data name change] dialog box in which a name can be 
changed.

•	 Graph rendering color 
Displays the line color of the corresponding graph. 
If the graph color cell is double-clicked, the [Trend graph settings] dialog 
box is displayed, and the line color, the line type, and the display axis for the 
corresponding graph can be set. 

•	 The latest data values 
The latest values of the corresponding data are displayed in real time. 
Values cannot be changed.

●● Functions
Select [Monitor] → [Start] from the menu bar of the [Universal monitor] window. 
The latest data values of the trend group and the trend graph are updated in real 
time.
Selecting [Monitor] → [Exit] from the menu stops monitoring and updating of both 
of the trend graph and the latest data values. 
The trend graph and latest data values will not be cleared until the start of 
monitoring is selected again.
The monitoring cycle can be changed to a desired value. The default is 400 msec via 
Ethernet, and 2,000 msec via a USB loader cable. 
The trend graph is automatically allocated depending on the number of graph 
display check boxes selected in each group name for trend groups.
The number of allocations is up to eight items vertically.
Allocated graphs are linked to trend group data in order from the top area.
The order in which items are displayed in trend groups can be changed by dragging 
and dropping header items when monitoring is being stopped.
By dragging and dropping definitions from the Numeric monitor or the Bit display 
monitor to the Trend group, data to monitor can be added.

	 Handling Precautions

•	 Because data sampling for the [Trend group] window and [Numeric 
Monitor] window are conducted individually, values for the same data 
may be displayed differently. 

Chapter 7. UNIVERSAL MONITOR

7-21



●● Trend group right-click menu

Menu items Functions Remarks

Full-screen display Displays only the selected group in the [Trend 
monitor] window.
The header of the group that is full-screen display in 
the window is displayed in yellow.

—

Y axis high and low limits 
settings

Displays the [Y axis high and low limits settings] 
dialog box.
Set the [Y axis high and low limits settings] for the 
selected group.

 [Y axis high and low limits settings] dialog box 
(below).

—

Digital trend switchover Switch the selected group to the digital trend setting.
The header of the selected group when set is 
displayed in blue.

Enabled only when 
monitoring is being 
stopped.

Trend graph settings Displays the dialog box for setting the line color, the 
line type, and the display axis.
Set all information of data registered under a group.

 [Trend graph settings] dialog box (below).

—

Data name change Displays the dialog box for changing the data name.
Set the name of the selected data.

 [Data name change] dialog box (next page).

Enabled only when 
monitoring is being 
stopped.

Remove from trend monitor. Enabled only when a group is selected.
Removes the selected group from the trend monitor. 
(Groups registered by default cannot be deleted.)

Remove individual data Enabled only when data is selected, and then 
removes the selected data.

•	 [Y axis high and low limits settings] dialog box 
Set the Y axis high and low limits for the applicable group.

•	 [Trend graph settings] dialog box 
Set the line color, the line type, and the display axis for the graph of the 
applicable data.
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[Data name change] dialog box 
Set the name of the applicable data.  

Click the [OK] button. 

	 Note

•	 The [Return to default.] button will be enabled when a different name is 
entered, and the name is returned to the name at the time that the dialog 
box was initiated. 

■■ Crossline data window
Crossline data is displayed as follows.

●● Display items
•	 Data name 

Displays trend group data names when moving the cursor in the [Trend 
monitor] window, or those corresponding to double-click locations.

•	 Start point value X, start point value Y 
Displays trend group start point times and values at start point when moving the 
cursor in the [Trend monitor] window, or those corresponding to double-click 
locations. 

•	 End point value X, end point value Y 
Displays trend group end point times and values at end point when moving the 
cursor or double-clicking when the start point has been established in the [Trend 
monitor] window. 

	 Note

•	 If no data exists, [–] is displayed.

•	 Y axis difference value 
Displays the difference between start point value Y and end point value Y. 

•	 Tilt 
Displays the tilt between start point values (X, Y) and end point values (X, Y). 

●● Functions
The crossline function is only enabled when monitoring is being stopped.
When the cursor is moved in the trend graph, perpendicular lines are rendered in 
the trend graph area, displaying corresponding each value for Y from the X axis 
value.
Displays the difference value/tilt between the point double-clicked on the trend 
graph and the point to which the mouse has been moved or which was clicked in 
coordinates.
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■■ Bit display monitor window
The [Bit display monitor] window is described below. 
Example:  Controller module

If a category is selected in the [Monitor tree] window, the content for bit display is 
displayed in the [Bit display monitor] window. 
It is possible to register bit data to the [Trend monitor] window by selecting it in the 
[Bit display monitor] window and dragging and dropping it in the [Trend group] 
window. 
When registering data to the [Trend monitor] window, a message to confirm 
whether to set it as a digital trend will be displayed. 
If data rows are double-clicked when monitoring is being started, the [Bit display 
monitor -- online writing] dialog box is displayed and values can be changed.

•	 [Bit display monitor -- online writing] dialog box 
If data rows are double-clicked when monitoring is being started, the [Bit display 
monitor -- online writing] dialog box is displayed.

Select one of the choices and click the [OK] button, and when the dialog box 
closes the value is written to the module.  
If the [Cancel] button is clicked, the value entered is not applied. 
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■■ Logical Operation Monitor Window
In the [Logical operation monitor] window, the settings for logical operation, input 
assignment, and logical operation results can be checked. Calculations that meet the 
conditions are displayed in red.

To display the [Logical operation monitor] window, do either of the following 
operations.
•	 On the [Universal monitor] window menu bar, select [Window] → [View] → 

[Logical operation monitor].
•	 Select  on the [Universal monitor] window toolbar. 
After either operation, the window is displayed in the regular position.

	 Note

•	 In the initial status, the [Logical operation] window is not displayed.
•	 When a module that supports logical operation is selected from the monitor 

data tree, the [Logical operation monitor] window becomes effective.  For 
example, if a workgroup is selected from the monitor data tree or if the 
version of the selected module does not support logical operation, only the 
window is displayed while the contents are not. 

■■ [Alarm monitor] window
The [Alarm monitor] window is displayed in the following way. 

When an alarm occurs, the [Alarm Monitor] window is displayed in front. 
Set the integral multiple of the monitor cycle as the alarm cycle. The default value 
is 5,200 msec. The cycle can be changed in the [Monitor settings] dialog box by 
selecting [Settings] → [Monitor settings] from the menu bar of the [Universal 
monitor] window. 

	 Note

•	 When no alarm has occurred [Alarm monitor] tab will be displayed. 
[Alarm monitor] tab display 

 7  -  3	 Universal Monitor Window (P. 7-3)
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■■ Status bar
The following information is displayed in the status bar of the [Universal monitor] 
window. 

●● Monitor time display
At the left end of the status bar, the most recent time of data sampling based on the 
monitoring cycle is displayed in the “YYYY/MM/DD hh:mm:ss.msec” format.
The difference between the time of the previous data sampling and the current time 
is displayed following the hyphen in msec.
Display example:  

●● Monitor COM status display
The communications status is displayed at the right end of the status bar.
The following three types of status are displayed.
[Wait] : Monitoring is stopped
[OK] : Monitoring is started
[Break] : Response stopped due to a communications error when monitoring is 
started
Display example:  

●● Zoom status display
The zoom status of Trend monitor is displayed at the right end of the status bar.
Operations for which [ZoomIn] is displayed are as follows.
•	 Zooming while dragging and dropping within the trend monitor
•	 When trend group header is right-clicked and [End full-screen display] is 

selected
•	 When the zoom in icon on the toolbar  is selected
Display example:  

Operations for which [ZoomOut] is displayed are as follows.
•	 When the zoom out icon on the toolbar  is selected
Display example:  

[FullScreen] is displayed in the following situations.
•	 When the [Trend group] window is right-clicked and [End full-screen display] is 

selected.
•	 When a trend group that was zoomed-in returns to full-screen status.
Zoomed-in or zoomed-out status has priority over full-screen status.
Display example:  
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■■ Version information
To display the version information of the Universal monitor, select [Help] → [About 
(version info)] from the menu bar of the [Universal monitor] window.

>>	The version information of universal monitor is displayed as follows.
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7  -  6	 Settings

■■ Communication destination

[1]	 Select [Settings] → [Communication destination] from the menu bar of the 
[Universal monitor] window.

>>	The [Communication destination] dialog box is displayed.

[2]	 The displayed content is as follows. 
•	 [Server] 

The set IP address and port number are displayed.
•	 [Module] 

Select the module to be edited from the combo box and confirm the IP 
address, port number and node address.

[3]	 After confirming, click the [OK] button.

■■ Monitor settings

[1]	 Select [Settings] → [Monitor settings] from the menu bar of the [Universal 
monitor] window.

>>	The [Monitor settings] dialog box is displayed. 

[2]	 The displayed content is as follows. 
•	 [Monitoring cycle] 

Set the monitor data sampling cycle in msec. 
The initial value is as follows, depending on the number of modules that 
are targeted for communication.

Chapter 7. UNIVERSAL MONITOR

7-28



For Ethernet communication
1 module: 		  0.4 sec 
Up to 4 modules: 	 1 sec 
Up to 16 modules:	 2 sec 
Up to 31 modules:	 4 sec

For loader jack communication	 2 sec
•	 [Graph update freq.] 

Select how frequently to update (per number of monitoring cycles). The 
initial value is “1” cycle.

•	 [Alarm cycle] 
Set the alarm information data sampling cycle in msec. 
The initial value is “5,000” msec.

•	 [High and low limits] 
Set the high and low limit values for data displayed in the graph area. 
The Y axis of the trend graph will be fixed within the range of set values if 
fixed values are selected. 
The initial setting is “Automatic.”

•	 [Display time length] 
Set the time range for data displayed in the graph area. 
The X axis displayed in the trend graph is determined according to the 
value selected in the combo box. 
The initial value is “1 min.”

•	 [Display time format] 
Sets the format of the time displayed on the trend graph’s X axis. 
The default value is “M/d HH:mm:ss.f.”

•	 [Fixed Sample] 
Specify the number of data to be held in one graph area. 
The initial value is “10,000.”

[3]	 After making the settings, click the [OK] button.

 Handling Precautions
•	 The following message may be displayed, depending on load conditions such 

as the computer load, number of modules, data sampling from monitors, and 
trend log writing. 

 
If this message is displayed, take action to restore monitor operation as 
follows.

•	 Change the monitoring cycle
•	 Reduce the number of modules monitored by removing the check mark 

from monitor tree or trend group check boxes.
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■■ Trend monitor color settings

[1]	 Select [Settings] → [Trend color settings] from the menu bar of the 
[Universal monitor] window.

>>	The [Trend monitor color settings] dialog box is displayed.

[2]	 The displayed content is as follows.
•	 [Line color] 

Select the graph’s line color. 
Clicking the target displays the [Color settings] dialog box. 

•	 [Line type] 
Select the graph’s line type. 
The six types of line are continuous, dashed, dotted, continuous (thick), 
dashed (thick), and dotted (thick).

•	 [Display axis] 
Select the display axis for the graph’s line. 
Two types of axis (right, left) may be selected.

	 Note

•	 To return all 32 colors to the default settings, click the [Return to default.] 
button.  
Initial line types are continuous for tabs [1-16] and dashed for tabs [17-32].  
Initial display axes are the left axis for tabs [1-16] and the right axis for tabs 
[17-32]. 

[3]	 After making the settings, click the [OK] button. 
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■■ Options

[1]	 Select [Settings] → [Options] from the menu bar of the [Universal monitor] 
window. 

>>	The [Options] dialog box is displayed. 

[2]	 The displayed content is as follows.
•	 [Trend time display settings] 

Set whether the trend monitor graph’s X axis will display absolute time or 
relative time from the start of monitoring.

•	 [Trend log settings] 
Set the trend log file’s core name and output target folder.
•	 Output target folder path specification

1.  Direct input
Set the entered folder as the output target. 
* �If the entered folder does not exist, a folder will be created with the 

name entered. 

	 Note

•	 If “Log” is entered, \Log in the loader installation folder will be set as the 
output target. 

2.  �If the [Browse] button is clicked to select a folder 
The output target will be set to the location selected.

	 Handling Precautions

•	 Do not set a folder on the network as the output target folder. Writing may 
not be done correctly due to temporary changes in the communication 
status.

•	 [Font settings] 
Set the font displayed in the [Universal monitor] window. Character size is 
fixed. 

•	 [Character code settings] 
Displays the character code for writing and reading.
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[3]	 Once the settings have been made, click the [OK] button.

>>	The data sampled in the trend monitor is written to an external file as a 
log.  
The file name is [core name]_[time stamp].[file extension].  
The time stamp format is “YYYYMMDDhhmmss”. 
The data written to the log file can be read [Offline] later and displayed in 
a graph. 

■■ Other settings
The docking state of each window in the [Universal monitor] window can be saved 
and called up. 

●● Positionally fix window
Select [Window] → [Fixed-position window] from the menu bar of the [Universal 
monitor] window. The docking status, position, and size of each window in 
Universal monitor is fixed. 
Floating windows are locked in the front position even if the [Universal monitor] 
window is moved.
To release a fixed window, select [Window] → [Fixed-position window] again from 
the menu bar of the [Universal monitor] window. 

●● Return windows to standard positions
Select [Window] → [Return to standard position] from the menu bar of the 
[Universal monitor] window. The docking status, position, and size of each window 
in the Universal monitor are returned to standard. 

●● Save current window status
Select [Window] → [Favorite] → [Add to favorites] from the menu bar of the 
[Universal monitor] window. The [Add to favorites] dialog box will be displayed, 
and with the specified name, the window position, size, and docking status will be 
saved. The initial setting is “Favorite”. 
Data is saved in the loader installation folder.

●● Organize items registered to favorites
Select [Window] → [Favorite] → [Organize favorites] from the menu bar of the 
[Universal monitor] window. 
Registered items will be displayed in a list and can be organized (renamed or 
deleted).

●● Call up window docking status registered to favorites
Select [Window] → [Favorite] from the menu bar of the [Universal monitor] 
window and select the name of the window settings to call up.
The window will be displayed in the saved status.
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7  -  7	 Custom Monitoring

The custom monitoring function is used when customizing monitored items. This section explains the editing 
method for custom monitoring and the corresponding operations in universal monitor. Select the [Custom] tab in 
the [Monitor tree] window to monitor items registered to custom monitoring in the Numeric monitor, etc. Also, 
standard items (models) corresponding to the model numbers and the number of modules in use are automatically 
registered in the [Default] tab of the [Monitor tree] window. The items that can be registered to custom monitoring 
vary depending on user level settings. 

■■ [Custom monitor editing] dialog box
To edit custom monitoring, select [Settings]  [Edit monitoring data] from the menu 
bar of the [Universal monitor] window.
>>	The following [Custom monitor editing] dialog box is displayed. 

Edited Data

Monitor Data Tree

Level View

Buttons 
for the Monitor Data Tree

 Handling Precautions
•	 To use content registered to custom monitoring offline (“7-9 Offline”, 7-41), 

register it as a trend (trend group). Settings for numeric monitoring cannot be 
used, or this cannot be used offline even if registered to a monitor. 

●● Monitor data tree
Displays the tree configuration displayed in the [Monitor tree] window of the 
[Universal monitor] window. 

●● Monitor data tree button
The custom levels of the monitor data tree can be edited.

Button Icon Functions
Add category Creates a new category

Enabled when a custom level is selected in the monitor data tree

Add group Creates a new group
Enabled when a category of a custom level in the monitor data tree is 
selected, adds the group to the selected category level

Copy Copies the level and all settings targeted for monitoring of the selected 
category of group. Enabled when a category or group is selected

Paste Pastes the copied category or group information

Delete Deletes the category or group selected in the monitor data tree

Digital trend Sets the items registered to a category or group as a digital trend
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●● Right-click menu for monitor data tree

Menu Submenu Functions Remarks

New Category Creates a new category.
Enabled when a custom level is selected in the 
monitor data tree.

—

Group Creates a new group.
Enabled when a category is selected in the monitor 
data tree, and the group is added to the selected 
category.

—

Copy — Copies the level of the selected category or group 
and the setting items targeted for monitoring.
Enabled when a category or group is selected in the 
monitor data tree.

—

Paste — Pastes the copied category or group information
Enabled when a custom level item is selected in the 
monitor data tree.

—

Change 
name

— Renames the selected category or group.
Selecting a category or group enables editing of the 
name.
Enter the new name and press the [Enter] key.
The name of the category or group is renamed.
Pressing the [ESC] key cancels editing without 
changing the name.

—

Delete — Deletes the category or group selected in the monitor 
data tree.

—

Trend 
monitor 
settings

— Switches whether or not to view in the trend monitor.
The icons of tree items that are set to be viewed in 
the trend monitor are changed, and the background 
color is highlighted in blue.

—

Digital trend Sets or cancels the items registered to a category or 
group as a digital trend.

A check mark on the menu 
indicates that the item is set.

View/Hide — Views or hides the category or group in the [Monitor 
tree] window of the [Universal monitor] window.
When hide is selected (there is no check mark to 
the left of [View/hide] on the right-click menu), the 
applicable level is not displayed in the monitor data 
tree.

—

Register 
trends by 
row

— Enabled when a category is right-clicked in the 
monitor data tree.
The [Trend registration by column] dialog box is 
displayed, and registration to the trend group is 
performed.

See also the [Trend 
registration by column] 
dialog box items.
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●● Edit data
This is enabled by selection of category items (settings, monitors, trends).
Category items are registered as follows.
•	 Settings 

Registered on the [Setting] tab of the [Numeric monitor] window. Registered 
data can be written to modules during monitoring.

•	 Monitor 
Registered on the [Monitor] tab of the [Numeric monitor] window. Registered 
data can be checked during monitoring.

•	 Trend 
Registered on the [Trend group] window, and can be displayed in the [Trend 
monitor] window.

The upper limit for number of data that can be added is 64 for settings and 
monitors and 32 for trends.
To edit setting content, click the [Data] button with a category item (setting, 
monitor, trend) selected, or copy items existing in another category and register 
them. 
Add, delete, or copy data as in ■ [Select data] dialog box (P. 7-36) ,
 or select a row header from the edit data grid in the [Custom monitor editing] 
dialog box, and edit using the right-click menu or the shortcut button.

●● Level display
Currently, levels of the nodes selected in the monitor data tree are displayed.

●● Right-click menu for edit data

Menu Functions Remarks

Copy row Copies one or more selected rows Enabled when a row header is selected
Cut row Cuts one or more selected rows Enabled when a row header is selected
Insert copied row Inserts the copied row data above the selected row Enabled only when copied or cut row 

data exists
Delete row Deletes one or more selected rows Enabled when a row header is selected
Copy column data �Copies the data of the selected cell Enabled when column data or a single 

cell is selected
Paste column data Pastes the copied column data Enabled when column data or a single 

cell is selected

●● Shortcut buttons for edit data
Shortcut buttons that can perform the same operation as the edit data right-click 
menu are displayed.
From the left, the buttons shown below are displayed.
•	 Copy	  button
•	 Cut	  button
•	 Paste	  button
•	 Delete	  button
These buttons are enabled when a row header is selected.
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●● [Data] button
This button is enabled when selecting category items (settings, monitors, trends) in 
the monitor data tree.
Custom data monitor parameters are displayed in the New list of the custom editor.
The range displayed in the [Custom monitor editing] dialog box differs depending 
on user level settings. 
Click the [Data] button. 
>>The [Select data] dialog box is displayed.

 ■ [Select data] dialog box (P. 7-36).
●● [OK] button

Clicking this confirms edited items and data and closes the [Custom monitor 
editing] dialog box. 

●● [Cancel] button
Clicking this discards edited items and data and closes the [Custom monitor 
editing] dialog box. 

■■ [Select data] dialog box
Selecting category items (settings, monitors, trends) in the Monitor data tree of the 
[Custom monitor editing] dialog box and clicking the [Data] button call up the 
[Select Data] dialog box.
Items set in the [Select Data] dialog box are set as monitor display item candidates 
for new registration in relation to the [Custom monitor editing] dialog box 
selection items. 

 Handling Precautions
•	 The items set in the [Select Data] dialog box are display candidates, and 

clicking the [OK] button in the [Custom monitor editing] dialog box confirms 
them as display items. 

Search

Add Data

Tree Monitor

Registered Data List

Delete Data

Move Data

Search Data List Input Text BoxExact Match
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•	 [Tree Monitor] 
Displays data searched for in the database in a tree format.

•	 [Search Data list] 
Displays all data in the levels selected in the tree monitor.

•	 [Registered Data list] 
Displays a list of data registered to items selected in the monitor data tree of the 
[Custom monitor editing] dialog box. 

•	 [Search] 
It is possible to narrow down the data search list with specified conditions 
([Perfect match] check box, [Text box for input]). 

•	 [Exact Match] check box
 : �Displays only data that perfectly match the data in the data search list and 

the text input in the text box.
 : �Displays data in the data search list that include the text input in the text box.

•	 [Input Text Box] 
Character strings for workgroup, category, type, and property can be input.

•	 [Add Data] button 
Adds data selected in the data search list to the registered data list.

•	 [Delete Data] button 
Removes data selected from the registered data list from the registered data list.

•	 [Move Data] button 
Moves data specified in the registered data list up or down. 
Multiple items can be selected.

•	 [OK] button 
Adds items in the registered data list to items selected in the monitor data tree of 
the [Custom monitor editing] dialog box and closes the dialog box. 

•	 [Cancel] button 
Interrupts the operation and closes the dialog box.
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■■ [Trend registration by column] dialog box
Right-clicking a category in the monitor data tree of the [Custom monitor editing] 
dialog box enables the [Register trends by row] menu. Selecting the [Register 
trends by row] menu displays the [Trend registration by column] dialog box, and 
registers the items registered in the [Setting] tab of the [Numeric monitor] of the 
applicable tree level as a trend group. 

Select the row header of the item name and click the [OK] button. 

>>Registered to the monitor data tree as a trend group candidate.
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7  -  8	 Trend Memo

■■ Overview
Trend memo records comments from users and the history of PID parameter 
change.
Trend memo data is linked with a trend log file and saved (The file name is written 
to a trend log in the same way as a PID log).
Trend memos can be recorded by selecting [Record] from the menu bar of the 
[Universal monitor] window or using the right-click menu in the [Trend monitor] 
window. 

■■ Register a trend memo
Trend memos can be registered by selecting [Trend memo registration] from the 
right-click menu in the [Trend] window, or by selecting [Record] → [Trend memo 
registration] from the menu bar of the [Universal monitor] window. 
The [Register Trend Memo] dialog box is displayed. 

 Handling Precautions
•	 Trend memo registration is enabled during monitoring after receiving the 

first trend data. If a trend memo is registered from the menu of the [Universal 
monitor] window, the latest value on the trend graph’s X axis (absolute time) 
is the registration time. 
If registration is done from the right-click menu of the [Trend monitor] 
window, the time at the mouse position will be the registration time.

■■ Display a trend memo
To display a trend memo select [Record (R)] → [Trend Memo List (V)] from the 
menu bar of the [Universal monitor] window, or select [Trend Memo List (V)] from 
the right-click menu of the [Trend monitor] window.
>>	The [Trend memo list] dialog box is displayed.

[Delete selected items] Button

[Close] Button

[Push pin] Button

•	 [Delete selected items] button 
Select one or more row information items and delete them from the trend memo.

•	 [Pushpin] button 
While the pin is pushed in , the [Trend memo list] dialog box will be displayed 
in front on the [Universal monitor] window. 

•	 [Close] button 
Closes the [Trend memo list] dialog box.

Chapter 7. UNIVERSAL MONITOR

7-39



■■ History of PID parameter change
Select groups in Numeric monitor column units and click [History of PID 
parameter change] on the right-click menu.
>>	The [History of PID parameter change] dialog box is displayed. 

The [History of PID parameter change] dialog box displays only data related to the 
selected data.
•	 [Confirm] button 

Allows checking of the PID parameter values for the selected time.
•	  [Close] button 

Closes the [History of PID parameter change] dialog box.
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7  -  9	 Offline

■■ Offline overview
The offline function can be used to redisplay registered past trend graphs and 
numeric data. Graphs from multiple points in the past can also be displayed at the 
same time.

PID logs are log files storing data (settings and monitors) targeted to be displayed in 
the [Numeric monitor] window in a time sequence.
Trend data and PID logs are linked by units of groups or categories.
Read PID logs are displayed in the Numeric monitor window of Universal monitor 
[Offline] window.
In the same manner as online mode, the applicable log of the category selected in 
the [Monitor tree] window is displayed.
You can check the settings of log readouts and recorded PID parameters.

	 Note
•	 The offline function cannot be used to write data to modules.
•	 In the offline function, the values displayed for the numeric monitor are the 

values recorded when the monitor stopped, and the crossline data shows the 
values at the time when perpendicular lines are drawn on the trend graph.

The relationship of files and the writing and reading of log files is as follows.

Trend start Trend stop

Trend log File

PID log File

The PID log �le name is 
the same as the trend log 
�le name.

Records the PID value of 
when the trend is stopped.

Generates a log �le 
and records the PID 
value of when the trend 
is started.

• Writing of log files

Open the log �le

Trend log �le

PID log �le

• Reading of log files
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■■ Log File Conversion
Data collected by the trend monitor is saved to a file as a trend log. For SLP-NX 
version 3 and later, a compressed file called a slog file is usually selected as the 
output file for monitoring results.   Stored trend log files can be converted into 
other file formats. 

To convert a trend log file, select [File] → [Log file conversion] from the [Universal 
monitor] window menu bar.

[1]	 The [Open] dialog box is displayed. Select either of the following file formats 
and the desired file name.
•	 Encrypted log file (*.slog)
•	 Log file (*.tlog)

	 Note

•	 Log file (*.tlog) was the standard file format for SLP-NX Ver. 2 and earlier. It 
is still used for compatibility with older versions.

[2]	 Clicking the [Open] button displays the [Save As] dialog box. Select one of 
the following file formats and the desired file name.
•	 Absolute time (*.csv)
•	 Absolute time (*.xml)
•	 Relative time (*.csv)
•	 Relative time (*.xml)
•	 Log file portability (*.plog)

Chapter 7. UNIVERSAL MONITOR

7-42



[3]	 The selected file is output to the directory specified as the trend log directory.

The following types of log file can be opened in the universal monitor [Offline] 
window.
•	 Log file (*.tlog)
•	 Encrypted log file (*.slog)
•	 Log file portability (*.plog)

The log file portability (*.plog) format, in which trend logs, PID parameter change 
history, and trend memos from the start to the end of monitoring are combined and 
stored in a file, can be used for data sharing, etc. 

■■ Viewing Universal monitor [Offline] window

Tool Bar
Menu

Status Bar

Individual
Categories

[Monitor tree] 
Window

[Trend monitor] 
Window

[Trend group] 
Window

[Bit display monitor] 
Window

[Numeric monitor] Tab

[Crossline data] Tab [Numeric monitor] Window

The name of each window are as follows.
•	 [Monitor tree] window
•	 [Trend monitor] window
•	 [Trend group] window
•	 [Numeric monitor] window
•	 [Crossline data] window
•	 [Bit display monitor] window

	 Note
•	  The names and functions are described in “7  -  3	 Universal Monitor Window 

(P. 7-3)”.
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■■ Window docking functions
The window docking functions are the same as those of the [Universal monitor] 
window.

 n Window configuration operations (P. 7-6)
The docking functions can be set using [Window] from the menu and the mouse 
operations.

■■ Status bar
The following information appears in the status bar.
•	 Monitor time display 

Displays [Offline].
•	 Communication status display 

There is no communication in offline mode. [Wait] is displayed at the right end 
of the status bar.

•	 Zoom status display 
The zoom status display is the same as that in online mode.
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■■ Menu configuration list of the Universal monitor [Offline] window
The menu configuration in offline mode is as follows.

Menu Submenu 1 Submenu 2 Description Remarks

File Log file — Select [Open log file] or [Open log file [multi-
time mode](M)].

—

Log file conversion — Always disabled —

Copy graph to 
clipboard

— Copies the graph displayed in the trend monitor 
to the clipboard.

—

Start control profile — Not supported —

Exit — Closes the Universal monitor [Offline] window. —

Monitor — — Always disabled —

Settings Edit monitoring data — Always disabled —

Communication 
destination 

— Always disabled —

Monitor settings — Configures the display of the trend time on the 
trend monitor.

 ■ Monitor settings dialog box (P. 7-47)

—

Trend color settings — Sets the line types and default colors to use in 
trend graphs.

 ■ Trend monitor color settings (P. 7-30)

—

Options — Always disabled —

Record View trend memo — Displays the [Trend memo list] dialog box.
 7  -  8	 Trend Memo (P. 7-39)

—

Trend memo 
registration

— Always disabled —

Window Fixed-position 
window

— Prohibits floating of windows. Turn ON/OFF by adding/
removing a check mark.

Return to standard 
position

— Returns the position of each window to their 
standard positions.

Enabled only when the 
[Fixed-position window] 
menu item is OFF.

View Monitor tree Displays the [Monitor tree] window. If the window is already 
displayed, it becomes 
active.

Trend monitor Displays the [Trend monitor] window.

Crossline Data Displays the [Crossline data] window.

Trend Group Displays the [Trend group] window.

Numeric monitor Displays the [Numeric monitor] window.

Alarm monitor Always disabled 

Bit display Monitor Displays the [Bit display monitor] window.

Logical operation 
monitor

Always disabled

Favorite — Always disabled —

Help Show help — — Nothing is displayed.

About (version info) — Displays the [Version] dialog box. —
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■■ Reading trend logs
Data collected at different times can be viewed on the same trend group with the 
offline function.
Select [File (F)] → [Log file (L)] → [Open log file (O)] or [File (F)] → [Log file (L)] 
→ [Open log file [Multi-point mode] (M)] from the menu bar of the [Universal 
monitor] window.
When a trend log is read, the Universal monitor [Offline] window is displayed, and 
the data of the applicable log is displayed in the [Trend] window along with the 
trend group.
The date of an offline group data can be superimposed on a trend group in the 
Universal monitor [Offline] window.
When the data is copied, the data for the graph line are also copied.
No data can be added from the Numeric monitor or the Bit display monitor to the 
Trend group in the Universal monitor [Offline] window.
In addition, monitor execution is not possible in the Universal monitor [Offline] 
window.

	 Note

•	 If a log file portability file (*.plog) is opened by selecting  [File] → [Log file] 
→ [Open log file], the following message may appear.

This message will be shown if the trend collection exceeded the number 
of fixed samples set for monitoring so that the trend logs are divided into 
multiple files.

■■ Displaying the numeric monitor
You can check the recorded parameter values.
You cannot edit values displayed on the Numeric monitor, register data by drag and 
drop to a trend group, or write data to modules.
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■■ Monitor settings dialog box
This allows you to change the display settings for the trend graphs that are shown in 
the offline function.

[1]	 Select [Settings] → [Monitor settings] from the menu bar of the [Universal 
monitor] window.

>> The [Monitor settings] dialog box is displayed.

[2]	 The following items are displayed.
•	 [Trend time setting] 

Determines whether the trend graph's X axis shows absolute time or time 
relative to the start of monitoring. The default is absolute time.

•	 [Display time format] 
Sets the format for the time displayed on the trend monitor graph’s X axis. 
The default value is “M/d HH:mm:ss.f ” if the trend time is set for absolute 
time, and “H:m:s.fff ” if the trend time is set for relative time.

•	 [Display time length] 
Sets the time range for data displayed in the graph area. The X axis of the 
trend graph is determined according to the value selected here. The initial 
setting is "Automatic".
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■■ Trend group display
•	 You can move parameters from a group to another by dragging and dropping. 

Once data is moved, it is linked to the destination.

Destination

Drag

Drop

•	 Time axis superimposition 
The X-axis time can be changed and superimposed on another axis. 
Display the [Time axis superposition settings] dialog box from the right-click 
menu of the Trend group.  
According to the log read mode, the format differs depending on whether the 
value of the X axis is an absolute time or relative time. 
You can operate and compare the values in real time.

Absolute time:	 The selected start time is displayed with the time entered.

Relative time:	 The selected start time is displayed with the time entered and shift 
direction.

Both the trends collected at an absolute time and at a relative time are displayed 
with the recording start time of collection as the start point of the [Trend Monitor] 
window.
After a trend log is opened, the graph is shifted at the time interval specified with 
the shift time and shift direction settings.
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Examples of trend graph superimposition

 

➞

 

 

•	 Display PID value on Numeric monitor 
Right-click the group item provided as standard among the trend groups 
and select [Display PID value on numeric monitor] from the submenu. The 
applicable loop is selected in the Monitor tree and the applicable loop value is 
displayed in the Numeric monitor.

■■ Displaying the Bit display monitor
The Bit display monitor information cannot be displayed in offline mode.

■■ Displaying the crossline data
[Crossline data] tab displays the [Crossline data] window. The crossline cursor 
value on the Trend monitor is displayed. 
The window can be switched between floating and docking modes.

 ■ Crossline data window (P. 7-23)
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Chapter 8.	 PID Simulator
8  -  1	 Overview of PID Simulator

■■ Features
PID Simulator, which makes use of Azbil Corporation's proprietary simulation 
technology, provides PID tuning functions and is used with SLP-NX professional 
versions only.
This product has the following features.
•	 Creates a model of the control target with simple operation 

Using the model creation wizard, a model of the control target can be created 
easily.

•	 PID tuning by means of direct user interface 
Users of PID Simulator can adjust the PID using only the mouse. Because the 
control process graph is smoothly updated in response to movement of the 
mouse, the effectiveness of PID tuning can be grasped intuitively.

•	 Checks the effectiveness of functions like Just-FiTTER. 
Before actual operation, users can check the effectiveness of various functions 
including Azbil Corporation's unique control algorithm, Just-FiTTER.

	 Note
•	 A control model expresses in mathematical form the physical phenomena (such 

as heating, cooling, and changes of flow rate or pressure) which occur at the 
actual facility (the control target).
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 Handling Precautions
•	 To use PID Simulator, first install the USB protection key driver. 

 1  -  5	 Installing the USB Protection Key Driver (P. 1-11)
•	 PID Simulator operates only in conjunction with the NX-D25/35. It cannot be 

used for the NX-D15.
•	 PID Simulator results and actual control results may not match depending on the 

characteristics of the equipment (for example, equipment with very strong non-
linear characteristics or a master loop for cascade control).

•	 PID Simulator does not support tuning for cascade control and cooling/heating 
control.

	 Note

•	 “Very strong non-linear characteristics” means that the PV does not bear a 
linear relationship to the MV. Examples of a control target with very strong 
non-linear characteristics include temperature control accompanied by self-
heating when chemicals are mixed, and pH control at the equivalence point.
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■■ Procedure for Tuning using PID Simulator
Adjust PID parameters using PID Simulator as follows.

Operation screen Procedure for tuning Reference chapter
Retrieve PV and MV trend data from the 
equipment during operation.

Chapter 7.	 UNIVERSAL MONITOR
8  -  6	 How to Collect Trend Data (P. 8-23)

Activate PID Simulator to create a 
control model from the collected trend 
data.

8  -  2	 Starting PID Simulator (P. 8-4)
8  -  5	 Creating a Control Model (P. 8-18)

Calculate PID values in a PID control 
simulation.

8  -  3	 PID Simulator window (P. 8-6)
8  -  4	Useful Features (P. 8-13)

Apply the calculated PID values to the 
actual device and examine the control 
result.

Chapter 7.	 UNIVERSAL MONITOR

 Handling Precautions
•	 Due to disturbance or measurement error included in the trend data for 

creating the control model, the control result may not  match the simulation. 
In that case, after taking countermeasures against measurement error and 
disturbance, try the procedure again.
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8  -  2	 Starting PID Simulator

PID Simulator can be activated in the following ways.
●● Direct activation

Select [SLP] → [PID Simulator] from the Windows Start menu. If the program is 
activated in this way, the following restrictions apply to operation.
•	 Trend data cannot be read directly from the universal monitor without using a 

data file.
•	 Parameters cannot be read/written from/to controller modules.

●● Activation from the universal monitor
Right-click on the module name or a loop name under "Module configuration" in 
the monitor tree of the universal monitor. Then select [Start PID Simulator] from 
the menu.

If the program is activated from the universal monitor, it is possible to use not only 
trend data stored in files but also trend data collected by the universal monitor. 

 8  -  6	 How to Collect Trend Data (P. 8-23)
The number of trend data records usable for model creation varies depending on 
the right-click location. In the monitor tree, if the program is activated by right-
clicking the controller module name, the trend data for all loops can be used. If the 
loop name is right-clicked, that loop's trend data can be used. 

	 Handling Precautions

•	 PID Simulator can be activated only when the monitor is not running.
•	 The program can be activated from the universal monitor [Offline] 

window.
•	 Before activating PID Simulator, make sure that the USB protection key 

is securely inserted in the PC. If the PC does not recognize the key, the 
following error message appears. 
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■■ Startup window
When PID Simulator is activated, the [Welcome to PID Simulator] dialog box 
appears. Select a method for creating a control model here. To terminate PID 
Simulator, click the [Cancel] button to close the dialog box.

There are 3 model creation methods, as described below.

●● Creating a model from a data file (*.pdn).
Reading a dedicated data file (*.pdn) activates the model creation wizard.  Or use 
the menu to select [File] → [Create model from data file...]. 

 8  -  6	 How to Collect Trend Data (P. 8-23) 
 8  -  5	 Creating a Control Model (P. 8-18)

●● Reading model data from a model file (*.pmn) 
Reading a model file (*.pdn) which stores model data and simulation data starts 
PID control simulation.  A previous simulation can be resumed by reading a model 
file.
Or, use the menu to select [File] → [Read model from model file...].

●● Creating a model from trend data
Directly loading data which is collected by the universal monitor without using a 
data file activates the model creation wizard.  This method is available only if PID 
Simulator was activated from the universal monitor after the universal monitor 
collected trend data properly.  

 8  -  6	 How to Collect Trend Data (P. 8-23) 
 8  -  5	 Creating a Control Model (P. 8-18)
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8  -  3	 PID Simulator window

This section describes the structure of PID Simulator window.

■■ Menu Bar and Toolbar
The table below describes the menu items and tool buttons.

Menu Button Submenu Description Shortcut Keys

File Create model from 
data file... 

Opens a data file 
(*.pdn) to create a 
control model.

[CTRL]+[M]

Read model from 
model file

Reads a model file 
(*.pmn).

[CTRL]+[L]

Save Model Saves data into an 
existing model file 
(overwriting the old 
file).

[CTRL]+[S]

Save model as... Specify a model file 
name to which to save 
the data.

Save simulation data... Saves the trend data 
(PV) displayed in the 
simulation graph to a 
file in CSV format.

Copy graph to 
clipboard

Copies the simulation 
graph to the 
clipboard.

Convert PDN to CSV Converts a *.pdn data 
file to a CSVfile and 
saves it.

Quit Terminates PID 
Simulator.

[CTRL]+[Q]

View Toolbar Switches the toolbar 
view/hide status.

Show PID Slider Shows or hides the 
PID slider.
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Menu Button Submenu Description Shortcut Keys

Simulation Auto-tuning... Executes auto-tuning [CTRL]+[T]

Options Add current 
parameters to a 
memo... 

Saves the currently 
used parameters to a 
memo.

[CTRL]+[A]

Delete selected memo Deletes the currently 
selected memo.

Rename selected 
memo... 

Changes the name of 
the currently selected 
memo.

Load/Save Parameters Writes parameters 
such as PID values to a 
controller.

[CTRL]+[P]

Graph Auto-adjustment of 
PV axis

Adjusts Y-axis (PV axis) 
automatically.

[CTRL]+[J]

Adjustment of Y-axis... Displays the dialog 
box for adjusting the 
Y-axis (PV/MV axis).

[CTRL]+[Y]

Undo Zoom Undoes the graph 
zoom.

[CTRL]+[U]

Properties... Shows the [Properties] 
dialog box to change 
graph colors. 

Help Version information... Displays PID Simulator 
version information.

The following functions can be used on the toolbar only.

Control Description

Selects a registered memo.
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■■ Simulation Graph Functions
The simulation graph shows the result of PID control simulation. The graph 
includes the following functions.

●● Zoom function
Enlarges the area defined by the mouse. Position the mouse cursor at the top left of 
the desired area to be enlarged. While holding down the left mouse button, drag the 
mouse diagonally to the bottom right of the area. When the button is released, the 
area will be enlarged.

To cancel the zoom operation, press the left mouse button at any point in the graph 
area and keep it pressed, and drag the mouse cursor toward the top left and release 
it at the desired point.

Alternatively, use one of the following methods.
•	 On the menu bar, select [Graph] → [Undo zoom].

•	  Click the button on the toolbar.
•	 Press the [U] key while holding down the [Ctrl] key.

●● SP / initial PV change function
To change the SP or initial PV, position the mouse cursor over the SP slider or the 
initial PV slider on the simulation graph and drag the slider up or down, keeping 
the left mouse button pressed.
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SP slider

Initial PV slider

	 Handling Precautions

•	 When changing a value using the SP slider or the initial PV slider, 
depending on the size of the simulation graph it may not be possible to 
set the desired value (for example, the SP may increase from100 to 102, 
skipping 101). In this case, make the change using the [Parameter] tab.

•	 These sliders are not displayed when the graph is enlarged using the 
zoom function.

•	 The simulation graph update time varies in proportion to the simulation 
period. Set the period length so that it is suitable for practical use.

●● Disturbance setup function
If the [Disturbance setting] tab is selected in the parameter tab, the sliders shown 
below are displayed on the simulation graph so that the disturbance settings can 
be changed. The disturbance start time slider can be moved horizontally and the 
disturbance level slider can be moved vertically.

Disturbance start time slider

Disturbance level slider

	 Handling Precautions

•	 When changing a value using these sliders, depending on the size of 
the simulation graph it may not be possible to set the desired value 
(for example, the disturbance start time may increase from 100 to 102, 
skipping 101). In this case, make the change using the [Parameter] tab.

•	 These sliders are not displayed when the graph is enlarged using the 
zoom function.
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■■ PID slider
Changes the PID using the mouse.
Sliders Slider range setting buttons

Sliders
Slider range setting buttons
The slider ranges can be changed using the buttons.
If one of these buttons is clicked, the maximum value of the slider range increases 
in steps. If the value exceeds the high limit, it returns to the minimum value in 
the setting range. If the [▼] button on the right of the setting button is clicked, the 
following menu appears so that the range can be directly specified.

	 Note

•	 The slider value can be changed using arrow keys. To increase the value, 
press the [↑] or [→] key. To decrease the value, press the [↓] or [←] key. 
Additionally, if the [→], [ ↓ ], [←], or [↑] key is pressed simultaneously with 
the [Shift] key, the amount of increase or decrease is 10 times larger.

•	 When the [→] or [↑] key is used to increase the PID, if the value exceeds 
the high limit of the current range, the range is automatically set to the next 
higher range. When the [↓] or [←] key is used to decrease the PID, if the 
value decreases below the high limit of the next lower range, the current 
range is automatically set to the next lower range. For example, if the 
proportional band has a range of 0.1-200.0 and the value is increased beyond 
200.0 using the [→] or [↑] key, the range automatically changes to 0.1-500.0. 
If the value is decreased below 100.0 using the [↓] or [←] key, the range 
automatically changes to 0.1-100.0.

	 Handling Precautions

•	 If the range is changed to another range whose high limit is smaller than 
the current slider value, the value is forcibly set to the high limit of the 
new range. For example, when the proportional band is set to 150.0 %, if 
the slider range is changed to 0.1-100.0, the proportional band is forcibly 
changed to 100.0 %.

If the slider range is changed, the minimum amount of slider travel (the amount of 
increase/decrease by moving the slider 1 unit) also changes as shown in the tables 
below.
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Proportional band (P)

Setting range 0.1-100.0 0.1-200.0 0.1-500.0 0.1-1600.0

Min. travel 0.5 1.0 5.0 10.0

Setting range 0.1-3200.0

Min. travel 20.0

Integral time (I) / Derivative time (D) 
(when the control parameter has no decimal point)

Setting range 0-100.0 0-200.0 0-500.0 0-1000

Min. travel 1 1 5 5

Setting range 0-2000 0-5000 0-16000 0-32000

Min. travel 10 25 100 200

Integral time (I) / Derivative time (D) 
(when the control parameter has 1 digit after the decimal point)

Setting range 0.0-100.0 0.0-200.0 0.0-500.0 0.0-1600.0

Min. travel 0.5 1.0 5.0 10.0

Setting range 0.1-3200.0

Min. travel 20.0

Integral time (I) / derivative time (D) 
(when the control parameter has 2 digits after the decimal point)

Setting range 0.00-10.00 0.00-20.00 0.00-50.00 0.00-160.0

Min. travel 0.05 0.10 0.50 1.00

Setting range 0.00-320.00

Min. travel 20.0

■■ Parameter tabs
Parameters can be changed using the parameter tabs. There are tree tabs: [Control], 
[Other], and [Disturbance setting].

       
●● Control tab

Sets parameters for control such as the PID and the set point.
●● Other tab

Sets SP ramp parameters as well as the MV change rate limit and the simulation 
period.
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●● Disturbance setting tab
Sets parameters for disturbance simulation.

	 Note

•	 To change parameters, use either of the following methods.
•	 Enter values directly using the keyboard.
•	 Change values using the [→] or [←] key.
•	 If the [→] or [←] key is used, it is possible to increase or decrease values in 

increments of the minimum unit (for example, in the case of 1 digit after the 
decimal point, 0.1). If the [→] or [←] key is pressed simultaneously with the 
[Shift] key, the amount of increase or decrease is 10 times larger.

	 Handling Precautions

•	  Network Instrumentation Module Controller module NX-D15/25/35 
User's Manual of Function (CP-SP-1308E).

•	 PID Simulator does not support SP groups and PID groups.
•	 PID Simulator does not support changing the manual reset value. For the 

manual reset value, the trend data collected by the controller is used.
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8  -  4	 Useful Features

■■ Auto-tuning
This function automatically calculates the PID for the control model.

•	  Click the icon. 
Or, select  [Simulation] → [Auto-tuning... ]. Alternatively, press [Ctrl]+[T]. 

>> The [Auto-tuning] dialog box is displayed.

For PID Simulator, as also for controllers, the auto-tuning type can be chosen from 
the following 3 types.
0: Normal (regular control characteristics)
1: Fast (response to disturbance)
2: Stable (minimal up/down PV fluctuation)

When the [Auto-tuning] dialog box appears, PID Simulator automatically chooses 
and shows the optimum type below "Recommended." To change the PID and 
update the simulation graph, click the [OK] button.

■■ Memo
This function saves all parameters specified on the parameter tabs ([Control], 
[Other], and [Disturbance setting]) as a memo. One memo can store up to 256 
parameters.

●● Memo creation
Adds a memo to the list.

•	  Click the icon. 
Alternatively, select [Options] → [Add current parameters to memo...]. Or, 
press [Ctrl]+[A]. 

>> The [Add a memo] dialog box appears.
Enter the desired name and click the [OK] button.
The memo will be added.
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>> If the name has already been used, a [Confirmation] dialog box appears. 

Click the [Yes] button.

	 Note

•	 To replace an existing memo, select the memo name from the drop-down list 
in the [Add a memo] dialog box. 

●● Memo deletion
Deletes the currently selected memo

•	  Click the icon. 
Alternatively, select [Options] → [Delete selected memo].

>> A [Confirmation] dialog box appears. 

Click the [Yes] button.

●● Memo name change
Changes the name of the currently selected memo
•	 Select  [Options] → [Rename selected memo...] from the menu.
>> The [Rename] dialog box appears. 

Input a new name and click the [OK] button.
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●● Selection of a saved memo
Allows selection of a memo from a list and restoring of parameters 
•	 Select the memo name from the drop-down list on the toolbar.

■■ Simulation Graph Setup 

●● Auto-adjustment of the PV axis
This function automatically adjusts the high and low limits of the PV axis (left 
Y-axis) on the simulation graph to make the PV data on the graph easy to see.

•	  Click the icon. 
Alternatively, select [Graph] → [Auto-adjustment of PV Axis] from the menu. 
Or, press [Ctrl]+[J].

●● Y-axis adjustment
Specifies the display range for the PV-axis (left Y-axis) and the MV-axis (right 
Y-axis) in the simulation graph. 

•	  Click the icon. 
Alternatively, select [Graph] → [Adjustment of Y axes] from the menu. Or, press 
[Ctrl]+[Y].

>>The [Y-axis adjustment] dialog box appears. 

Input the high and low limits for each axis and click the [OK] button.
Clicking the [Default] button resets the high and low limit settings for the PV and 
MV axes to the default. The default minimum and maximum values for the PV 
axis and the MV axis are the high and low limits of the PV range and the high limit 
(110%) and low limit (-10%) of the MV settings, respectively. 
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●● Line color change
Changes the color of lines on the simulation graph.
•	 Select [Graph] → [Properties...] from the menu.
>>The [Properties] dialog box appears.

Press the button located on the right of the desired line. The [Color] dialog box will 
appear.

Specify the color and click the [OK] button, and then click the [OK] button in the 
[Properties] dialog box. The color of the line on the simulation graph will change. If 
the [Default] button in the [Properties] dialog box is clicked, the color of each line 
will be reset to the default.

Chapter 8. RESTRICTIONS AND IMPORTANT NOTES ON USE

8-16



■■ Parameter read/write
This function reads/writes parameters like PID values from/to a controller.

•	  Click the icon. 
Or, select [Options] → [Read/write parameters] from the menu. Alternatively, 
press [Ctrl]+[P].

>>The [Parameter read/write] dialog box will be displayed.

Combo box for 
PID group selection

Combo box for 
loop No. selection

Network Instrumentation 
Module parameter grid

PID Simulator 
parameter grid

To write the PID Simulator parameters listed in the grid to the Network 
Instrumentation Module parameter grid, select a PID group and click the [<Write] 
button. To write the Network Instrumentation Module parameters listed in the 
grid to the PID Simulator parameter grid, select a PID group and click the [Read>] 
button. Clicking the [OK] button sends the parameters that were written to the 
module parameter grid to the controller, or causes the parameters that were written 
to the PID Simulator parameter grid to be read in by PID Simulator. Parameters 
can be written to any PID group in any loop. The PID group and a loop number are 
changed using the combo box for PID group selection and the combo box for loop 
No. selection, respectively.

	 Handling Precautions

•	 If there is a difference in derivative time, integral time, or decimal point 
position between PID Simulator and the Network Instrumentation 
Module, parameter read and write are not possible.

•	 If PID Simulator is directly activated, this function cannot be used. 
•	  8  -  2	 Starting PID Simulator (P. 8-4)
•	 Before using this function, make sure that the PC and controller module 

are connected.
•	 Parameter settings cannot be written unless the universal monitor is 

running. 
To write parameters, activate the universal monitor.

•	 The SP and ramp settings cannot be read or written.
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8  -  5	 Creating a Control Model

This section describes how to create a model for control that is used for PID control simulation, using MV and PV 
trend data collected from the control target.

 8  -  6	 How to Collect Trend Data (P. 8-23)

■■ Model Creation Wizard
A control model can be created easily using PID Simulator's model creation wizard.

●● Start-up methods
There are 3 ways of starting the model creation wizard.
•	 Select [Model from a data file (*.pdn)] in the [Welcome to the PID simulator] 

dialog box.
•	 Select [Model from trend data] in the [Welcome to the PID simulator] dialog 

box.
•	 Or, select  [File] → [Create model from data file] from the menu.

If [Model from trend data] is selected in the [Welcome to the PID simulator] 
dialog box, trend data is read directly from the universal monitor to start the model 
creation wizard. With the other methods of starting the wizard, the [Open data file] 
dialog box is displayed for selection of data files to read.

To start the model creation wizard, enter a pdn file name and click the [Open] 
button.

	 Note

•	  8  -  2	Starting PID Simulator (P. 8-4)
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●● Startup window
When the model creation wizard is activated, the following items are displayed.

Trend data check graph Combo box for loop No. selection

Zoom (data selection) cancel button Model parameter display grid

On this window the user can select a loop and check trend data and parameters. 
On the trend data check graph, the display area can be enlarged or moved. The 
methods of zooming and moving are the same as on the simulation graph.

 8  -  2	 Starting PID Simulator (P. 8-4) To cancel the zoom function, click the 
[Undo zoom] button or press [Ctrl]+[U].
After checking the trend data and parameters, click the [Next] button.

●● Data selection window for model creation
This window is for selection of the area to be used for creating a model from the 
trend data.

Trend data selection graph

Range selection text boxes Zoom (data selection) cancel button

There are 2 methods of determining the trend data range: entering the values into 
the text boxes for range selection, and specifying the range directly using the mouse 
on the trend data selection graph.
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●● Range selection text boxes
The trend data range can be specified by inputting the start and end times into the 
range selection text boxes.

●● Trend data selection graph
Pressing the left mouse button at the left end of the desired selection area shows a 
vertical line that indicates the left end of the area. If the mouse is moved to the right 
while holding down the left mouse button, a vertical line that indicates the right 
end of the area is shown. Move this line to the right end of the desired area and 
release the button.

To cancel the selection, press the left mouse button anywhere on the graph, move 
the mouse to the left while holding down the button, and release the button 
anywhere. Alternatively, click the [Undo zoom] button or press [Ctrl]+[U].

After selecting the trend data range, click the [Next] button.

	 Handling Precautions

•	 Select a trend data range in which the PV and MV of the first 10 data 
records are stable at a constant value. 

 8  -  6	 How to Collect Trend Data (P. 8-23)
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●● Model creation window
When the [Executing...] dialog box appears, model creation starts automatically.

To cancel the operation, click the [Cancel] button in the [Executing...] dialog box.

	 Handling Precautions

•	 If modeling has not been completed, cancellation of modeling disables 
the [Completed] button. In this case, click the [Create new model] button 
to complete modeling.

●● Model creation completion window
When modeling is complete, the following window appears. On this window the 
created control model can be checked.

Model checking graph Model creation start button

"Undo zoom" buttonModel divergence 
display area

Model parameter 
display grid
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●● Model checking graph
Shows the PV and MV trend data that was read from the data file, as well as the 
control model outputs corresponding to the MV.
The graph can zoom in on any area. The zoom and zoom cancel functions operate 
the same way as those on the simulation graph of the main window.

 8  -  2	 Starting PID Simulator (P. 8-4) To cancel the zoom function, click the 
[Undo zoom] button or press [Ctrl]+[U].

●● Model divergence display area
Shows the model divergence (a value that represents the difference in trend data 
between the PV and the model output). The smaller the divergence, the better the 
control model recreates the characteristics of the equipment. As a guideline, model 
divergences are classified as follows.
		 0 to 0.25: Adequate model
		 0.25 to 1.00: So-so model
		 1.00 or more: Inadequate model
In the case of an inadequate model, there could be a large difference in results 
between the PID simulation and the actual control.

	 Handling Precautions

•	 Model divergence is just a guideline and does not guarantee the accuracy 
of a control model or PID control simulation.

●● Model parameter display grid
Shows the control model parameters. This control model can be expressed in the 
transfer function shown below.

		
G (s) =

Kp · e –Lp · s

(1+T
1
· s ) (1+T

2
· s )

		 Kp: Gain
	 T

1
: Primary time constant

	 T
2
: Secondary time constant

	 Lp: Dead time

●● Model creation start button
Executes model creation. Used to resume modeling if it is interrupted or to create a 
model after initializing the current model's parameters.
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8  -  6	 How to Collect Trend Data

■■ Overview
To create a control model, it is necessary to obtain the following MV and PV trend 
data.
•	 Step response when the SP is changed
•	 Step response when the MV is changed
This section describes how to collect the trend data during step response if the SP is 
changed. The procedure is as follows.

•	 Step 1: Specify the initial PV and the SP.
•	 Step 2: Stabilize the PV and MV.
•	 Step 3: Start collecting trend data.
•	 Step 4: Start the step response.
•	 Step 5: Stop collecting trend data.
•	 Step 6: Save the collected trend data.

Use the SLP-NX universal monitor for trend data collection. 
 Chapter 7.	 UNIVERSAL MONITOR

	 Handling Precautions

•	 Follow the steps above very carefully. If trend data collection is not done 
properly, the control result may not match the simulation.

•	 If the sampled data exceeds the specified number of records (10000 
records or 10000 s at a 1 s sampling cycle), the SLP-NX universal monitor 
will create another file and begin again to collect trend data. In this case, 
the data stored in the older file cannot be used for PID Simulator. Take this 
into account.
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■■ Step 1: Specify the initial PV and the SP.
As shown below, the collected trend data must be stable at around a constant value 
and must include the step response when the SP is changed.

SP PV MV

Step
response
SP

Initial PV

For preparations for trend data collection, specify the initial PV (PV under stable 
conditions) and the step response SP so that the following conditions are met.

●● Step response SP
Unless there are restrictions on the step response SP, set the same SP that is used in 
actual operation.

	 Handling Precautions

•	 If the settings for model creation in the trend data differ from those for 
actual operation, the control result may not match the simulation.

●● Initial PV
The initial PV must meet the conditions below.
•	 Use an initial PV with which outputs greater than 0.0 % can be generated 

continuously and steadily.
•	 If the PV is a temperature, use one that is above the ambient temperature.
•	 Configure the initial PV as shown below. 

If the equipment takes the reverse action (heating): 
		 Initial PV < Step response SP. 
If the equipment takes the direct action (cooling): 
		 Initial PV > Step response SP.
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•	 Specify the initial PV using the formula below as a guideline so that the 
difference between the initial PV and step response SP is not too small. 
		 | Step response SP – Initial PV value | 
		 ≥ (5 % of the PV range)  
For example, if the step response SP is 200 and the PV range is –200 to +400, set 
the initial PV to less than 170. 

•	 If the sensor or the actuator has a dead zone (a range that prevents normal 
operation of the equipment), set an initial PV which will not cause the PV or 
MV to enter the dead zone.

■■ Step 2: Stabilize the PV and MV.
Stabilize the PV and MV at around the initial PV value specified in step 1.

●● Guidelines for stable conditions
“Stable conditions” means that variation in the PV and MV are within a certain 
range. As shown below, a guideline for stable conditions is that variation of the MV 
is 10 % or less, and variation of the PV is 1 % or less of the PV range (for example, 6 
or less if the PV range is –200 to +400) in PV.

PV (matching the SP)

MV

1% �

10% �

The following are not suitable conditions for trend data.
•	 Both PV and MV fluctuate greatly.
•	 The PV is almost stable, but the MV fluctuates greatly (by 10 % or more).
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PV

MV

Both PV and MV fluctuate greatly.

PV (matching the SP)
MV

The PV is almost stable, but the MV fluctuates greatly.

●● Stabilizing the PV and MV
If the PV and MV fluctuate, try the following measures.
•	 Make the proportional band larger (2 or 3 times larger than the current value).
•	 Make the integral time larger (2 or 3 times larger than the current value).
•	 Do both of the above.
If the PV and MV still fluctuate, change the loop mode to MANUAL to make the 
PV and MV stable. Then, if the PV and MV behave as shown below, set the MV to 
near the middle between its high and low limits.
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PV

MV

MV in 
MANUAL 
mode

	 Handling Precautions

•	 If the loop mode is changed to MANUAL, allow sufficient time for the PV to 
stabilize.

•	 It is not a problem if the PV differs from the initial PV after the loop mode 
is changed to MANUAL. However, if the conditions for the initial PV stated 
in step 1 are not met, change the MV.

■■ Step 3: Start collecting trend data.
When the PV and MV are stable, select [Monitor] → [Start] from the universal 
monitor menu to start trend data collection. After the monitor has started, collect 
10 or more data records as shown below (for 10 s or more if the sampling cycle is 1 
s) before step response while the PV and MV are stable.

10 or more stable 
data records
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■■ Step 4: Start the step response.
After collecting 10 or more trend data records of the PV and MV, start the step 
response. The step response starting procedure may vary depending on the 
operation mode.

●● In AUTO mode
1. Change the PID values if needed.
2. Change the controller's SP to the step response SP.

●● In MANUAL mode
1.	 Change the PID values if needed.
2.	 Change the controller's SP to the same value as the current PV. For example, if 
the current PV is 60.5 °C, change the controller SP to 60.5.
3.	 Change MANUAL mode to AUTO.
4. Change the controller SP to the step response SP.

	 Note

•	 After the PID values have been changed, the MV or the PV may fluctuate 
until the SP changes. However, if step 3 is complete, that is not a problem.  

	 Handling Precautions

•	 If there are particular PID values connected with a problem to be solved, 
execute the step response using those PID values.
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■■ Step 5: Finish collecting trend data.
When the step response is complete, finish trend data collection. The guidelines for 
completion timing vary depending on the step response result.

●● If overshoot occurs:
As shown below, collect data for 3 times longer than the period when the PV 
reaches the SP after the SP was changed.

●● If hunting occurs:
As shown below, collect data for 3 times longer than the period when the PV 
reaches the SP after the SP is changed.
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●● If the PV is slow to reach the SP:
As shown below, collect data for 3 times longer than the period between the time 
when the SP is changed and the time of intersection of the SP and the tangent of the 
PV immediately after the PV begins to change toward the SP.  

■■ Step 6: Save the collected trend data.
The collected trend data is saved in a data file format specially designed for 
PID Simulator. In the monitor tree of the universal monitor, under Module 
configuration, right-click the controller module name or the loop name to open the 
menu.

To open the [Save As] dialog box, select [Save to a data file].
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Enter a file name and click the [Save] button to save the file.

■■ Summary of the procedure
Steps 3 to 6 are summarized in the table below.

Procedure for trend 
data collection

Universal monitor / numeric monitor operation

AUTO mode MANUAL mode

Start trend data 
collection Start the universal monitor Start the universal monitor

Collection of 10 data 
records under stable 

conditions

SP = current PV
Change PID values if necessary.

Start the step response. Change PID values if necessary.
SP = step response SP

MANUAL → AUTO
SP = step response SP

Step response in 
progress

Finish trend data 
collection

Stop the universal monitor
Save the data

Stop the universal monitor
Save the data
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8  -  7	 Error Messages

■■ PID Control Simulation Error Message
Type Message Description Countermeasures

Function error Auto-tuning was not 
successful.

PID values cannot be 
calculated because auto-
tuning was not successful.

Tune the PID values manually.

Can not add any more notes. The number of saved notes 
exceeds maximum limit.

Remove the unnecessary 
notes.

Internal processing error Process was not successful 
due to lack of memory.

The PC memory is insufficient. Close any applications not 
in use to increase available 
memory.

■■ Data file error
Type Message Description Countermeasures

Data saving error At least 20 data items are 
required.

Sufficient trend data records 
for pdh file creation were not 
collected.

Collect 20 or more trend data 
records.

Either manipulated variable 
(MV) data or process variable 
(PV) data could not be 
collected.

The collected trend data does 
not include MV or PV trend 
data.

Collect both MV and PV trend 
data.

Data read error All trend data values are 
identical.

All PV or MV trend data 
records have the same value.  8  -  6	 How to Collect 

Trend Data (P. 8-23)
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Chapter 9.	‌� RESTRICTIONS AND 
IMPORTANT NOTES ON USE

■■ PC Power Management
In [PC Power Management] (the power conservation function), if the [Turn Off 
Monitor] option has been selected, errors may occur while monitoring using the 
Universal Monitor. 
Do not select the [Turn Off Monitor] option while monitoring. 
In addition, make sure that the hard disk does not go into the hibernation or 
standby mode,

■■ Infrared Devices
If any infrared device is installed on your PC and [Use Infrared Communication] is 
selected, errors may occur while monitoring with the Universal Monitor. 
Do not select the [Use Infrared Communication] option while monitoring.

■■ Restrictions on Using Actual Module Configuration Scan
If modules and external devices are connected via no communication boxes when 
an actual module configuration scan is executed, diagnostic frames (Ethernet 
multicast frames) are sent to the external network for about 6 seconds every 2 msec. 
If any devices other than the module on the external network cannot handle frames 
at that frequency, be sure to install a communication box in between.

■■ Restrictions (IP Addresses) on Using Actual Module Configuration Scan
If an incorrect address has been set in a module using a process other than the 
loader, it may not be possible to scan the actual module configuration correctly.  
Connect to each module individually using a serial port, and perform the actual 
module configuration scan and IP address numbering again. 

■■ Windows Firewall
If you cannot scan the actual module configuration despite a correct network 
connection the loader environment may not be registered correctly with Windows 
Firewall.
If this happens, open the Windows Control Panel, click [Security Center], and 
select [Windows Firewall]. In the displayed [Windows Firewall] dialog box, click the 
[Exceptions] tab and, register the [ICServer.exe] directory path name in the loader 
directory by clicking the [Add Program] button. 
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■■ Prohibited Usage of Compressed Folders
Do not use Windows folder compression. Doing so may cause loader malfunction.

■■ List of Value Limits
Data Unit Limit

Project name and mapping name Characters Not exceeding 20 characters

Workgroup name, node name, and 
chain name

Bytes Not exceeding 16 bytes

Comments Characters 255 characters

Chain ID, workgroup ID, and node ID Range 1 - 65535

No. of project modules No. of modules 31 or less

No. of workgroup modules No. of modules 31 or less

No. of simultaneous trend monitor 
data packets

Data packets 256 or less

1 logging file and No. of image 
samples (No. of fixed samples)

Samples 100 to 60000 or less *1

Monitor cycle Milliseconds 400 msec or more *2

Minimum communication interval Milliseconds 0-1000 *3

Timeout Milliseconds 10-10000 *3

No. of resend times No. of times 0-10 *3

Graph update cycle n times the monitor cycle 1 or more

Alarm cycle Milliseconds Not less than the monitor 
cycle

No. of custom monitor registrations No. of data packets 64 per grid

No. of custom trend registrations No. of data packets 32 per group

No. of trend monitor simultaneous 
displays

No. of trend groups 8

No. of supervisor modules per 
workgroup

No. of modules 1

*1.	 Once a value has reached the upper limit, logging files are moved to a different 
file and the graph display is cleared. Samples may not be created to a maximum 
number depending on environment factors such as the PC load and the 
number of modules.

*2.	 Data sampling may not be performed in accordance with the monitor cycle 
setting, depending on environment factors such as the PC load and the number 
of modules. 
The recommended monitor cycle settings according to the number of modules 
are shown below.  
Recommended settings:
(for Ethernet communication)
	 1 module	 : 400 msec
	 2-4 modules	 : 1 sec
	 5-16 modules	 : 2 sec
	 17 modules or more	 : 4 sec
(for loader jack communication)
			   2000 msec

*3.	 These are the settings for loader communication (Ethernet and serial). 
(The parameter read/write timeout values are fixed at Ethernet: 50 sec and 
Serial: 40 sec)
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■■ Monitoring of Modules with Error Status through Universal Monitor
If normal modules are combined with abnormal modules (unable to communicate 
with the loader) in the [Trend group] window in the [Universal monitor] window, 
change the settings so that data is not sampled for abnormal modules. If the system 
is trying to sample data for modules that cannot be communicated with, many 
timeouts will occur. This will affect communication (monitoring) with normal 
modules. The communication status displayed in the status bar in the [Universal 
monitor] window will alternate between [OK] and [Break].

■■ Coexistence with Virus Security Software
If your PC is installed with security software that has functions such as personal 
firewalls, loader Ethernet communication will be limited and it may not be possible 
to read/write module parameters or execute monitoring through the Universal 
Monitor.
If you do not disable the Windows Firewall function or stop security software 
operations when using the loader, unexpected errors might occur.
However, if you do disable firewall functions or stop security software, you need 
to consider the risk of computer viruses penetrating the system. We ask you to 
carefully consider this risk and assume full responsibility for any actions that you 
take. 
Azbil Corporation is not responsible for any damages or errors that occur as a result 
of changing these settings. 

■■ Communication Boxes for Ring Communications in Chain Connections
Communication boxes for ring communication in a chain connection are displayed 
in the [Module configuration] window using the actual module configuration 
scan function in the loader. Communication boxes, terminal adapters, and 
communication adapters not used for ring communication in a chain connection 
are not displayed in the [Module configuration] window.

■■ Write Errors in Actual Module Communication Settings Using Saved Projects
Projects that have acquired module configuration information read the MAC 
address information in actual devices. If you want to write actual module 
communication settings or replace a module that has failed when there are 
multiple sets of modules with the same configuration, perform an actual module 
configuration scan in the [Actual module configuration] window.
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■■ When PC Has Multiple User IDs with Administrator Privileges
If a PC has multiple user IDs with administrator privileges (administrator group), 
an error might be displayed when a different user ID with administrator privileges 
is used to log on to the PC and to run the loader.
Error message examples:	 Failed to create new (1) 
		  Failed to open system database (401) 
		  Failed to connect to database (411)
When there are multiple user IDs with administrator privileges, specify the user ID 
with administrator privileges to log on to the PC and to use the loader.

■■ When PC Has Multiple Network Interface Cards of the Same Type
(Restriction only for version 2 and earlier)
If multiple network interface cards of the same type are installed in the PC, or a 
network interface card have multiple ports, the loader cannot be used.

■■ Prohibition of network setting changes while SLP-NX is running
While SLP-NX is running, please do not modify the computer’s network settings 
such as IP address, etc.

■■ Prohibition of file creation in the SLP-NX log directory
SLP-NX creates a log directory in the SLP-NX installation directory. Seven days 
after it is created, the log directory is automatically deleted. Do not create any files 
manually in the SLP-NX log directory because doing so may cause an error in the 
automatic deletion process.

■■ Access rights for the installation destination folder
The SLP-NX installer checks beforehand whether the user has the appropriate 
access rights for the folder selected as the installation destination. If not, the user is 
prompted to use a different folder.

■■ Changing the IP Address, etc. of a Module That Is Using Data Transfer Function 
between Modules or Multi-Loop Cooperative Control

The following precaution applies when changing an IP address, node ID, 
workgroup ID or chain ID communication setting after setting data transfer 
function between modules or multi-loop cooperative control for a module.
Data transfer between modules and multi-loop cooperative control create internal 
parameters that are linked to the IP address, node ID, workgroup ID and chain ID.
After writing the communication settings to the module, be sure to execute 
parameter writing.
When using data transfer function between modules or multi-loop cooperative 
control, after changing the IP address, node ID, workgroup ID and chain ID, 
write to the communication setting module, and then continue and write to 
the parameter module. If parameter reading is done before parameter writing, 
inconsistencies may occur in the settings for data transfer function between 
modules or multi-loop cooperative control, resulting in unintended operations.
If inconsistencies occur in cooperative control, a message stating, "The 
corresponding module does not exist in the project database", is displayed 
during parameter writing, and a message stating, "Cannot monitor Control 
Group 1 because there is inconsistent information in the control group settings 
of cooperative control", is displayed during monitoring. In data transfer function 
between modules, a message stating, "The destination module cannot be found for 
a communication setting. Do you want to clear the setting?" is displayed during 
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parameter writing. If such a message is displayed, redo the settings of cooperative 
control or data transfer function between modules, and then write the parameters 
to the module again.
If required, read out the module parameter settings before changing the 
communication settings.

■■ Precautions for Module Replacement
If a module is replaced because of a module failure or some other reason, and 
immediately afterwards reading or writing is done, communications may fail.
This is because updating related to the computer’s MAC address and IP address 
takes several minutes.
After replacing a module, wait several minutes before restart.
Also, after replacing a module, do an actual module configuration scan, and restore 
the actual module communication settings and various parameter settings to their 
state before replacement.

■■ Decimal Point Position in the Universal Monitor
When values from controller module ROM version 1.xx are displayed in the 
universal monitor, the numeric data is fixed at two digits after the decimal point.
Beginning with controller module ROM version 2.00, numeric data is displayed 
according to the decimal point position setting.

■■ Changing the Number of Loops for the Control Module Used in Multi-Loop 
Cooperative Control

Do not change the number of loops for the controller module used in multi-loop 
cooperative control.
If a change of the number of loops is required, change the number first and redo the 
control group configuration for multi-loop cooperative control, and then execute 
parameter writing for the supervisor module and controller module.

■■ Precautions for Default Gateway Configuration
Do not set the default gateway for multiple network interface cards when a network 
profile is configured.
If any network interface card is set to "Obtain an IP address automatically" (the 
Windows default setting), do not set the default gateway for any other network 
interface card.

■■ Coexistence with network changeover software
If the PC is installed with network changeover software that can store and switch 
IP addresses, it may not be possible to read/write module parameters or execute 
monitoring through the universal monitor because IP address modification by the 
loader is limited.
If network changeover software is running when the loader is used, an unexpected 
error may occur.

■■ Precautions for Setting Font Size for Windows
If “Medium-125 %” or “Large-150 %” is set for “Display” in “Control Panel” in 
Windows, some window cannot be displayed normally (the right edge or the 
bottom will be hidden.) In this case, set "Smaller-100 % (default)" and use the 
loader.
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■■ Use of Multiple USB Loader Cables
If multiple USB loader cables are used, they cannot be identified separately on the 
screen.
If the loader does not work when multiple USB loader cables are connected, try 
changing the cables.

■■ Installation of Professional and Standard Versions on the Same PC
The standard SLP-NX and the SLP-NX Professional cannot be installed on the same 
PC.
If the professional version is installed on a PC on which the standard version has 
already been installed or vice versa, temporarily uninstall the loaders using [Add or 
Remove Programs] and then install the desired loader.
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Appendix
Appendix - 1 Explanation of Terminology

Project
File

Read only for Model No.

Parameter
Basic

Input-output
SP

Event
PID

Function
Others

Settings related to 
communications

IP address
Node ID
Chain ID

(Workgroup ID)
Communication settings

(RS-485, etc.)

Module de�nitions
Model No.*, name

Module
*Controller module

Parameter
Basic

Input-output
SP

Event
PID

Function
Others

Parameter
Monitor

Standard bit/number
AUTO/MANUAL

RUN/READY
etc.

Actual module communication settings
IP address, node ID, chain ID (workgroup ID), 

communication settings (RS-485, etc.)

Startup (universal monitor is activated according to mapping information)

Actual module con�guration window

SLP-NX Project window

Trend/number/bit display/alarm monitor

Universal monitor window

Module de�nitions
Model No., name

Module de�nitions
Model No., name

Write

Open

Actual module
Con�guration scan

Parameter
write

Parameter
read

Start
monitoring

Mapping information
IP address
Node ID

(Chain ID)
Workgroup ID

Communication settings
(RS-485, etc.)

Custom

 MappingOverrite after
scanning

Save

Project An item handled by the loader, such as the parameter settings for modules, is 
called a Project.

Workgroup A group of modules handled by the loader is called a Workgroup. Each 
workgroup is assigned a unique number that is known as the Workgroup ID. 
The workgroup is a logical grouping of modules.

Chain A group of modules physically connected in a daisy chain is called a Chain. 
Each chain is assigned a unique number that is known as the Chain ID.
Multiple chains are separated using devices such as communication boxes.

Actual Module Communication 
Settings

Ethernet communication settings and RS-485 settings such as IP addresses for 
actual modules are called Actual Module Communication Settings.
Communication settings for modules are scanned and written to modules 
through the [Actual module configuration] window.

Mapping Associating a module configured in a workgroup with an actual module is 
called Mapping.

Node ID A Node ID is an identifier for each module when the data transfer function 
between modules is used.

Parameter The settings required to operate modules are called Parameters.

Node Address An ID that combines the Workgroup ID and Node ID is called a Node 
Address.
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Appendix - 2 Version History

This section describes the functions added and the specifications changed for the new version.

■■ Version 2.00 (support start date: January 2011)

●● Added functions

Description

Support for NX-DX1/DX2

Support for NX-S11/S12/S21

A logical operation window

A line graph window

[Data sampling switchover] check box in the monitor tree window of the universal monitor

[Module communication status] icon in the monitor tree window of the universal monitor

Date and time setting change function for the supervisor module in the universal monitor

Flash ROM backup and restore function for the supervisor module in the universal monitor

●● Specification changes

Description

Changed so that a reset occurs only when required during parameter writing if the NX-D15/D25 ROM version is 2.00 or 
later.

■■ Version 3.00 (support start date: April 2012)

●● Added functions

Description

Compatible with Windows 7

PID Simulator

Support for NX-D35

Support for NX-DY1/DY2

[List for data transfer between modules] window.

Module version processing (Reading Parameters, Writing Parameters, [Compare module versions] dialog box, and offline 
version change using [Change module version] dialog box)
[Logical operation monitor] window added to the universal monitor

●● Specifications change

Description

SQL Server 2008 Express SP1 was changed to SQL Server 2008 Express SP3.

Compatible with functional extension of NX-D15/D25/DX1/DX2/S21 
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■■ Version 4.00 (available June 2013)

●● Added functions

Description

Support for NX-S01

●● Specifications change

Description

Compatible with functional extension of NX-D15/D25/D35/S11/S12/S21

■■ Version 4.01 (available Aug. 2015)

●● Added functions

Description

Compatible with Windows 8.1

■■ Version 5.00 (avaliable: Mar.2017)

●● Added functions

Description

Compatible with Windows 10
.NET Framework 3.5.1 → 4.6.2
SQL Server 2008 Express → 2014 Express Local DB SP2
File extension was changed from SLX to SLX2 (no compatibility with SLP-NX 4.01 and earlier versions).
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Appendix - 3 Loader Support Corresponding to Module Versions

The table below shows loader support corresponding to module versions.

NX-D15/D25 NX-D35 NX-DX1/DX2 NX-DY1/DY2 NX-S11/12/21

SLP-NX  
Version 1

1_0_0 Unsupported Unsupported Unsupported Unsupported

SLP-NX  
Version 2

1_0_1 Unsupported 2_0_0 Unsupported 1_0_0

SLP-NX  
Version 3

1_0_3 1_0_3 2_0_1 1_0_0 1_0_2

SLP-NX  
Version 4 ~

1_0_4 1_0_4 2_0_1 1_0_0 1_0_3

Module
Version

1_0_0
1_0_1
1_0_2
1_0_3
1_0_4

1_0_3
1_0_4

2_0_0
2_0_1

1_0_0 1_0_0
1_0_1
1_0_2
1_0_3
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Revision History

Printed Edn. Revised pages Description

Aug. 2010 1
Jun. 2011 2 Overall revision
Apr. 2012 3 A new model (NX-D35) was added. Fully revised due to function enhance-

ments.
June 2013 4 The 4th Engl. ed. corresponds to the 4th Jp. ed.
Sep. 2015 5 ii

1-2

1-4
1-11

1-11 to 1-17
1-12 to 1-17
1-18

3-8
5-10
7-12
9-5
App-3
App-4
End of the manual

The Role of This Manual section was changed.
The table in the System Requirements section was changed. The Handling 
Precautions section was changed.
Windows XP → Windows 7
The Handling Precautions section was changed: "Windows XP" was delet-
ed, and "Windows 7" was changed to "Windows 7/8."
Descriptions and images were changed.
Old pages 1–12 to 1-16 became pages 1–12 to 1-17.
"Windows XP (32-bit)" was deleted, and "Windows 7" was changed to 
"Windows 7/8."
A handling precaution was added.
A note was added.
Descriptions were added to the "Settings tab and Monitor tab" section.
Windows 7 → Windows 7/8.1
■ Version 4.01 (available Aug. 2015) was added.
The note was deleted.
The version of Terms and Conditions was updated to AAS-511A-014-05.

Feb. 2016 6 i
1-6
End of the manual

Explanation about customer registration card was deleted.
The explanation was deleted.
AAS-511A-014-06

Apr. 2017 7 1-2

6-66
App-3
End of the manual

■ System Environment table was changed. 
A handling precaution was changed.
The explanation was added.
■ Version 5.00 (avaliable: Feb.2017) was added.
AAS-511A-014-09



Terms and Conditions
We would like to express our appreciation for your purchase and use of Azbil Corporation's products. 
You are required to acknowledge and agree upon the following terms and conditions for your purchase of Azbil Corporation's 
products (system products, field instruments, control valves, and control products), unless otherwise stated in any separate 
document, including, without limitation, estimation sheets, written agreements, catalogs, specifications and instruction manuals. 

1.	 Warranty period and warranty scope
1.1	 Warranty period

Azbil Corporation's products shall be warranted for one (1) year from the date of your purchase of the said products or 
the delivery of the said products to a place designated by you.

1.2	 Warranty scope
In the event that Azbil Corporation's product has any failure attributable to azbil during the aforementioned warranty 
period, Azbil Corporation shall, without charge, deliver a replacement for the said product to the place where you 
purchased, or repair the said product and deliver it to the aforementioned place. 
Notwithstanding the foregoing, any failure falling under one of the following shall not be covered under this warranty: 

(1)	 Failure caused by your improper use of azbil product  
(noncompliance with conditions, environment of use, precautions, etc. set forth in catalogs, specifications, 
instruction manuals, etc.); 

(2)	 Failure caused for other reasons than Azbil Corporation's product;
(3)	 Failure caused by any modification or repair made by any person other than Azbil Corporation or Azbil 

Corporation's subcontractors;  
(4)	 Failure caused by your use of Azbil Corporation's product in a manner not conforming to the intended usage of 

that product; 
(5)	 Failure that the state-of-the-art at the time of Azbil Corporation's shipment did not allow Azbil Corporation to 

predict; or 
(6)	 Failure that arose from any reason not attributable to Azbil Corporation, including, without limitation, acts of God, 

disasters, and actions taken by a third party. 
Please note that the term “warranty” as used herein refers to equipment-only-warranty, and Azbil Corporation shall not 
be liable for any damages, including direct, indirect, special, incidental or consequential damages in connection with or 
arising out of Azbil Corporation's products. 

2.	 Ascertainment of suitability 
You are required to ascertain the suitability of Azbil Corporation's product in case of your use of the same with your 
machinery, equipment, etc. (hereinafter referred to as “Equipment”) on your own responsibility, taking the following 
matters into consideration: 

(1)	 Regulations and standards or laws that your Equipment is to comply with.
(2)	 Examples of application described in any documents provided by Azbil Corporation are for your reference 

purpose only, and you are required to check the functions and safety of your Equipment prior to your use. 
(3)	 Measures to be taken to secure the required level of the reliability and safety of your Equipment in your use 

Although azbil is constantly making efforts to improve the quality and reliability of Azbil Corporation's 
products, there exists a possibility that parts and machinery may break down. 
You are required to provide your Equipment with safety design such as fool-proof design, *1 and fail-safe 
design*2 (anti-flame propagation design, etc.), whereby preventing any occurrence of physical injuries, fires, 
significant damage, and so forth. Furthermore, fault avoidance, *3 fault tolerance,*4 or the like should be 
incorporated so that the said Equipment can satisfy the level of reliability and safety required for your use. 

*1. A design that is safe even if the user makes an error. 
*2. A design that is safe even if the device fails. 
*3. Avoidance of device failure by using highly reliable components, etc. 
*4. The use of redundancy. 

3.	 Precautions and restrictions on application 
Azbil Corporation's products other than those explicitly specified as applicable (e.g. azbil Limit Switch For Nuclear Energy) 
shall not be used in a nuclear energy	controlled area (radiation controlled area). 
Any Azbil Corporation's products shall not be used for/with medical equipment. 
The products are for industrial use. Do not allow general consumers to install or use any Azbil Corporation's product. 
However, azbil products can be incorporated into products used by general consumers. If you intend to use a product for 
that purpose, please contact one of our sales representatives. 
In addition, 
you are required to conduct a consultation with our sales representative and understand detail specifications, cautions 
for operation, and so forth by reference to catalogs, specifications, instruction manual, etc. in case that you intend to use 
azbil product for any purposes specified in (1) through (6) below. 
Moreover, you are required to provide your Equipment with fool-proof design, fail-safe design, anti-flame propagation 
design, fault avoidance, fault tolerance, and other kinds of protection/safety circuit design on your own responsibility to 
ensure reliability and safety, whereby preventing problems caused by failure or nonconformity. 

(1)	 For use under such conditions or in such environments as not stated in technical documents, including catalogs, 
specification, and instruction manuals 

(2) 	For use of specific purposes, such as: 
*	� Nuclear energy/radiation related facilities  

[For use outside nuclear energy controlled areas] [For use of Azbil Corporation's Limit Switch For Nuclear 
Energy] 

*	 Machinery or equipment for space/sea bottom 
*	 Transportation equipment 
	 [Railway, aircraft, vessels, vehicle equipment, etc.] 
*	 Antidisaster/crime-prevention equipment 



*	 Burning appliances 
*	 Electrothermal equipment 
* 	Amusement facilities 
*	 Facilities/applications associated directly with billing 

(3)	 Supply systems such as electricity/gas/water supply systems, large-scale communication systems, and traffic/air 
traffic control systems requiring high reliability 

(4)	 Facilities that are to comply with regulations of governmental/public agencies or specific industries 
(5)	 Machinery or equipment that may affect human lives, human bodies or properties 
(6)	 Other machinery or equipment equivalent to those set forth in items (1) to (5) above which require high reliability 

and safety 

4.	 Precautions against long-term use 
Use of Azbil Corporation's products, including switches, which contain electronic components, over a prolonged period 
may degrade insulation or increase contact-resistance  and may result in heat generation or any other similar problem 
causing such product or switch to develop safety hazards such as smoking, ignition, and electrification.
Although acceleration of the above situation varies depending on the conditions or environment of use of the products, 
you are required not to use any  Azbil Corporation's products for a period exceeding ten (10) years unless otherwise 
stated in specifications or instruction manuals. 

5.	 Recommendation for renewal
Mechanical components, such as relays and switches, used for Azbil Corporation's products will reach the end of their life 
due to wear by repetitious open/close operations. 
In addition, electronic components such as electrolytic capacitors will reach the end of their life due to aged deterioration 
based on the conditions or environment in which such electronic components are used.
Although acceleration of the above situation varies depending on the conditions or environment of use, the number of 
open/close operations of relays, etc.  as prescribed in specifications or instruction manuals, or depending on the design 
margin of your machine or equipment, you are required to renew any Azbil Corporation's products every 5 to 10 years 
unless otherwise specified in specifications or instruction manuals.
System products, field instruments (sensors such as pressure/flow/level sensors, regulating valves, etc.) will reach the end 
of their life due to aged deterioration of parts.
For those parts that will reach the end of their life due to aged deterioration, recommended replacement cycles are 
prescribed. You are required to replace parts based on such recommended replacement cycles. 

6.	 Other precautions
Prior to your use of Azbil Corporation's products, you are required to understand and comply with specifications (e.g., 
conditions and environment of use), precautions, warnings/cautions/notices as set forth in the technical documents 
prepared for individual Azbil Corporation's products, such as catalogs, specifications, and instruction manuals to ensure 
the quality, reliability, and safety of those products. 

7.	 Changes to specifications 
Please note that the descriptions contained in any documents provided by azbil are subject to change without notice for 
improvement or for any other reason.
For inquires or information on specifications as you may need to check, please contact our branch offices or sales offices, 
or your local sales agents. 

8.	 Discontinuance of the supply of products/parts
Please note that the production of any Azbil Corporation's product may be discontinued without notice. 
For repairable products, we will, in principle, undertake repairs for five (5) years after the discontinuance of those 
products. In some cases, however, we cannot undertake such repairs for reasons, such as the absence of repair parts.
For system products, field instruments,  we may not be able to undertake parts replacement for similar reasons. 

9.	 Scope of services 
Prices of Azbil Corporation's products do not include any charges for services such as engineer dispatch service. 
Accordingly, a separate fee will be charged in any  of the following cases: 

(1)	 Installation, adjustment, guidance, and attendance at a test run 
(2)	 Maintenance, inspection, adjustment, and repair
(3)	 Technical guidance and technical education 
(4)	 Special test or special inspection of a product under the conditions specified by you

Please note that we cannot provide any services as set forth above in a nuclear energy controlled area (radiation 
controlled area) or at a place where the level of exposure to radiation is equivalent to that in a nuclear energy controlled 
area. 
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